1. Are you ready for the Galaxy S20? Here is everything we know so far!

Tips USB OTG not working

Discussion in 'Android Devices' started by scottishscott, Jul 14, 2013.

  1. scottishscott

    scottishscott Newbie
    Thread Starter

    Hello all, I have an S3 and have been trying to transfer music from my phone to a flashdrive. I bought a OTG and it would just say connected them immediately say disconnected. I have since bought two more OTG'S, but having same results. I have also tried different flashdrives. I am running Android version 4.1.2
     

    Advertisement

  2. spagman72

    spagman72 Member

    Do you have the Samsung phone drivers installed?
    If Yes, try uninstalling and reinstalling them...then reboot the computer.
    If you have Kies installed make sure it's not running by killing it in Task manager..( they conflict)
    Try a different USB port.... do not use a USB hub, If you can test it on another computer.
     
  3. Rxpert83

    Rxpert83 Dr. Feelgood

    Is the phone rooted?

    I'm not sure if Samsung's kernel supports OTG out of the box
     
    funkylogik likes this.
  4. funkylogik

    funkylogik share the love peeps ;)

    Is OTG that adaptor that turns the micro usb into a usb?
     
  5. scottishscott

    scottishscott Newbie
    Thread Starter

    I'm sorry. I wasn't clear. Ive got one of those 4-5" otgs. I plug it in the phone and then plug the flasdrive in the other end. Like I said, it connects for a second and then disconnects.
     
    funkylogik likes this.
  6. Ramer84015

    Ramer84015 Well-Known Member

    That's what I thought you meant in the OP. You say you plug in the OTG cable and then plug in the flashdrive. Try having the flashdrive already attached to the OTG cable when you plug it in. I use mine on both my phone and my Nexus 7. With the phone (rooted), it automatically detects it and brings up "My Files". I'm not sure if that's standard or because I'm rooted. On the other hand, on my rooted Nexus 7, I still have to run an app from the playstore to make it work. It's not required on my phone. Again, I'm not sure if it's my rom (TPR) but I don't think so. You mentioned that you've tried different cables, are they from different sources?
     
    funkylogik likes this.
  7. Rxpert83

    Rxpert83 Dr. Feelgood

    Yes, so you can hook a flash drive to your phone and use it as storage
     
    funkylogik likes this.
  8. Ramer84015

    Ramer84015 Well-Known Member

    I've also found another trick for it. You can plug in a USB dongle for a wireless keyboard/mouse and it works with that too :)
     
    Rxpert83 and funkylogik like this.
  9. Rxpert83

    Rxpert83 Dr. Feelgood

    Very interesting!:thumbup:
     
  10. funkylogik

    funkylogik share the love peeps ;)

    Wonder what other cool things u can do.. like could you plug in a printer lol?
     
  11. ImgBurn

    ImgBurn Member

    Rxpert83 and funkylogik like this.
  12. funkylogik

    funkylogik share the love peeps ;)

    Is that your vid bro?
     
    ImgBurn likes this.
  13. ImgBurn

    ImgBurn Member

    Hey Funky,


    Hope everything's well with you.:)

    I just picked these vids cause they seemed
    to follow the flow of discovery of this discussion.
    This guy seems like he's just questioning and
    learning like us. Thought it would be helpful.:idea:

    No It's not me.
     
    funkylogik likes this.
  14. funkylogik

    funkylogik share the love peeps ;)

    Thanx man. Aww i wanted to hear your voice lol :p:beer:
     
    ImgBurn likes this.
  15. scottishscott

    scottishscott Newbie
    Thread Starter

    Yes, they are all from different sources. I even bought a f/f usb adapter. I figured I could use it on the oem charge cord. No luck though. I did get one to work last night. I turned on usb debugging and it worked. Only problem I have to hold it in a
    awkward configuration or it disconnects. My phone is not rooted though. Don't know if I should really do that. Is it worth doing?
     
  16. bobb050

    bobb050 Member


    I am not an expert, as some of the others on here are, but it sounds to me like you might have a faulty connector on your phone. I can't think of another reason why holding it an awkward configuration would help.

    Bob
     
  17. ThatOneRearEnd

    ThatOneRearEnd Well-Known Member

    I use a generic adapter and so far it works with almost everything connected... Joysticks, printers, etc...
    It could be a faulty adapter in your case. You should try it with another one or use this one on another phone to be sure...
     
    ImgBurn likes this.
  18. scottishscott

    scottishscott Newbie
    Thread Starter

    Yeah I was thinking the same thing.
     
  19. Ramer84015

    Ramer84015 Well-Known Member

    I agree with everyone else too, sounds like a faulty, maybe worn or loose connector. Do you have any problems when charging the phone? Does the connection feel secure?

    As far as rooting, that's a decision only you can make. Are there any apps you really want to use that require root access? Do you have other devices that only have wi-fi that you want to use your phone to connect to the internet? Do you have the itch to try another rom? That's only some of the things you can do when you're rooted. Although, as a disclaimer, get your OTG-USB issue resolved first, in case you have to deal with a possible warranty issue.
     
  20. BynoUK

    BynoUK Android Enthusiast

    Ignore, wrong thread.
     
  21. sleeco

    sleeco Well-Known Member

    Can you try it on another phone?
     
  22. HighSierra

    HighSierra Member

    I have a similar issue with my OTG connector. I think it is loose in the phone port. If I hold is so it doesn't move I have no issue, but sometimes if I move the phone it stops working.
     
Loading...

Share This Page

Loading...