1. Download our Official Android App: Forums for Android!

Support USB stuck in charge only

Discussion in 'Android Help' started by Huawei P8, Feb 28, 2016.

  1. Huawei P8

    Huawei P8 Guest
    Thread Starter
    Rank:
    None
    Posts:
    0
    Joined:

    Hi everyone,

    Need some help here please. Starting off, I'm using a Huawei P8 great phone just stuck at the moment. Basically few months back in the notifications pull down when you connect your phone via USB cable it gives you the option to have charge only, PTP and MTTP if I remember rightly (correct me if I'm wrong). And well I selected charge only because I only wanted to charge the phone whilst connected to my college computer. Few days after I decided to transfer to pictures over from my recent holiday to the PC, only to find there was no drop down option appearing (automatically choosing charge only) could someone please help me change this and get the options back when I connect my phone via USB. *also side note I tried USB debugging but it's greyed out for some reason :(

    Thanks in advance
     

    Advertisement

  2. mikedt

    mikedt 你好
    Rank:
     #6
    Points:
    2,238
    Posts:
    24,947
    Joined:
    Sep 22, 2010

    Sep 22, 2010
    24,947
    13,918
    2,238
    Teachaaa
    Jinan, China
    If you're using Windows, I take it it's not doing any USB connection/disconnection sounds and taskbar indications, like "USB device connected". Are you using the same USB cable as before, when it worked? If you are, check it anyway, try another cable. Also be aware if you are using a different cable, some usually cheapo USB cables might be wired for charging only, and NOT data transfers.
     
    #2 mikedt, Feb 28, 2016
    Last edited: Feb 28, 2016
    LV426 and Dannydet like this.
  3. LV426

    LV426 I say we take off and nuke this place from orbit
    Moderator
    Rank:
     #11
    Points:
    1,988
    Posts:
    7,634
    Joined:
    Oct 16, 2015

    Oct 16, 2015
    7,634
    11,034
    1,988
    Male
    Software developer
    South West of England
    Agree, almost certainly the cable. In fact I had this exact problem last night with my Nexus 5. Connected using a USB cable I hadn't used before, and got no option on the phone to select data transfer mode. Tried a different cable, and back to normal.
     
    mikedt likes this.
  4. liam97

    liam97 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    7
    Joined:
    Feb 28, 2016

    Feb 28, 2016
    7
    0
    5
    Hi OP here, yes that's exactly the case. The phones getting no notifications or anything when connecting to my PC. I've tried multiple cables all if which were from either previous phones or family's latest phone. So is there any other suggestions because I really can't be arsed to factory reset my phone:(
     
  5. Jfalls63

    Jfalls63 Android Expert
    Rank:
     #30
    Points:
    818
    Posts:
    4,201
    Joined:
    May 15, 2015

    May 15, 2015
    4,201
    3,149
    818
    Male
    Electrician
    Satsuma,Alabama
    Could USB debugging be grayed out because developer options are turned off?
    In most newer devices you have to turn developer options on before you can make other selections.
     
  6. liam97

    liam97 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    7
    Joined:
    Feb 28, 2016

    Feb 28, 2016
    7
    0
    5
    Any idea on how to do this on the Huawei P8?
     
  7. Jfalls63

    Jfalls63 Android Expert
    Rank:
     #30
    Points:
    818
    Posts:
    4,201
    Joined:
    May 15, 2015

    May 15, 2015
    4,201
    3,149
    818
    Male
    Electrician
    Satsuma,Alabama
    Screenshot_20160228-194214.png Not sure on Huawei buton most new devices to unlock developer options you go to settings, about phone, and tap on the build number about 6 to 8 times. Then in developer options menu it should be near top
     
  8. liam97

    liam97 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    7
    Joined:
    Feb 28, 2016

    Feb 28, 2016
    7
    0
    5
    This is what I mean, USB is greyed out
     

    Attached Files:

  9. karthick1997

    karthick1997 Member
    Rank:
    None
    Points:
    28
    Posts:
    61
    Joined:
    Jan 2, 2016

    Jan 2, 2016
    61
    15
    28
    Male
    could you see " Select USB configuration " in developer options ....?
     
  10. El Presidente

    El Presidente Beware The Milky Pirate!
    Moderator
    Rank:
     #4
    Points:
    3,118
    Posts:
    32,120
    Joined:
    Jan 3, 2011

    Jan 3, 2011
    32,120
    24,094
    3,118
    Scotland
    Are you connected to the PC when trying to turn USB Debugging on/off? If yes, it will always be greyed out.

    There's are no options to change the connection type in Settings - Storage or Settings - More?
     
  11. liam97

    liam97 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    7
    Joined:
    Feb 28, 2016

    Feb 28, 2016
    7
    0
    5
    First question yes and no, I've tried USB debugging whilst connected to the PC and while unconnected. Still greyed out....

    Second, yes there is an option to change USB mount but that's greyed out, which is what I think is the primary problem.

    *image of the notification bar to try and show you guys what I mean by how I don't get USB mount options when connected to any pc*

    Please help guys, thanks :)
     

    Attached Files:

  12. liam97

    liam97 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    7
    Joined:
    Feb 28, 2016

    Feb 28, 2016
    7
    0
    5
    No sorry, it's not under dev options
    :(
     
  13. liam97

    liam97 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    7
    Joined:
    Feb 28, 2016

    Feb 28, 2016
    7
    0
    5
    So this is a photo I just took of my mates Phone connected to the same cable i just used on mine. The cable cleary works as he has his USB mount options. :/
     

    Attached Files:

  14. ndoody

    ndoody Lurker
    Rank:
    None
    Points:
    15
    Posts:
    1
    Joined:
    Mar 27, 2016

    Mar 27, 2016
    1
    0
    15
    Male
    I did exactly the same thing, I chose charge only one and now have no option to get back to USB mode. Connecting to whatever machine / cable combination no longer picks up the phone and only after once selecting "charge only" has this become a problem like the OP.

    Must be some fix to get the phone back into USB mode, and not charge only.
     
  15. ekor

    ekor Member
    Rank:
     #444
    Points:
    28
    Posts:
    49
    Joined:
    Nov 18, 2015

    Download the drivers your phone directly on your computer install them then connect your phone

    Forgot to mention, choosing charge only also installs the drivers to your computer but if it failed to install the first time and the file got corrupted it could be the cause of ur situation
     
  16. liam97

    liam97 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    7
    Joined:
    Feb 28, 2016

    Feb 28, 2016
    7
    0
    5

    Hi all,

    So yes after all this time I finally found a solution in which I didn't end up losing any data. So basically there's an app on the huawei p8 which lets you do a complete backup and saves it to the phone. So after doing a backup on the phone I decided to do a factory reset. This solved the problem, then all I had to do was use the backup I did just before and my phone was back to normal but obviously with the option to finally get onto the files option when plugged in via USB.

    :))
     
  17. Strawberry and bananas

    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Feb 3, 2017

    Feb 3, 2017
    1
    1
    5
    Hi,
    I called Huawei support, this is the SIMPLE SOLUTION:

    So, scroll down the shortcuts and under the USB connected select Photos or Files and that's it. If you don't select anything it will only charge the phone. Hope this will help. :)
     
    BustaLime likes this.
  18. hor01

    hor01 Lurker
    Rank:
    None
    Points:
    6
    Posts:
    2
    Joined:
    Apr 8, 2017

    Apr 8, 2017
    2
    1
    6
    I had this or a very similar problem and many of the suggestions above (and on several other websites) didn't fix it, but this did:
    • Settings > Security > Allow HiSuite to use HDB = OFF
    • Settings > Developer options = ON (with no other items in this screen turned on - not even USB debugging)

    Sadly, the point of HDB is to not have to turn on Developer options, but it failed to do this for me.

    I have Huawei P8-Lite with Android 5.0.1 (not rooted), connecting to Win 10 with HiSuite 5.0.1.300_OVE installed.

    Symptoms were, after plugging phone into USB port, Windows would report USB device not recognized - regardless of whether Photos, Files or USB drive selected on phone, same for USB tethering ... except after several tries 'Files' would work and HiSuite could see it! Another phone (Samsung S3 mini) worked just fine.

    I had tried without luck:
    • Updating the driver in Device Manager
    • Upgrading HiSuite from 4.x to 5.x
    • Settings > Security > Revoke HiSuite's HDB authorisations
    • Different USB cable
    • Different USB port
    • Restart phone and PC
    • Log into PC as admin
    • Dialler > *#*#2846579#*#* > Background Settings > USB Port Settings = "Hisuite Mode" (was this already), and the others on that screen

    I refused to be drawn into downloading drivers from random sites. Huawei.com doesn't seem to have any drivers for download. I didn't want to reset the phone, as that would mean several hours of my life I'd never get back.

    Sorry about the cross-post if you also saw this on another site. I was so happy when I was able to use USB tethering again, I just wanted to share the joy!! ... and help others solve their problem if they went through the same journey I went through.
     
    #18 hor01, Apr 8, 2017
    Last edited: Apr 8, 2017
    Jfalls63 likes this.
  19. kayes360

    kayes360 Lurker
    Rank:
    None
    Points:
    15
    Posts:
    2
    Joined:
    Aug 5, 2017

    Aug 5, 2017
    2
    0
    15
    sir I am having the same issues and tried all those fixes you've mentioned above but I didn't understand the final solution. If you could help me with that I will be very glad.My device is huawei honor 4c(android 4.4.2)
     
  20. hor01

    hor01 Lurker
    Rank:
    None
    Points:
    6
    Posts:
    2
    Joined:
    Apr 8, 2017

    Apr 8, 2017
    2
    1
    6
    You need to find the developer and security/Huawei HDB options I mention at the start of my post.

    I also have a Samsung phone with Android 4.1.2 OS. Developer options is the second to last in the settings menu, and Security about the middle. You might try playing with the Developer > USB Debugging option.

    I suspect the resolution this type of issue could be specific to the OS version, just guessing.
     
  21. steiny180

    steiny180 Android Enthusiast
    Rank:
     #140
    Points:
    98
    Posts:
    439
    Joined:
    Aug 7, 2014

    Aug 7, 2014
    439
    181
    98
    Male
  22. kayes360

    kayes360 Lurker
    Rank:
    None
    Points:
    15
    Posts:
    2
    Joined:
    Aug 5, 2017

    Aug 5, 2017
    2
    0
    15
    security/Huawei HDB option is not available on my phone.and tried couple of time with developer option but no luck
     
  23. GlitchCog

    GlitchCog Lurker
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Nov 21, 2017

    Nov 21, 2017
    2
    1
    5
    I have an LG G6 with this problem.

    I pull down the notification when I am connected, and there are no options do to anything but charge. In developer mode, under Select USB Configuration, I cannot select anything but Charging Only. If I select MTP (Media Transfer Protocol), it says Charging only, regardless of whether I am connected to a computer. I used the original cable that came with my phone, same result. I used fancy expensive cables I purchased from Amazon, same result. I bought another generic USB cable that claims to support transfers, and I bought a really expensive Belkin cable that claims to support transfers.

    Before I ever selected Charging only, I was able to use MTP mode. I transferred a number of files to my computer using it.

    Here's the crazy part. I just reset my phone to factory defaults, and it is still stuck in Charging only mode.

    Any ideas? Am I just eternally cursed to never be able to connect my phone to my computer again?

    Thanks.
     
    Darkner11 likes this.
  24. lunatic59

    lunatic59 Moderati ergo sum
    Moderator
    Rank:
     #2
    Points:
    4,238
    Posts:
    37,115
    Joined:
    Jun 12, 2010

    Jun 12, 2010
    37,115
    35,696
    4,238
    Male
    IT
    Pennsylvania
    Have you tried a different computer? Just to see if the USB port on the PC isn't the problem?

    If you've cleared the defaults, you should get the pop-up options when you plug it into a device with an active data connection. I know you said you tried different cables, but have you tried flipping the connector over? With not all type-c connectors are created equally and I have a few that are troublesome.
     
  25. xross

    xross Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Nov 24, 2017

    Nov 24, 2017
    1
    0
    5
    when you go into STORAGE you will see 3 dots right side of screen at the top click on this and you can change usb settings select MTP make sure it has blue dot press enter debugging now works let me know if this helps. New here but not new to computers and such,Thanks
     

Share This Page

Loading...