1. Download our Official Android App: Forums for Android!

usb tethering

Discussion in 'Android Lounge' started by catonano, Dec 20, 2013.

  1. catonano

    catonano Newbie
    Thread Starter
    Rank:
    None
    Points:
    36
    Posts:
    11
    Joined:
    Dec 20, 2013

    Dec 20, 2013
    11
    2
    36
    usb tethering won't work

    on fedora 19 with a lg l5 with android 4.1.2

    I described the sympthoms and posted a couple of screenshots on a fedora forum, here

    usb tethering - FedoraForum.org

    Is anyone using the same combination ?

    I tried on fedora 20 and it's even worse, it doesn't even react when I pull the usb cable in

    Thanks for any hint
     

    Advertisement

  2. Goodspike

    Goodspike Android Expert
    Rank:
    None
    Points:
    143
    Posts:
    1,144
    Joined:
    Dec 28, 2010

    Dec 28, 2010
    1,144
    143
    143
    Male
    Seattle
    I had trouble with it today too, but I just switched to a wireless hotspot rather than diagnose it.

    My main computer didn't even recognize the S4 being plugged in, so I think it was on my computer end, not the S4.
     
  3. catonano

    catonano Newbie
    Thread Starter
    Rank:
    None
    Points:
    36
    Posts:
    11
    Joined:
    Dec 20, 2013

    Dec 20, 2013
    11
    2
    36
    which is not encouraging

    well, thanks anyway
     
  4. Sandgoose

    Sandgoose Member
    Rank:
    None
    Points:
    38
    Posts:
    52
    Joined:
    Jun 29, 2010

    Jun 29, 2010
    52
    10
    38
    only thing that comes to mind, have you tried disabling the media mode or whatever the poor excuse for mass storage is called these days?
     
  5. mikedt

    mikedt 你好
    Rank:
     #6
    Points:
    3,238
    Posts:
    27,485
    Joined:
    Sep 22, 2010

    Sep 22, 2010
    27,485
    16,978
    3,238
    Teachaaa
    Jinan, China
    I sometimes tether my Linux Mint laptops with a Samsung and a Lenovo phone, but I've not been using them as "Mobile Broadband". I go into the phone's tethering settings and select USB tethering, the laptops see them as "Wired Ethernet", and work straight away.

    If you're using "Mobile Broadband", have you got the correct APN details for the carrier? When I've used USB 3G/4G modem dongles in Linux which work as "Mobile Broadband". I just select country and carrier. in my case China > China Unicom, and it does the APN settings automatically.

    What's that "Provider 22288", is that your carrier? When I tether Linux to my phones, it doesn't even know the phone's IMEI, it's just an internet connection via USB.

    The "Connected" networking interface is a Samsung Galaxy Win phone on USB, Linux Mint 15 KDE.
    [​IMG]

    On LG phones, does USB tethering work as "Mobile Broadband" rather than as a networking interface?
    tethering.jpg
     
    MoodyBlues and argedion like this.
  6. argedion

    argedion The TechnoFrog
    Rank:
    None
    Points:
    953
    Posts:
    6,360
    Joined:
    Jun 20, 2011

    Jun 20, 2011
    6,360
    6,294
    953
    The Infernal Swamp
    I just hotspot my phone with my OpenSuse 12.3 and never use a cable. I forgot that you could

    Ok just set up to usb tether and OpenSuse picked it up just fine. So no idea of what could be going on with yours unless its a bad cable. Have you tried another cable?
     
    MoodyBlues, ocnbrze and mikedt like this.
  7. argedion

    argedion The TechnoFrog
    Rank:
    None
    Points:
    953
    Posts:
    6,360
    Joined:
    Jun 20, 2011

    Jun 20, 2011
    6,360
    6,294
    953
    The Infernal Swamp
    So I have a question now which is better to do to set up as a mobile hotspot so I can use a few devices or to tether which only gives me the computer?

    Which is faster? More secure?
     
  8. mikedt

    mikedt 你好
    Rank:
     #6
    Points:
    3,238
    Posts:
    27,485
    Joined:
    Sep 22, 2010

    Sep 22, 2010
    27,485
    16,978
    3,238
    Teachaaa
    Jinan, China
    Speed, no difference I think. Unless your 4G is faster than your WiFi.
    Security, no problem. Provided the hotpot is not using open or WEP(both insecure). As long as the hotspot is set to WPA or WPA2, will be fine.

    I've used both, USB and WiFi tethering no problem, on Linux and Mac.

    Even if using the phone as a WiFi hotspot, can still plug the USB in just to keep it charged.
     
  9. catonano

    catonano Newbie
    Thread Starter
    Rank:
    None
    Points:
    36
    Posts:
    11
    Joined:
    Dec 20, 2013

    Dec 20, 2013
    11
    2
    36
    no, I haven't tried another cable. But because the sympthoms are different among fedora 19 and fedora 20 (that I also tried) I assume it's not the cable.

    But this is a good hint. I will try.

    Thanks
     
  10. catonano

    catonano Newbie
    Thread Starter
    Rank:
    None
    Points:
    36
    Posts:
    11
    Joined:
    Dec 20, 2013

    Dec 20, 2013
    11
    2
    36
    thanks for taking the time to test the cable tethering ! :)

    Well your suggestion is probably the best until now.

    I didn't consider the hotspotting possibility

    Should it work it would solve the problem

    I'll let you know (I'm not sure as how to switch the hotspotting on on the phone)
     
    argedion likes this.
  11. SulkyAndroid17

    SulkyAndroid17 Android Enthusiast
    Rank:
    None
    Points:
    68
    Posts:
    333
    Joined:
    Dec 17, 2012

    Dec 17, 2012
    333
    145
    68
    Male
    College Student
    Uhmerica
    Would this be of use? I know its for Arch Linux but the steps should be similar. I know I had to do this once and followed similar steps.

    Have you checked to see what drivers/modules are being used? Maybe you're using the wrong one. You can check loaded modules typing "lsmod" into a terminal.
     
    catonano and argedion like this.
  12. Goodspike

    Goodspike Android Expert
    Rank:
    None
    Points:
    143
    Posts:
    1,144
    Joined:
    Dec 28, 2010

    Dec 28, 2010
    1,144
    143
    143
    Male
    Seattle
    The main difference, IMHO, is that with USB you don't need to worry about keeping your phone charged. Acting as a wireless hotspot sucks battery, while being tethered charges the phone.
     
    argedion likes this.
  13. catonano

    catonano Newbie
    Thread Starter
    Rank:
    None
    Points:
    36
    Posts:
    11
    Joined:
    Dec 20, 2013

    Dec 20, 2013
    11
    2
    36
    thanks, I hadn't thought about that.

    It wasn of any help.

    But I still didn't try the wi fi tethering, so there's hope !
     
  14. catonano

    catonano Newbie
    Thread Starter
    Rank:
    None
    Points:
    36
    Posts:
    11
    Joined:
    Dec 20, 2013

    Dec 20, 2013
    11
    2
    36
    I hadn't thought about that.

    It wasn't of any specific help, but I still didn't try the wi fi tethering, so there's hope !

    As for the driver module, if you're curious, here it is:

    Code (Text):
    1.  
    2. [catonano@xps ~]$ lsmod | grep usb
    3. usbnet                 37645  1 cdc_ether
    4. mii                    13527  1 usbnet
    5. usb_storage            56690  0
    6. btusb                  28170  0
    7. bluetooth             361772  23 bnep,ath3k,btusb,rfcomm
    8.  
     
  15. SulkyAndroid17

    SulkyAndroid17 Android Enthusiast
    Rank:
    None
    Points:
    68
    Posts:
    333
    Joined:
    Dec 17, 2012

    Dec 17, 2012
    333
    145
    68
    Male
    College Student
    Uhmerica
    Interesting. When I run that same command on Linux Mint I get this:
    Code (Text):
    1.  
    2. usbnet                 31879  3 rndis_host,rndis_wlan,cdc_ether
    3. usbhid                 47074  0
    4. hid                   101002  2 hid_generic,usbhid
    5. usb_storage            57204  0
    6.  
    I googled rndis_host and the 1st link was an Android USB Tether wiki page for Gentoo. So it may be worth a look.

    Edit:
    Going through the links, it looks like RNDIS is probably important. These two Gentoo pages talk about it: Android 2.2 USB Tethering Tips and [Solved] USB Tethering (HTC eris Android)
    So try adding the rndis_host and the other modules. Then enable tethering on your phone and with Fedora use "dhcpcd usb0" in the terminal.
     
  16. catonano

    catonano Newbie
    Thread Starter
    Rank:
    None
    Points:
    36
    Posts:
    11
    Joined:
    Dec 20, 2013

    Dec 20, 2013
    11
    2
    36
    Thanks

    I'm not too well versed in this kind of linux stuff

    I can't find the rndis_host thing in no package. As for dhcpcd, it's in a package called wlassistant, it has 60 megs of kde dependencies. I use Gnome, I won't install such a thing just for the tethering.

    I suppose the Fedora guys had something else in mind.

    I can't figure out how the general layout of packages is supposed to be, ehm, layed out. I don't know my way around this

    I had hoped some help would have come in the Fedora forum, but my post there is around 180 views now and no answer :-(
     
  17. SulkyAndroid17

    SulkyAndroid17 Android Enthusiast
    Rank:
    None
    Points:
    68
    Posts:
    333
    Joined:
    Dec 17, 2012

    Dec 17, 2012
    333
    145
    68
    Male
    College Student
    Uhmerica
    So modprobe rndis_host and modprobe wlan does nothing? As for dhcpcd, I have no idea. I don't have it installed either. I use Mint's Cinnamon which is based on Gnome.

    Is usb debugging on?
     
  18. catonano

    catonano Newbie
    Thread Starter
    Rank:
    None
    Points:
    36
    Posts:
    11
    Joined:
    Dec 20, 2013

    Dec 20, 2013
    11
    2
    36
    Ok, so :


    1. rndis_host is not present at all. Probably because the Fedora policy is not to have proprietary stuff in the default distribution
    2. I use the stock network manager in the Gnome desktop, I don't know if it's Cinnammon or something else
    3. No, usb debugging is off. I'll try with it on and report back
    thanks for your follow ups ! :)
     
  19. catonano

    catonano Newbie
    Thread Starter
    Rank:
    None
    Points:
    36
    Posts:
    11
    Joined:
    Dec 20, 2013

    Dec 20, 2013
    11
    2
    36
    Ok, I activated the usb debugging and rebooted the phone. Nothing changes

    On another side I tried wi fi tethering and it works

    Probably fedora has to mature a bit in this regard

    thanks anyway
     
    argedion likes this.
  20. SulkyAndroid17

    SulkyAndroid17 Android Enthusiast
    Rank:
    None
    Points:
    68
    Posts:
    333
    Joined:
    Dec 17, 2012

    Dec 17, 2012
    333
    145
    68
    Male
    College Student
    Uhmerica
    No problem,

    The only other idea I have would be to compile all the modules yourself and add them to the kernel. But that's more work than it should be to just tether. Anyway, at least you have wifi tethering.

    Maybe in the future this will work out. I'd certainly give Fedora another try if it did. Good luck. ;)
     
    argedion likes this.
  21. argedion

    argedion The TechnoFrog
    Rank:
    None
    Points:
    953
    Posts:
    6,360
    Joined:
    Jun 20, 2011

    Jun 20, 2011
    6,360
    6,294
    953
    The Infernal Swamp
    I left fedora on v 17. I just didn't care for the way gnome was going and I decided to go back to OpenSuse. I never tried usb tethering on fedora though. I did hook my phone up to it all the time to do adb stuff but never had an issue with that.
     
  22. catonano

    catonano Newbie
    Thread Starter
    Rank:
    None
    Points:
    36
    Posts:
    11
    Joined:
    Dec 20, 2013

    Dec 20, 2013
    11
    2
    36
    I want to thank all of you, guys, who contributed to this thread.

    Even if I didn't get to a solution, I still appreciate the feedback. And I find frustrating the silence of other forums.

    Kudos
     

Share This Page

Loading...