1. Download our Official Android App: Forums for Android!

Support USB to Windows XP

Discussion in 'Android Help' started by japitts, Feb 21, 2016.

  1. japitts

    japitts Lurker
    Thread Starter
    Rank:
    None
    Points:
    6
    Posts:
    4
    Joined:
    Feb 21, 2016

    Feb 21, 2016
    4
    1
    6
    Male
    Firstly sorry for the long initial post...

    I'm a relative Android-virgin, just taken ownership of an Asus Zenpad, but a couple of days ago my Windows XP laptop stopped talking to it over the USB cable, and now I'm in a vicious circle of "found new hardware, MTP Device" > cannot install drivers > "there was a problem > (device manager yellow question-mark) > cannot update drivers manually > repeat.

    So far, I have tried..
    1: Using the tablet on another identical-build XP laptop, same problem. This other machine is normally used with a Samsung Galaxy no issues. I've not yet tried my laptop with their tablet.
    2: My tablet with a Windows-7 desktop, straight on no issues.
    3: Reinstalling Windows MTP-pack, trying to force the drivers manually, no joy.
    4: Trying to find some Asus-specific MTP drivers out there on interweb, no joy so far.
    5: Enabling the hidden developer menu and toggling USB-debugging, no joy.
    6: Toggling the tablet between MTP & PTP modes, no joy. PTP works fine, MTP doesn't.

    Immediately before it stopped working, I had disabled a few of the Asus-UI apps (PC link and suchlike), but these have all now been re-enabled without success. It's also had an Android-software update of some kind - now running WW_V4.6.1_20151228 if that makes any difference.

    I've also had problems previously, with this laptop talking to a Windows Mobile OS device over USB which I think was also MTP-related, so I'm betting that's at the root of the problem somehow.

    At the moment I'm out of ideas!
     

    Advertisement

    tareq zeiad likes this.
  2. AZgl1500

    AZgl1500 Extreme Android User
    Rank:
    None
    Points:
    618
    Posts:
    6,396
    Joined:
    Feb 3, 2011

    Feb 3, 2011
    6,396
    3,141
    618
    Male
    Retired and loving it.
    Oklahoma grasslands
    Kudos for an excellent description of what you have done.

    Now, bowing out to the experts.
     
  3. chanchan05

    chanchan05 The Doctor
    Rank:
    None
    Points:
    1,108
    Posts:
    15,208
    Joined:
    Jun 30, 2011

    If I remember correctly, there is a PC program for ASUS,. devices, PC Connect I think or something like that. It should come with the drivers.
     
  4. japitts

    japitts Lurker
    Thread Starter
    Rank:
    None
    Points:
    6
    Posts:
    4
    Joined:
    Feb 21, 2016

    Feb 21, 2016
    4
    1
    6
    Male
    Unfortunatelu PC Connect doesn't support XP. Kind of ironic, really. I've since tried another XP SP3 build machine which works fine with another Android handheld (not sure on OS), and the exact same problem. If it hadn't worked on this machine originally I'd swear it's a compatibility issue!
     
  5. japitts

    japitts Lurker
    Thread Starter
    Rank:
    None
    Points:
    6
    Posts:
    4
    Joined:
    Feb 21, 2016

    Feb 21, 2016
    4
    1
    6
    Male
    For the benefit of others, it turned out to be simple yet awkward. None of the "freely-available" driver files worked, but a support case with Asus yielded a set of drivers with a subtly-different filename that I didn't initially spot. In short, they worked. The solution made no sense interms of how the problem happened, but still..a good result in the end.
     

Share This Page

Loading...