1. Download our Official Android App: Forums for Android!

Root USCC Desire HBoot 1.06 rooted but wifi not working!

Discussion in 'Android Devices' started by MightyBraeburn, Aug 30, 2011.

  1. MightyBraeburn

    Thread Starter
    Rank:
    None
    Points:
    25
    Posts:
    3
    Joined:
    Aug 30, 2011

    Aug 30, 2011
    3
    0
    25
    Hey all,

    So I finally took the plunge and decided to try and root my USCC HTC Desire CDMA (first time rooting a phone). I read everything I could about my phone and the topic and it went as expected except now my wifi is no longer working.

    The entire set of steps that I took are as follows:
    1. Since Unrevoked can't handle HBOOT 1.06 I ran the unrevoked/alpharev Revolutionary which as I understand it changes the HBOOT to allow Unrevoked to work. This ran fine with no errors.
    2. Next I ran Unrevoked, which also ran find with no errors and I had a rooted phone!
    3. Since my main reason for rooting was to fix the app storage problems I then followed the directions here in the "[FAQ]ROOT MEMORY: a2sd+ / partitions" thread to setup my partitions and then the directions in the "[DEV][DATA2SD] More space (and more I/O) for your Desire (Updated/EXT4/Flashable ZIP)" thread to add init.d support without flashing a new ROM. Everything went well again and I verified that all my apps were moved out of the internal memory.

    My problem is however that now my WIFI is no longer working. When I attempt to turn it on there is a delay and it goes from "Turning on..." to "Error". This is kind of freaking me out since this is my first rooting and I really really hope I didn't break the WIFI.

    My question is, what do you think is wrong and what should I try to fix it? I'm not sure at what point of the process the WIFI stopped working (I didn't notice until the end) but I would bet it was when I used alpharev Revolutionary to change the HBOOT. Is it possible for me to restore my old HBOOT 1.06 without losing root? Is that likely to fix the problem?

    Sorry about the lack of links to the forum threads I reference but it won't let me post links yet because I'm a new user!

    Please help!
    Thanks
    MightyBraeburn
     

    Advertisement

  2. SUroot

    SUroot Android Expert
    Rank:
    None
    Points:
    1,123
    Posts:
    23,925
    Joined:
    May 25, 2010

    May 25, 2010
    23,925
    5,307
    1,123
    UK Technical Lead; Desktop Support
    Riddlesden, West Yorkshire, UK
    Can't see why this would happen but often kernel would be a cause. Why no custom Rom though?
     
  3. MightyBraeburn

    Thread Starter
    Rank:
    None
    Points:
    25
    Posts:
    3
    Joined:
    Aug 30, 2011

    Aug 30, 2011
    3
    0
    25
    I guess I'm new to all this rooting and I'm really trying to keep my first changes to a minimum, the main motivation for rooting was to solve the super annoying low disk space warnings. From what I read about some of the more popular custom roms they require flashing the radio as well, is that correct? If so, that scares me.

    I restored a backup from before I enabled init.d support and my wifi was back! So it appears that my intuition was wrong it was NOT the HBOOT update that messed it up but rather the changes I made to enable init.d, I used the update.zip file from post #40 in this thread (sorry won't let me post links:mad:):
    forum.xda-developers.com/showthread.php?t=894445&page=4

    I've gone ahead and posted over there in those forums (well in the general forum there since that's all it allows a new user to post in) now that I know it's a problem when I enable init.d

    Since it IS the init.d settings that broke the wifi would loading a custom ROM likely solve this problem? If so, there are so many custom roms out there can you recommend a good initial one? I've seem cyanogenmod's mentioned a lot but I thought I saw that it requires a radio flash.

    Thanks for the quick response.
     
  4. SUroot

    SUroot Android Expert
    Rank:
    None
    Points:
    1,123
    Posts:
    23,925
    Joined:
    May 25, 2010

    May 25, 2010
    23,925
    5,307
    1,123
    UK Technical Lead; Desktop Support
    Riddlesden, West Yorkshire, UK
    Radio is only required if your android version before root was 2.1. radios that came with 2.2 are compatible with 2.2 and 2.3 so thats fine.

    Anyway, CDMA roms dont use teh same radios that GSM models do so do not even think about radios. It s acompletely different process and you should forget about this.

    A custom rom will help. I'd check out Eddy OS's rooted stock CDMA on XDA... based on the USCC
     
Tags:

Share This Page

Loading...