1. Are you ready for the Galaxy S20? Here is everything we know so far!

Used EasyRoot, now I need help

Discussion in 'Android Devices' started by liam., Aug 6, 2010.

  1. liam.

    liam. Newbie
    Thread Starter

    Ok so here is the deal, I'm sorry in advance if this was discussed already, I rooted my phone earlier today using EasyRoot. I already downloaded 2.2 last week, so when I heard EasyRoot would give you root access on stock 2.2 I went for it.
    I tried to download BuglessBeast v.4 and I keep getting stuck after I download it. I dont know what to do! It gives two options "Wipe data and cache" and I forget what the other one was. I tried to flash the rom using Rom Manager and the phone re-booted. It wiped all my info and I had to reactivate my phone and re-download my apps. Right now I have 2.2 with root access and NO custom ROM. Does anyone have a step-by-step for running custom ROMs using EasyRoot?

    This is what it says in my ABOUT PHONE right now

    android version


    kernel version
    android-build@apa26 #1

    build number

    Any help is greatly appreciated.

    1. Download the Forums for Android™ app!


  2. vincentp

    vincentp Android Expert

    When you reboot into recovery, what do you see?

    Turn off the phone and hold X then press the Power button while continuing to hold X. If your recovery is all green-ish text, you're on Clockwork. If it's blue text with an Android guy in the background and says something about SirPsychos up top, it's SPRecovery. If you have the triangle with the exclamation point (I think.. haven't seen it in a while), you have the stock recovery and need to reflash one of the other ones from ROM Manager before you can proceed.
  3. liam.

    liam. Newbie
    Thread Starter

    i get the exclamation point
  4. vincentp

    vincentp Android Expert

    Ya, you lost your custom recovery. That's happened to most people using EasyRoot. Open ROM Manager and flash Clockwork Mod Recovery. Should be the first option on there. Then you can install from ROM Manager and it should work. The reason it's not installing is because you don't have the custom recovery on there right now.
  5. patch

    patch Well-Known Member

    I want to point out since most of the rooting veterans wouldn't need this application and haven't seen how it works.

    I'm new to the rooted Android scene, but most of the standard techiques seem to all involve flashing a rooted firmware with RSD Lite and pretty much directly afterwards installing the custom recovery. Full disclaimer that I have still not updated to a custom recovery or firmware yet, and I'm running the FRG01B OTA update version.

    From that version I installed EasyRoot from Market this morning, and the only system permissions it required was Bluetooth access. I had Bluetooth turned off when I started EasyRoot and noticed it turned Bluetooth on during the "rooting process" which took a few seconds only. It then instructs to reboot your phone and from that point on you have root access.

    It seems it does not do anything with firmware or custom recovery whatsoever, and maybe most of the users who used EasyRoot are having problems since they don't realize you NEED to install a custom recovery to be able to install the custom (unsigned) firmware. Please correct me if I'm wrong, this is what I understand from reading these forums, not from experience!
  6. liam.

    liam. Newbie
    Thread Starter

    Will I have to go through the reboot menu? Or will it automatically boot itself?
  7. derek533

    derek533 Member

    That doesn't seem to work either. I had the same problem and even after reflashing the clockworkmod recovery with Rom Manager, it would boot into clockworkmod one time, then after that, it was back to the standard exclamation point. The only way I have found to permanently fix it, is to flash the SP Recovery file onto the phone using the tried and true method with RSD Lite. Once that's done, you can then use Rom Manager to flash clockworkmod on and it will take hold. Until you flash SPRecovery on with RSd Lite however, it won't work except for the first time after flashing.

    OP, go read the guide to how to root your phone by OMJ or Trident and follow it step by step. You don't have to go all the way through, just the first few steps to get SPRecovery onto the phone. It's really very easy and only takes a few minutes. Once it's done however, you can flash clockworkmod back onto the phone using Rom Manager and flash any rom you want from that point on without fear of something like this happening again.
  8. vincentp

    vincentp Android Expert

    So the lesson here is don't trust EasyRoot. It doesn't seem to give you consistent ongoing root access. Do it the right way and you shouldn't run into these problems.
  9. bmkindoll

    bmkindoll Member

    I am having luck using the version of clockword modrecovery that is the version before the current one. I believe. You can find that at the bottom of the ROMManager screen just select the one second from the top. Using that version I have been flashing roms and kernels like crazy.

  10. nstallion

    nstallion Android Expert

    LOL. Called it.
  11. patch

    patch Well-Known Member

    No, you can't logically come to that conclusion. OP probably never installed a custom recovery.

    If anything, these problems to me it sounds more likely that there is an issue with the current version of clockwork, especially since previous versions have no problems. Has anyone had issues using SPRecovery instead of clockwork?

    I wish I cared to install a custom rom myself now, and I can put all this speculation to rest :) I'm sure I will eventually though, and will share my findings. So far everything I've tried on my "Easy Root"ed 2.2 has worked fine by following directions and researching what I was trying to do before doing it.
  12. liam.

    liam. Newbie
    Thread Starter

    ok so has anyone done a step by step how to with the easy root app? I read another "easyroot" thread and I understand for those that put the time in to root their phones the old fashioned way it can be annoying having the n00b running up a post count with dumb questions. But not everyone is a tech savy and in to it as others, so the easy one step meathods are GREAT for us. I would still be running 2.1 if Trident hadnt posted that easy to do thread and I wouldnt be rooted if it wasnt for easy root!!!

    So i take it what I have to do next after rooting, is flash a custom recovery (sp recovery or clockwork) then download sapphire or BB like I wanted to?

Motorola Droid Forum

The Motorola Droid release date was November 2009. Features and Specs include a 3.7" inch screen, 5MP camera, 256GB RAM, processor, and 1400mAh battery.

November 2009
Release Date

Share This Page