1. Download our Official Android App: Forums for Android!

Support Using i7500 with x64 Computer (Drivers)

Discussion in 'Android Devices' started by cpwood, Sep 6, 2009.

  1. cpwood

    cpwood Member
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    31
    Joined:
    Aug 31, 2009

    Aug 31, 2009
    31
    4
    16
    What follows may be old news to many readers here, but I just wanted to share the solution to a problem I've had getting my Windows 7 x64 computer to talk to my Galaxy. This may be relevant for Vista x64 too, though I can't check myself.

    As is well known, the New PC Studio software that comes with the Galaxy is more than a little bit rubbish. In fact, on my Windows 7 x64 machine the installer failed all over the place when installing the drivers. The end result was that I just couldn't get my Galaxy and Windows to talk. Naturally, this was a huge problem because I couldn't transfer files without taking my phone to bits and extracting the micro SD card every time!

    It seems that the CD that comes with the phone just doesn't have any x64 drivers on there (could somebody else confirm this, or is my CD just fundamentally flawed?).

    Today, I found that this file from Verizon contains all the drivers I needed to get the thing working though:

    Samsung Drivers

    1. Extract it but don't bother running Setup.exe
    2. Plug in your phone
    3. Go to Device Manager and then choose to update the driver for the device which has a yellow exclamation icon
    4. Choose to browse your computer for the drivers and point the wizard to the "drivers" folder you extracted from the zip file.

    You may have to do steps 3 and 4 several times, as after you've set up the first device (a composite device), two other devices suddenly appear and these also need drivers from the same folder.

    Again, I'm sure this is quite probably old news to many regular readers, but I couldn't find this information with a description that matched my problem, so I'm just posting this to help others in the same boat in the future.

    All the best,

    Chris
     

    Advertisement

  2. ZeeToo

    ZeeToo Member
    Rank:
    None
    Points:
    15
    Posts:
    47
    Joined:
    Sep 3, 2009

    Sep 3, 2009
    47
    0
    15
    Hi cpwood,

    Interesting, I'm using XP64 and my CD (surprisingly, I'm used to absolutely no drivers for anything) had drivers for my machine on it.

    I've got (from the disk):
    Ver. NPS IF2_2
    GH46-00999A

    I've taken a look in the USB Driver directory, but it only has an .exe installer that doesn't open easily so I don't know if that has win7 drivers in it at all :(

    But thanks for the info, I'll be moving to Win7 64 when it comes out and this'll be useful if they've not fixed it by then :)

    ZeeToo.
     
  3. cpwood

    cpwood Member
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    31
    Joined:
    Aug 31, 2009

    Aug 31, 2009
    31
    4
    16
    I've got the same CD.. maybe it just gets completely confused by Windows 7 x64 then (everything worked first time using the CD on my laptop running Windows 7 x86).

    On x64, it installs the driver files (after complaining several times about the untrusted source of the drivers) and the .INF files seem to suggest that 64-bit drivers are available. What you normally see alongside the .INF is two subfolders called "i386" and another called "amd64". But on Windows 7 x64, only the "i386" folder seems to be installed by the .exe! So when you plug the device in, Windows 7 x64 *thinks* it has found a driver, only to subsequently fail with a "file not found" error.

    I've completely uninstalled and reinstalled the CD drivers several times and have the same problems each time.

    Downloading the file above worked flawlessly though, so I'm happy :) Plus I don't have to install New PC Studio before I can install any USB drivers!!

    Chris
     
  4. ZeeToo

    ZeeToo Member
    Rank:
    None
    Points:
    15
    Posts:
    47
    Joined:
    Sep 3, 2009

    Sep 3, 2009
    47
    0
    15
    That can only be a good thing, NPS isn't exactly winning me over with it's reliability :)

    Well they've got till october 22nd or something when the pre-order arrives to fix it, but thanks very much for posting the information, I may have to use that later :)

    Hmm, not that it matters too much with that link you've posted but there are some tools somewhere that can probably unpack the .exe file so we can actually see if there are any 7x64 drivers - it wouldn't surprise me too much if there were some and just the installer broke :)

    ZeeToo.
     
  5. seeanimal

    seeanimal Lurker
    Rank:
    None
    Points:
    5
    Posts:
    5
    Joined:
    Sep 19, 2009

    Sep 19, 2009
    5
    0
    5
    Hey, I'm a little confused on the issues here.

    I'm running Win7x64 and, since I keep a tidy system, I just didn't bother to install PCstudio assuming it was unnecessary crapware.

    Just plug the USB in, tap Mount on the USB inserted notification, and Lo, explorer autoruns two removable disks (the internal and external SDs).
     
  6. pegasus21

    pegasus21 Android Enthusiast
    Rank:
    None
    Points:
    36
    Posts:
    253
    Joined:
    Aug 26, 2009

    Aug 26, 2009
    253
    1
    36
    The drivers are for ADB and modem. For the drives, no additional drivers are required.

    These drivers are for the modem. It supports both x86 and x64.
     
  7. synchromatik

    synchromatik Lurker
    Rank:
    None
    Points:
    5
    Posts:
    5
    Joined:
    Sep 4, 2009

    Sep 4, 2009
    5
    0
    5
    all worked on my win7 , thnx
     
  8. jonnegri

    jonnegri Newbie
    Rank:
    None
    Points:
    15
    Posts:
    12
    Joined:
    Sep 24, 2009

    Sep 24, 2009
    12
    0
    15
    Guys, I have Vista 64 and cannot get the i7500 to connect. I've tried all the above to no avail. Vista does reconise the two drives when the phone is connected, but I just get an error message saying please insert a disk into the drive. I have no 'yellow exclamations' in device manager when the ophone is connected.

    Any ideas? Its driving me mad!

    :cool:
     
  9. KlaymenDK

    KlaymenDK Android Expert
    Rank:
    None
    Points:
    143
    Posts:
    1,217
    Joined:
    May 29, 2009

    May 29, 2009
    1,217
    130
    143
    Denmark
    This may be a dumb question, but have you mounted the phone? Pull down the menu and tap the USB message, it should display a dialog asking you to mount your drives. :) If that's not it then yes, you have driver problems.
     
  10. kam187

    kam187 Android Expert
    Rank:
    None
    Points:
    118
    Posts:
    1,320
    Joined:
    Aug 3, 2009

    Aug 3, 2009
    1,320
    46
    118
    UK
    Use the original CD and install the NPS and the drivers. Then turn on USB debugging on the phone and plug it in. You'll be asked for a bunch of drivers, point to program files\samsung\usb drivers\1 (or 2 or 3 etc) untill it finds them all. You'll be left with 1 that doesnt install which is the adb driver, ignore it.
     
  11. skinauk

    skinauk Lurker
    Rank:
    None
    Points:
    5
    Posts:
    7
    Joined:
    Oct 25, 2009

    Oct 25, 2009
    7
    0
    5
    Phone: Samsung Galaxy O2UK (latest firmare according to NPS - XXII6 I think?)
    OS: Windows 7 Pro x64 fresh install

    I can see the SD card, browse it and delete files from it. However, if I try to copy any large files to it (such as an mp3 file) the disk will unmount and the copy will fail.

    I had this issue with a previous installation of Windows 7 x64 after installing the NPS software. From a fresh windows install and freshly wiped phone I am still unable to copy anything to my SD card even after following the above instructions.

    Any ideas?

    Note: I tried it on a windows XP machine and everything works fine so it looks like a driver/compatibility issue as opposed to fault phone/SD.

    Thanks,

    Daniel
     
  12. Rastaman-FB

    Rastaman-FB Android Expert
    Rank:
    None
    Points:
    313
    Posts:
    6,113
    Joined:
    Sep 11, 2009

    Sep 11, 2009
    6,113
    1,010
    313
    UK
    are you using the default cable or an aftermarket one?
     
  13. skinauk

    skinauk Lurker
    Rank:
    None
    Points:
    5
    Posts:
    7
    Joined:
    Oct 25, 2009

    Oct 25, 2009
    7
    0
    5
    The cable that came in the box - it's branded 'samsung data link cable'
     
  14. Rastaman-FB

    Rastaman-FB Android Expert
    Rank:
    None
    Points:
    313
    Posts:
    6,113
    Joined:
    Sep 11, 2009

    Sep 11, 2009
    6,113
    1,010
    313
    UK
    strange, i have that behaviour at work when i use a none samsung cable and it just sends the phone nuts. then i plugin the default one and it works

    im using win7 x64 pro at home with standard cable and mass storage works perfectly
     
  15. skinauk

    skinauk Lurker
    Rank:
    None
    Points:
    5
    Posts:
    7
    Joined:
    Oct 25, 2009

    Oct 25, 2009
    7
    0
    5
    Is USB debug mode on?
    How did you install the drivers? Using the CD that came with the phone?
    Does NPS work fine for you (if you installed it)?

    I will try a different USB port, Windows XP Mode and another Vista/7 x64 computer if I can get hold of one to test and report back.
     
  16. Rastaman-FB

    Rastaman-FB Android Expert
    Rank:
    None
    Points:
    313
    Posts:
    6,113
    Joined:
    Sep 11, 2009

    Sep 11, 2009
    6,113
    1,010
    313
    UK
    mass storage mode worked without installing nps and debug mode was off

    in order to gt nps working i had to do what was described in this guide but nps will only work for updates and updates will only showup if a csc enabled phone finds a more recent version of that networks android csc
     
  17. tranquan83

    tranquan83 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    3
    Joined:
    Aug 28, 2010

    Aug 28, 2010
    3
    0
    5
    i had New_PC_Studio_1.2.1.IH2 in my Win7 x64. but when i connect may i7500 to the PC. then appear 2 devices name removable disk with size 0kb. when i use NPS, it reconize that an android device had connected and appeared 2 icon name "Android" and "Android(1)", but when i clicked on these icon, it said "Insert the disk into the H drive". And I absolutely not get my data on the phone :(. i tried remove all old install of samsung on my PC but it didn't seem work, then i had tried to update driver for thoes 2 device but it said that i had had up to date.
    sorry for my bad English.
     
  18. Lelouch

    Lelouch Android Enthusiast
    Rank:
    None
    Points:
    98
    Posts:
    655
    Joined:
    Aug 6, 2010

    Aug 6, 2010
    655
    70
    98
    Kri
    Did you try to turn on USB storage? Do you use USB debugging?
    The same questions as above posts. Some info please.

    NOTE: Windows & Android just don't love each other, but with Ubuntu (Linux) and Android that's a different story.
     
  19. Alpha17x

    Alpha17x Lurker
    Rank:
    None
    Points:
    5
    Posts:
    6
    Joined:
    Aug 30, 2010

    Aug 30, 2010
    6
    0
    5
    Graphic Artist
    Canada
    How does this work? the driver folder is full of sys files, not inf files, it's not every going to find anything if you're doing a manual driver update. Is there a step missing?

     
  20. panther2010

    panther2010 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    5
    Joined:
    Sep 4, 2010

    Sep 4, 2010
    5
    0
    5
    I installed the x64 drivers. Now my Phone is getting detected as Samsung Galaxy but my SD cards are not shown in "My Computer".

    I did the "mount" thing. Its still not showing up.

    I also installed the droid explorer which downloaded some stuff I dont know about.

    Can anyone please help me. I cant go further as I cant see the SD cards left alone copying data onto it.
     
  21. panther2010

    panther2010 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    5
    Joined:
    Sep 4, 2010

    Sep 4, 2010
    5
    0
    5
  22. Alonzzo2

    Alonzzo2 Well-Known Member
    Rank:
    None
    Points:
    36
    Posts:
    106
    Joined:
    Nov 23, 2009

    Nov 23, 2009
    106
    3
    36
  23. Shorrack

    Shorrack Member
    Rank:
    None
    Points:
    38
    Posts:
    45
    Joined:
    Oct 9, 2009

    Oct 9, 2009
    45
    17
    38
    Finland

Share This Page

Loading...