1. Are you ready for the Galaxy S20? Here is everything we know so far!

Using MT4G as mp3 player

Discussion in 'Android Devices' started by LunchBB, Feb 3, 2011.

  1. LunchBB

    LunchBB Android Enthusiast
    Thread Starter

    hey guys, what's your experience using MT4G as mp3 player? I tried it today. when the phone is locked in my pocket, the headphone play/pause, prev, next buttons won't work. Then, touching the power button will cause the screen turn on and accidentally hit the next track. Kinda annoying.

    Anything to do to improve this experience so I don't have to carry a separate mp3 player?

    Thanks
     



    1. Download the Forums for Android™ app!


      Download

       
  2. behold_this

    behold_this Android Expert

  3. pantlesspenguin

    pantlesspenguin Android Enthusiast

    That's really weird. I haven't had those experiences using the stock media player. The only media player issue I have is when I'm in shuffle mode, it repeats songs a LOT. But, I figured out if you go into a playlist & select "play all" first, it doesn't repeat.
     
  4. defiantbeast

    defiantbeast Well-Known Member

    The stock player is good but i found that power amp is a much better player. The lock widget allows you to continue playing track and control them using headset controls just fine. plus you have the benefit of being able to control the equalizer settings.
     
  5. Basscasey

    Basscasey Member

    I use the stock media player pretty much exclusively when driving my car...no issues so far.
     
  6. LunchBB

    LunchBB Android Enthusiast
    Thread Starter

    Stock media play is fine. I was just asking about using the headphone with the remote control buttons on the headphone comes with the phone. After the phone is locked, those 3 buttons on the headphone becomes inactive.
     
  7. lopro

    lopro Newbie

    Once again, your questions go unanswered...? Please excuse me for not providing answers, but I don't know because I haven't had the luxury of playing mp3s on the headphones much. Maybe one day...
     
  8. paqman

    paqman Newbie

     
  9. behold_this

    behold_this Android Expert

    Yeah it works locked. I use it all the time. You just need to turn the feature on (check use headphone controls) in the preferences.
     
  10. LunchBB

    LunchBB Android Enthusiast
    Thread Starter

    I also don't have luck using the head phone with Cube even though I activate the headphone control feature.
     
  11. paqman

    paqman Newbie

    Yeah tried that. No workie.
     
  12. paqman

    paqman Newbie

    Update: If this will help anyone who's having this issue, I found an app that works for me. Meridian media player. Funny thing is, I've had this app on my phone for months, just as a video player. The music player wasn't all that fancy, so I just wasn't using it. But I gave it a shot and it works. Buttons work locked or unlocked.
     
  13. behold_this

    behold_this Android Expert

    Ok then. I guess I have a super awesome special phone that magically works then cause I use cubed with the screen locked all the time using the stock headphone controls. It must have been sprinkled with magic android dust. Lucky me ;)Lol.
     
  14. paqman

    paqman Newbie

    Ok you can stop rubbing it in now.
     
  15. behold_this

    behold_this Android Expert

    Ok ok...just havin' some fun this beautiful monday morning. I do wonder what it might be causing the buttons not to work for you guys. I've looked all around for any other settings or apps that might be conflicting but no luck, and like I said, it works for me (not rubbing in). Guess I'm not gonna be much help to ya.

    Just to clarify, the buttons do NOT work for me either when phone is locked, using the stock player (media room). This is a terrible flaw in the app, but it is the only player that I have had this problem with.
     
  16. paqman

    paqman Newbie

    Yeah me too. There's got to be a setting somewhere mucking it up. But mine has been this way since day one, before I had even loaded any apps or changed any settings. Strange.
     
  17. mingc

    mingc Newbie

    Have you tried a factory reset?
     
  18. paqman

    paqman Newbie

    No, it's not THAT important, lol. I don't want to have to reinstall everything. But I've found a solution so I'm happy.
     
  19. mingc

    mingc Newbie

    You've had the Meridian all this while, and the headphones work on Meridian while the phone is locked, but not on the stock or other players? Betcha Meridian's intercepting the headphone commands and that if you uninstall Meridian or turn headphones off on it, the headphone commands will start working on the other players.
     
  20. LunchBB

    LunchBB Android Enthusiast
    Thread Starter

    It's frustrated.. no luck on Cube, PowerAmp, and Meridian. None of them takes any buttons with the remote control buttons. On the Media Room program takes them when the player is the active program. ahhhh..

    But then, I like PowerAmp with it's equilizer feature. It makes music output more dynamic and bass enhanced. Amazing bass with the little ear bug.. I think it worths $5.
     
  21. LunchBB

    LunchBB Android Enthusiast
    Thread Starter

    I GOT IT I GOT IT

    You have to go through all other media program installed to turn off the option to control the headphone buttons. I have MediaFly installed. After I turned off the headset control in the options, Meridian works. Now I put powerAmp back in, it works too.

    Thank you guys!
     
  22. mingc

    mingc Newbie

    Alright! :D
     
  23. paqman

    paqman Newbie

    My friend, you and mingc have solved this problem. I also have a few different media players installed (because I've been trying to find the perfect one.) and each one has the buttons setting configured. I unchecked the option in all the different media players I had installed, and now the default media player works!

    Funny thing starts happening now though. Now the default player works, I tried to re-enable the option in another app, like Meridian, and now, the buttons control BOTH apps. AT THE SAME TIME. So now, if I am playing a song in one app, and I hit the "next" button, it goes to the next song, AND a song starts playing in the other app. So I now have two songs playing at the same time. Interesting, but not fun.

    So it seems now that it works, but I have to disable it in everything else to get it to work in media room (the default app). But if I enable it in anything else, it will work, but then start up media room any time I hit a button. Strage. But I can live with it.

    Edit: If I kill all other media player apps, I can control the one I choose without others starting up music at the same time. Just bad programming.
     
  24. drbeamer

    drbeamer Lurker


    What exactly are "other media programs"? I have no other MP3 players installed, and the music controls still don't work when the device is locked.
     
Loading...

Share This Page

Loading...