1. Are you ready for the Galaxy S20? Here is everything we know so far!

Various problems with Sony Xperia Z1 Compact

Discussion in 'Android Devices' started by Arbu, Sep 24, 2014.

  1. Arbu

    Arbu Member
    Thread Starter

    I've had my Sony Xperia for about a month and, while it seems nicely designed, I wish it would work a bit better. In particular:

    1. It beeps at irregular times but about once an hour and I can't see what it's trying to notify me of.
    2. When I turn it on it is always in the camera mode and I have to dismiss this. This is annoying.
    3. When I connect it to my computer it tells me that I need to install an update. When I follow these instructions it just gets stuck on one screen and tells me to start over again. Clearly this could go on indefinitely if I followed the instructions.
    4. I'd like to be able to stop it from beeping during the night even if it does have something to notify me of, but I can't see how to do this

    The phone only came with a very limited instruction manual which doesn't help with any of the above. Can anyone kindly help at all?

    Thanks
     



    1. Download the Forums for Android™ app!


      Download

       
  2. MoodyBlues

    MoodyBlues Compassion is cool!
    VIP Member

    Hi there, Arbu. Which Sony Xperia do you have? I'm asking because if we have a dedicated forum for it, we can move this to its forum and other owners of the device will be more likely to see it--and, hopefully, help! :)
     
    Arbu likes this.
  3. Arbu

    Arbu Member
    Thread Starter

    Thanks. It's a Sony Xperia Z1 Compact Black D5503. I've figured out the solution to the second problem.
     
  4. Slug

    Slug Check six!
    VIP Member

    Thread moved.
     
  5. Nelviticus

    Nelviticus Well-Known Member

    You can set it to go into silent mode at night using the Smart Connect app. Create a new profile with the + button then add a time (don't add a device). Add a start action of Sound mode -> Silent and an end action of Sound mode -> normal, then give it a name and you're done.

    Any notification beeps should be accompanied by a notification message in the notification area. If it isn't obvious which app a notification is from, you can long-press on one and select 'app info' to find out.

    Regards
     
  6. Arbu

    Arbu Member
    Thread Starter

    Thanks v. much. Funny how you don't get an instruction manual with a phone these days nor a help file with software but have to use fora like this to work them out.

    Anyway, the Smart Connect app looks like it should work and I've figured out how to start up my phone normally and not in camera mode. The beeps continue to come without notification messages though and my computer still always wants to install updates whenever I plug the phone in in spite of me having gone through its instructions dozens of times...
     
    SanFran likes this.
  7. Arbu

    Arbu Member
    Thread Starter

    Unfortunately this doesn't work. I have a profile in SmartConnect which is on, shows silent mode after 11:30pm and normal after 8am. Last night someone sent me a message on Google Hangouts at 2:30am. My phone joyfully beeped and woke me up yet again.

    Really I'd like it to be possible for people to phone me at night, in case of an emergency. But I don't want all these unimportant notifications waking me up. Perhaps that's an impossible request and I will just have to turn my phone off every night.
     
  8. Nelviticus

    Nelviticus Well-Known Member

    Did you set the event to happen every day, or just weekdays or weekends? This caught me out - I have different ones for weekdays and weekends because I like to wake up later at weekends, and I had to set the 'weekdays' one to be Monday, Tuesday, Wednesday, Thursday & Sunday and set the 'weekends' one to Friday and Saturday. This is because the 'end' action - the bit where I wake up - depends on the day the 'start' action started. So my Saturday wake-up time has to be configured as the end action of Friday night's 'silent' action. It confused the heck out of me for a while.

    If your problem's not related to that then I'm stumped. When it went off did the sound mode still say 'silent'?
     
  9. Arbu

    Arbu Member
    Thread Starter

    I set it to happen every day. Where do I check what the sound mode is at any given time?
     
  10. Nelviticus

    Nelviticus Well-Known Member

    You can see it in the Quick Settings panel - a speaker with waves coming out (normal), a phone with little vibrations next to it (vibrate) or a greyed-out speaker with an 'x' through it (silent).
     
  11. Arbu

    Arbu Member
    Thread Starter

    It went off again at 4am last night. A lunatic sent me a message on Tinder and the phone vibrated loudly a couple of times. No mention of this event in the Notifications bar, only in Tinder.

    My Quick Settings panel currently shows Wi-Fi, Bluetooth, Location, Hotspot, Throw, Auto-rotate and Brightness. None of the things you mention.
     
  12. Arbu

    Arbu Member
    Thread Starter

    And again last night. I checked Smart Connect and my silent at night setting had an additional condition namely that the phone had to be connected to the charger. What the heck! I certainly didn't set this and I can't see why on earth anyone would want this condition. Seems anything but smart to me. I suppose perhaps I should be grateful that I've only been woken twice at night by this phone in the last year, but still it's annoying. I'm inclined just to leave my phone's volume at a minimum at all times and rely on it vibrating to answer any incoming calls.
     
  13. Arbu

    Arbu Member
    Thread Starter

    And again, last night. Smart Connect was set to "Do not disturb" mode. But at 2am my phone decided to beep and tell me to learn about "pinning" the screen. I suppose at least it's been a long time since this last happened but still it's really annoying. I never asked for these notifications, probably there's an opt out somewhere, but who knows where?
     
  14. Hadron

    Hadron Smoke me a kipper...
    VIP Member

    As a work-around you could use a third-party app to enforce a "silent at night" condition (Timeriffic, Tasker, Macrodroid, whatever).

    But waking you to provide a "tip" on using the phone is particularly silly. Does long-pressing or sliding the notification not give you any options (I don't have a Sony to compare with)?
     
  15. Arbu

    Arbu Member
    Thread Starter

    I can't find the tip any more. But I think it came from Xperia Tips Service which I have now uninstalled.

    SmartConnect failed me. If it does it again I'll ditch it and try one of the apps you suggest.
     
  16. Arbu

    Arbu Member
    Thread Starter

    And again last night. 4:37am and the cursed thing decided to vibrate and beep to notify me of a facebook message. Smart Connect had disabled the silent event for some reason and I certainly wasn't aware of this. So now I've got both Smart Connect and Macrodroid silencing the phone at night. If this doesn't work then I'll have to resort to turning the phone off every night.
     
  17. Hadron

    Hadron Smoke me a kipper...
    VIP Member

    Make sure that Facebook notifications are not flagged as "priority" or allowed to override "do not disturb" (different ways of doing things in different Android versions). Just in case.
     
  18. Arbu

    Arbu Member
    Thread Starter

    If the designers of facebook think I'm going to hunt around to find how to turn off its right to override my settings (I bet it's not easy to find) then it's coming off my phone.
     
  19. Hadron

    Hadron Smoke me a kipper...
    VIP Member

    I don't know that that's the case. I was just thinking of possible explanations, and it occurred to me that it is possible for an app's notifications to be set as "priority" and thus still passed on when in "do not disturb" mode (though it shouldn't override just setting the ringer to silent, which is slightly different). Any app can be set that way. I should add that on my phone the FB app is not set to give priority notifications, and not overriding do not disturb was the default. I was literally just considering possibilities.

    As I recall on my previous (android 5.0.2) device the "priority" thing was in the notifications settings, but I may have misremembered as it has been a long time since I looked at it. In my current one (android 8.1) you look in Settings > Apps > Facebook (for example) and there is an "app notifications" option where you can choose whether the app can override "do not disturb".
     
  20. Arbu

    Arbu Member
    Thread Starter

    No, there's no such option on Notifications for facebook. Just "On", "Allow notification dot", "Allow sound", "On the lock screen" and "Interrupts in Priority only".

    I got woken up again last night, 3:30am. I'm absolutely sick of the way this cursed system behaves. I have about 30 apps on my phone and they update themselves regularly. When they update themselves I don't know if they are keeping settings the same. If there is an option for them to override the do not disturb setting then I am probably looking at a ten minute job every day to ensure that no app is going to wake me up.

    Clearly the only solution is to turn the phone off every night.

    Oh, and by the way I had both MacroDroid and Smart Connect supposedly ensuring that the phone was on silent.
     
    #20 Arbu, Jan 25, 2018
    Last edited: Jan 25, 2018
  21. Arbu

    Arbu Member
    Thread Starter

    Forgot to turn it off last night and Whatsapp joyfully woke me up at 6:45am even though Macrodroid and Smart Connect were both running. So I've added an action on Macrodroid to put the phone in Airplane Mode overnight. I think that should work. Next step will be to have Macrodroid turn the phone off automatically which I see it can do. I don't suppose there's any way to turn the phone back on automatically though.
     
  22. Hadron

    Hadron Smoke me a kipper...
    VIP Member

    No, there's no way to turn it on automatically.
     

Sony Xperia Z1 Compact Forum

The Sony Xperia Z1 Compact release date was January 2014. Features and Specs include a 4.3" inch screen, 20MP camera, 2GB RAM, Snapdragon 800 processor, and 2300mAh battery.

January 2014
Release Date
0
Reviews
Loading...
Similar Threads - Various problems Sony
  1. melani78
    Replies:
    6
    Views:
    411
  2. GeneralGhest
    Replies:
    24
    Views:
    585
  3. spman
    Replies:
    2
    Views:
    381
  4. Oldschool297
    Replies:
    14
    Views:
    567
  5. Derek John Castle
    Replies:
    3
    Views:
    494
  6. King Mustard
    Replies:
    3
    Views:
    1,234
  7. Papamalo
    Replies:
    2
    Views:
    758
  8. EvoVAlpha
    Replies:
    5
    Views:
    1,819
  9. 14km
    Replies:
    2
    Views:
    1,228
  10. MisterOlga
    Replies:
    1
    Views:
    1,518

Share This Page

Loading...