1. Are you ready for the Galaxy S20? Here is everything we know so far!

[Verizon] Clockwork Backups Gone (toro)

Discussion in 'Android Devices' started by GrandpaJeff, Dec 17, 2012.

  1. GrandpaJeff

    GrandpaJeff Lurker
    Thread Starter

    I looked through the similar thread section but I could not find anything that solved my problem. I am relatively new to flashing roms. I flashed clockwork recovery, made a backup of stock, and switched to cyanogen mod 10 for my device. It worked great, and made a backup of that too. Tonight, I saw that the nightly for CMod 10.1 (4.2) was out, so I went into check for updates, and downloaded the latest nightly (from inside cyanogen mod). After it updated, and was booting apps, it got stuck on "upgrading media database". This is when I probably made the fatal mistake. I pulled the battery, and rebooted it. I turned it on, played with it for a little, and hated it. Camera didn't work, didn't have google apps, etc. When i went back into recovery mode, I opened up the restore menu, and got the message: "couldn't open directory, no files found". I went into the folder on a file manager, and found the backups still there. Does this mean that my backups, are gone? Damaged? Recoverable? Please help!
     



    1. Download the Forums for Android™ app!


      Download

       
  2. Dmeeks90

    Dmeeks90 Well-Known Member

    What recovery do you have and what version?
     
  3. GrandpaJeff

    GrandpaJeff Lurker
    Thread Starter

    ClockworkMod 6.0.2.3
     
  4. Crashumbc

    Crashumbc Android Expert

    Search the forums here, 4.2 changed the file structure. Your stuff is still there, you just need to move it into the correct location.

    I'm not familiar enough with it to tell you what you need to do though :(

    I know the newer recoveries "fixed" the problem, I guess your version of CWM isn't new enough. (I use twrp so I don't which CWM version work properly)
     
    GrandpaJeff likes this.
  5. Dmeeks90

    Dmeeks90 Well-Known Member

    I had the same problem when i went to 4.2 The files are there but im pretty sure you can find them and relocate them using a file manager but im not 100%
    Use file explorer look under /sdcard/0 it should be in there
     
    GrandpaJeff likes this.
  6. gapi

    gapi Android Expert

    According to who's ROM you are using and which way you wanna go ....

    Open Root Explorer on your device and locate both of the data/media/clockworkmod folders, one will be in the SDcard/0/data/media/clockworkmod and the other in the SDcard/data/media/clockworkmod.

    If you are in a 4.2.x and want to go back to a 4.1.x you will see an empty /backups folder in the /Clockworkmod folder. Go to the 0/ folders clockworkmod/backups folder and choose to move them to the other one.

    Boot and open CWM and restore your nandroid.

    Now others will say just use TWRP to do all your 4.2.x flashing and its all taken care of but its not the same for everyone.

    After doing the above I had to factory data reset and format system and then restore my nanny in recovery. So if your restores fail because of a "system" error it may be due to a bad file move. I suggest you do not copy and paste it over, do a move. A copy will stall and you may have to jump through more hoops.
     
  7. teddyearp

    teddyearp Android Expert

    GrandpaJeff, you have found the hardest part of upgrading from an Android 4.1.x rom to an Android 4.2.x rom. Would it be too much of a stretch for me to say that when you say you "downloaded the latest nightly (from inside cyanogen mod)" that you actually meant "from inside Rom Manager"? For sure, as you posted, you shouldn't have turned your phone off in the middle of "updating media database", it was probably quite a fatal mistake.

    From your results, I can only assume that this is the case. And that is why it can be hard to restore back from a 4.2.x rom to a 4.1.x rom. Even if you use the latest custom recoveries to flash to a 4.2.x rom, (from what I've read) you will still experience difficulties restoring to your 4.1.x nandroid/roms.

    I am still running a 4.1.2 rom and the problems you are experiencing are one of the main reasons I have not flashed a 4.2.x rom. However, as posted, you should be able to restore via some diligent file modifications via your favorite file manager program.\

    good luck
     
  8. gapi

    gapi Android Expert


    Same here. My 4.1x is running like a fine jeweled watch.
     
  9. Ulmo

    Ulmo Lurker

    When I did my ROM Manager upgrade to the latest nightly (2012-12-24), I got "Upgrading Media Database", and I realized my 20 gigabytes of media was going to take longer than most people, so I looked on the web to see if this was a time issue. Apparently, it's not just a time issue, but a MASSIVE one, and I estimated I'd have to wait about a week for mine to complete. Well, guess what, I actually USE my smartphone, so this was unacceptable, so I battery-pulled. I rebooted several times to find the device unusable due to it being so slow it basically crashes after a few minutes or less,

    so I decided to Clockworkmod Nandroid Restore, and got "no files found" when trying to do that. I then again looked here and found out that the files normally in /data/media/clockworkmod are now in /data/media/0/clockworkmod, so

    I installed an older adb from http://forum.xda-developers.com/showthread.php?t=1387527 on my older MacOS 10.5.8 to access my ClockworkMod Recovery v6.0.2.3 shell (the current Google.Com adb doesn't work with MacOS older than 10.6 any more).

    Then, from adb shell, I did "cd /data/media; ln -s 0/clockworkmod .", then suddenly all the files were found, and the Nandroid Restore proceeded.

    I just rebooted right now, and SO FAR everything looks OK (back to my old ROM as Nandroid Restored):

    + Camera works
    + SMSs work
    + Wifi works
    + GPS works
    + Social app using Wifi & GPS works fine

    So, I'm back in business. Thank god for Nandroid Restore! I'll let some of the experience level of upgrading settle down on this one! And let some of the bugs work out too ...

    STOP THE PRESSES! Gallery is messed up. Ohkay ..... it seems like Gallery always gets messed up.

    Ohhhhh ... /sdcard/ isn't what it seems. /sdcard/* was moved to /sdcard/0/*, so I have to move it back. One moment while I do that (in recovery) ...

    So, there was quite a bit of new directories in /sdcard/* pretty empty to replace the missing ones hiding in /sdcard/0, so I had to sort of move them out of the way (trash, rename, etc.), then move /sdcard/0/* and /sdcard/0/.??* back to /sdcard/.

    Gallery does not start properly, but I force stopped it, cleared data (in manage apps), and now it starts properly.

    My phone is back to normal, as far as I can tell.
     
  10. gapi

    gapi Android Expert

    Once you flash a 4.2 ROM you will have a /0 directory no matter what you do. Rather or not its critical is another question. I have gotten back to my 4.1.x ROM and formatted my SDcard and all that and in Root Explorer you can still see an 0 directory.

    This is a black eye because the multu users is for tablets. I don't lend my phone and don't want to touch your finger germs either. Life or death emergency only. These touch devices are nasty items.
     
  11. teddyearp

    teddyearp Android Expert

    And I'm going to take this as all the more reason not to flash a 4.2 rom on my phone. I already have the 4.2 camera and from what I read in my poll thread, there's really no other reason to upgrade.
     
  12. gapi

    gapi Android Expert

    I hear you. I am a crack flasher and a big time AOKP fan boy and have been following their 4.2.X preview thread since day one and they still cannot release a stable build to their standards.

    Their standards are pretty high so I understand. The fact they have not released an official yet is a story in its self. But I wait.

    I did flash an early preview and barley got out alive. They are working overtime on it though. A great bunch and it will be worth waiting for if it gets here before Key Lime Pie.:)
     
  13. teddyearp

    teddyearp Android Expert

    Well, this is getting off topic, but as I said in another thread, I truly feel that 4.2.x should have been reserved for tablets only just like Honeycomb (3.x.x).
     
  14. Rxpert83

    Rxpert83 Dr. Feelgood

    I agree. I have 4.2.x on my nexus 7and 4.1.x on my phone. I won't take an update to 4.2.x if it comes to my phone
     
  15. slyd

    slyd Android Enthusiast

Galaxy Nexus Forum

The Galaxy Nexus release date was November 2011. Features and Specs include a 4.65" inch screen, 5MP camera, 1GB RAM, TI OMAP 4460 processor, and 1750mAh battery.

November 2011
Release Date
0
Reviews
Loading...
Similar Threads - Verizon Clockwork Backups
  1. craiger4233
    Replies:
    2
    Views:
    300
  2. NewArtDroid
    Replies:
    5
    Views:
    526
  3. persistentone
    Replies:
    5
    Views:
    879
  4. Hannibal 99
    Replies:
    4
    Views:
    645
  5. persistentone
    Replies:
    3
    Views:
    1,034
  6. LuckyBit33
    Replies:
    6
    Views:
    2,592
  7. Clint w
    Replies:
    5
    Views:
    1,427
  8. ZepTepi
    Replies:
    1
    Views:
    877
  9. ZepTepi
    Replies:
    10
    Views:
    3,463
  10. ZepTepi
    Replies:
    4
    Views:
    5,347

Share This Page

Loading...