1. Download our Official Android App: Forums for Android!

[Verizon] Google talk is pissing me off, would appreciate some help

Discussion in 'Android Devices' started by kg2128, May 2, 2012.

  1. kg2128

    kg2128 Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    43
    Posts:
    197
    Joined:
    Jul 2, 2010

    Jul 2, 2010
    197
    34
    43
    Just to clarify I am on AOKP Milestone 5 with the 4/22 Gapps. I am probably in the minority but I don't like Google Talk or gchat on my phone, and it comes with Gapps and it auto signs in, so it is very annoying.

    Up till now no matter what Rom I was on, I just used the ICS disable feature and the program wouldn't run. This time even after I disabled it in Apps it somehow auto signed on and I kept getting messages. So I said okay screw it I will permanently delete with Titanium Backup.

    Now I check my phone and I am still signed on and receiving Google Talk notifications. Even though the Talk app is deleted, "Google messaging service" was running and I kill that and the notifications disappear. I can't find google messaging service anywhere to delete/uninstall it. Is there some better way to get rid of Google talk on my phone? The crazy thing is I never opened Talk once after flashing the latest AOKP, it should not sign on on run ever.
     

    Advertisement

  2. VoidedSaint

    VoidedSaint Resident Ninja
    Rank:
    None
    Points:
    423
    Posts:
    8,201
    Joined:
    Feb 10, 2010

    Feb 10, 2010
    8,201
    2,090
    423
    Male
    Virginia
    i just usually sign off of it, and leave it signed off and it will still update but it will be signed off so you wont have to worry, however, whenever you install gapps, it will turn itself back on.


    you can if you want download and install 7Zip open the .zip file of gapps, and delete Talk.apk and it wont install it, but you also might take a risk of things not working properly.

    i just prefer to log off of gtalk whenever i flash a new rom or gapps
     
    kg2128 likes this.
  3. kg2128

    kg2128 Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    43
    Posts:
    197
    Joined:
    Jul 2, 2010

    Jul 2, 2010
    197
    34
    43
    Thanks I'll give that a shot (deleting it from gapps). I've signed out and disabled auto sign-in in the past (while leaving talk installed) and still had the random sign-in issue, but I haven't combined it with the deleting before. Hopefully one of those 2 solutions will work.
     
  4. PhilosoRaptor

    PhilosoRaptor Android Enthusiast
    Rank:
    None
    Points:
    93
    Posts:
    722
    Joined:
    Jan 26, 2010

    Jan 26, 2010
    722
    108
    93
    US Army - 25B (I.T. Specialist)
    Ft. Knox, KY
    Are you sure "Google Messaging Service" isn't the SMS ("messaging") app? Gtalk just shows up as "gtalk" for me when I look at running apps/services.
     
  5. kg2128

    kg2128 Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    43
    Posts:
    197
    Joined:
    Jul 2, 2010

    Jul 2, 2010
    197
    34
    43
    Yeah it wasn't a text, got a couple messages from different people all google talk messages. Also unlike a text, pressing the notification did nothing because I already deleted talk.
     
  6. jkc120

    jkc120 Android Expert
    Rank:
    None
    Points:
    313
    Posts:
    2,266
    Joined:
    Apr 12, 2010

    Apr 12, 2010
    2,266
    1,107
    313
    Senior Software Engineer
    El Dorado Hills, CA
    Like you, I prefer not to have google talk on my phone. It was causing wakelocks for me, and I just don't want to be "that accessible" at all times :)

    I've had good success with Titanium Backup and freezing the google talk app. Note that as stated earlier in the thread, if you re-flash gapps you'll need to re-freeze it (or sign out). I still see some gtalk stuff in better battery stats with it frozen, but I am NOT getting inbound gtalk notifications or conversations. Give the freezing trick a shot!
     
Tags:

Share This Page

Loading...