Root [Verizon] GPS not working


My GPS has never worked well (I've had the phone since launch) but I haven't had the opportunity or motivation to deal with it.

A few months ago I rooted in the hopes that that might help, it didn't.

I did some reading and came across the suggestion to remove the battery cover and tighten the screws. That worked for a day.

Now it is back to not working. I tried the screws again but they were all snug and it didn't make a difference.

I finally called Verizon and they want me to do a factory reset. If that doesn't work then they'll replace it under warranty.

What will happen if I do a factory reset while rooted? I'm fine with losing root and if I'm going to return it for a warranty replacement I'd want it clean first anyway.


~30% Carbon Black ±
All you will lose in a factory reset while rooted is your apps/contacts/settings etc.
It will be as if you just flashed the rom:)
Nandroid backup just in case ;)


Thread starter
So this is basically flashing the stock ROM?

Also, assuming this doesn't work (and I have no reason to believe it will) and I need to swap it out under warranty, what all should I do with the phone before I send it back?

Is just the factory reset (and pulling my SD, obviously!) enough or should I "un root"?

Edit...never mind, a friend just pointed me towards this page:
Many people have been able to tightened the screws and get gps to pick up. If they send you another phone it will be a refurb so if you take care of your stuff its worth giving the screws a shot.

Sent from my SCH-I535 using Tapatalk 2