1. Are you ready for the Galaxy S20? Here is everything we know so far!

[Verizon] Help, Soft Bricked!!

Discussion in 'Android Devices' started by Namrak, Jan 31, 2012.

  1. Namrak

    Namrak Android Expert
    Thread Starter

    So I was doing the usual fastboot commands to unlock my nexus, and all was well. I hit reboot, and in the middle of the boot animation screen the phone went dead. I did NOT pull the battery. Anyways It keeps bootlooping on the initial google screen. I followed instructions from here How to: Unroot the Galaxy Nexus, Re-lock the Bootloader and Return to a Factory State – Droid Life . Basically I flashed all the stock images back and when I rebooted I had the same bootlooping issue. Went into recovery mode and did a complete data wipe and still having issues. Help Please?


    Edit: Does ANYONE HAVE ANY IDEAS Please??!!!

    I have tried flashing stock manually-it seemed to not work but upon reboot it went into bootloop again

    I have tried using ODIN which said it flashed properly but upon reboot got bootloops again

    I have a nandroid backup on my desktop (from a previous phone) which I have tried to flash using fastboot commands-it didn't work but I may be doing this wrong

    I tried using the unlock/lock+root/unroot toolkit-clicked to "flash stock+unroot" and it processed fine but phone went into bootloop upon restart

    ANY help is greatly appreciated!
     



    1. Download the Forums for Android™ app!


      Download

       
  2. Yeahha

    Yeahha Usually off topic

    Is this your third phone? I know you have been having issues previously.

    Can you boot into fastboot?
     
  3. Namrak

    Namrak Android Expert
    Thread Starter

    Yup third phone. I was hoping to get this one working lol.

    Yeah I can boot into fastboot and it recognizes under "fastboot devices" just fine
     
  4. Namrak

    Namrak Android Expert
    Thread Starter


    Not sure if this helps but I still have two other rooted gnexs with me (I haven't returned yet) if I can somehow get the nandroid from them and copy it to my soft bricked phone (which was cwm but is not rooted as It keeps getting errors)?
     
  5. Yeahha

    Yeahha Usually off topic

    You should be able to use nandroid fine. If you are getting these issues I wouldn't root it. I still think you need to test a new phone plenty before rooting it so you don't try to root a problematic refirb
     
  6. Namrak

    Namrak Android Expert
    Thread Starter

    Can you explain how this would work? The nandroid is on my other phone. How would I go about transferring it to the broken phone bc whenever I go to do a restore (on the broken phone) in cwm as of now it has nothing (as expected)

    You're right, before tinkering with it the phone should be thoroughly tested first. I was pretty happy though bc I got a new phone (checked by dialing *#*#786#*#* and reconditioned status was "NO"). However, you're right that it should still be tested.

    Edit: whenever I try to push anything to the sdcard i get an error on my laptop saying "failed to copy...............: is a directory. And when I select choose zip from sdcard in CWM on my phone it says "no files found"
     
  7. Namrak

    Namrak Android Expert
    Thread Starter

    This is getting frustrating. Tried restoring through Odin 3 and I'm still getting bootloops
     
  8. drdoom

    drdoom Android Expert

  9. Namrak

    Namrak Android Expert
    Thread Starter

    I already tried this. (Boot into fastboot, click "flash stock+unroot.) Am I missing something?

    Edit: The "flash to partition" option on this might be helpful as I do have a nandroid (from a previous gnex) on my comp. Do you know if it guides you through the process on how to flash a nandroid. I tried doing it manually yesterday but it was a no go. Maybe I'll have better luck using this..
     
  10. Yeahha

    Yeahha Usually off topic

    I noticed your other thread. If SA got your issue fixed please let me know. Otherwise while in recovery you should be able to use ADB to push the nandroid to your phone then restore it.

    You would need to use ADB to push it to /sdcard/clockworkmod/backup
     
  11. Namrak

    Namrak Android Expert
    Thread Starter

    I did this by flashing cwm
    adb push 2012-1-14-20.22.37 /sdcard/clockworkmod.backup
    It pushed the system.ext.4.tar
    It pushed the recovery.img
    It was IN THE PROCESS of pushing data.ext4.tar when it came up with "protocol failure" My nexus then turned off and booted onto the screen with the android guy and a red triangle on top of him. After a few minutes of sitting at that screen it began to bootloop again...
     
  12. Yeahha

    Yeahha Usually off topic

    I think you need to push the folder not the individual tar files.

    I am beginning to think you got a defective device actually which I would work on trying to lock it and get it back to factory then get yet another.
     
  13. Namrak

    Namrak Android Expert
    Thread Starter

    I did push the file(seen in post above) but then when it ran it I guess it pushed the tar files separately?

    How would I lock it back? whenever i do a fastboot oem lock and choose the option to lock on the phone it says complete, but whenever I reboot it shows as unlocked again
     
  14. Yeahha

    Yeahha Usually off topic

    Yeah I just read your post again. It did make sense that is pushes the tar files individually...[facepalm]

    Do you have the stock recovery on the phone?

    Edit: I just saw the other thread again...I hope SA will be able to help further with this, I can't do the same things he can ;)
     
  15. Namrak

    Namrak Android Expert
    Thread Starter

    Like the stock files from google?

    Edit: Lol I hope so too. Thanks for trying! If you think of anything else please let me know :)
     
  16. scary alien

    scary alien not really so scary
    VIP Member

    Yeah, I'm beginning to think there's a problem with the internal memory (too many bad blocks or something)...

    +1 ^^^

    Things aren't acting like they should...the current flash back to stock should help confirm since he's doing exactly what I did 30 minutes ago...

    You're doing it right...fastboot oem lock is the right command...

    LOL, I see Namrak's been two-timing me with you, Yeahha behind my back! :mad: :p ;) :D

    (or is it me two-timing with him behind your back? LOL :p :))

    Still crossing my fingers....
     
    Yeahha likes this.
  17. Namrak

    Namrak Android Expert
    Thread Starter

    Hah! just expanding my sources of information...:D. Yeah at this point I'm just trying to get the unlock icon to go away so I can send it back
     
  18. Yeahha

    Yeahha Usually off topic

    I knew he was staff cheating with someone...nvm that just sounds weird...maybe I should go condemn tethering or something...;):p:eek:

    @Namrak If I can think of anything else I will suggest it. That little lock on the splash is really a tell. I have never used ODIN but it may work. I know Samsung people use ODIN for a lot and that may be able to get you back to stock...
     
    scary alien likes this.
  19. Namrak

    Namrak Android Expert
    Thread Starter

    These are the results I got when using Odin. The last 6 lines are especially interesting...I'm sure the "removing" isn't a good thing

    <ID:0/003> Added!!
    <ID:0/003> Odin v.3 engine (ID:3)..
    <ID:0/003> File analysis..
    <ID:0/003> SetupConnection..
    <ID:0/003> Initialzation..
    <ID:0/003> Get PIT for mapping..
    <ID:0/003> Firmware update start..
    <ID:0/003> radio.img
    <ID:0/003> Removed!!
    <ID:0/003> Completed..
    <OSM> All threads completed. (succeed 1 / failed 0)
    <ID:0/004> Added!!
    <ID:0/004> Removed!!
    <ID:0/004> Added!!
    <ID:0/004> Removed!!
    <ID:0/004> Added!!
    <ID:0/004> Removed!!
     
  20. Yeahha

    Yeahha Usually off topic

    I have never used odin before so I am not sure what that means or if it is how it should work...it does look very counterproductive
     
  21. iowabowtech

    iowabowtech root@android:/ #

    After quietly following this, I'm beginning to think this MAY be the cultprit. I wonder if anyone has verified fsck for the Nexus? Be interesting to know how /data and /system check out. Might even be able to repair them if this is indeed the issue. I'm just not sure what to list as a command for this phone to try it.
     
  22. Namrak

    Namrak Android Expert
    Thread Starter

    Yeah this is beyond me. Maybe someone else can shed some light on this...
     
  23. scary alien

    scary alien not really so scary
    VIP Member

    Yeah, for the Eris, there were some mtdutils that erisuser1 brought to light. I tried using the MTD_Inspect script he put together on my GNex, but the script tries to parse through the /mtd# partitions and there's only one reported on my GNex (cat /proc/mtd only yields mtd0 and I couldn't get the nanddump utility to work).

    I just don't understand how the internal memory is laid-out on the GNex nor what are the proper utilities for scanning (and possibly fixing/resetting) the status of any bad blocks, etc.

    Its only my list of things to research, but I don't know it yet...(wish I did ;)).
     
  24. iowabowtech

    iowabowtech root@android:/ #

    Well, I know many roms moved toward ext4 but I'm not sure what the stock file system was to be honest. I wasn't successful:

    c:\android-sdk-windows\platform-tools>adb shell
    ~ # e2fsck /dev/block/mmcblk0p2
    e2fsck /dev/block/mmcblk0p2
    e2fsck 1.41.6 (30-May-2009)
    e2fsck: Superblock invalid, trying backup blocks...
    e2fsck: Bad magic number in super-block while trying to open /dev/block/mmcblk0p2

    The superblock could not be read or does not describe a correct ext2
    filesystem. If the device is valid and it really contains an ext2
    filesystem (and not swap or ufs or something else), then the superblock
    is corrupt, and you might try running e2fsck with an alternate superblock:
    e2fsck -b 8193 <device>


    I just don't have enough knowledge on this device yet to troubleshoot the partitions with any degree of confidence.
     
    Namrak likes this.
  25. Namrak

    Namrak Android Expert
    Thread Starter

    Yeah I'll create an account and pm wugfresh in the morning and see what he says
     

Galaxy Nexus Forum

The Galaxy Nexus release date was November 2011. Features and Specs include a 4.65" inch screen, 5MP camera, 1GB RAM, TI OMAP 4460 processor, and 1750mAh battery.

November 2011
Release Date
0
Reviews
Loading...

Share This Page

Loading...