1. Check out our companion app, Forums for Android! Download from Google Play

Root Verizon is blocking my tethering.

Discussion in 'Android Devices' started by jeaucamom, Oct 27, 2011.

  1. jeaucamom

    jeaucamom Active Member
    Thread Starter

    Feb 27, 2011
    ERG!!!!! Verizon did an update in the middle of the night a few nights ago. And now I can't tether. My EasyTether Pro doesn't work. My Open Garden doesn't work. It automatically redirects me to dunsp.vzw.com etc. I have no way to get online at home now!!!! ERG!!! Please help me find a way around this! I am rooted but I can't find any tether app that works.


  2. Goodspike

    Goodspike Well-Known Member

    Dec 28, 2010
    Is this a big surprise, given that they want to charge you something like $10 a month to tether, and bandwidth is at a premium?
  3. JDunc

    JDunc Well-Known Member

    Aug 23, 2010
    Image Processor
    $20 I believe
  4. Goodspike

    Goodspike Well-Known Member

    Dec 28, 2010
    You're probably right, and that makes it half as surprising. ;)
  5. scary alien

    scary alien not really so scary

    Mar 5, 2010
    space alien ;)
    Thread moved to the all-things-root sub-forum.

  6. trudj

    trudj New Member

    May 11, 2012
    Verizon is messed up, you buy 2 gas of Mobile Date you get 2gbs of Mobile Data, Regardless of its TOS, it is still a violation of the Fair Use Act for Verizon to tell you how you can and connote use the data service you already pay for.

    I have a droid 3 and have had success with the following procedure on a droid 2/3/and X. Great especially if you are grandfathered into the unlimited data plan.

    1st. You need the most recent drivers for your computer so that your computer can see your phone. You can get them off the Motorola website, same as if you were going to use adb or RSDlite. The file I downloaded from the moto support site was called MotoHelper_2.0.49_Driver_5.0.0.exe

    2nd. You need a copy of Radiocom. Radiocom is a piece of software thats supposed to be for moto employees only and allows you to read and write data directly to your software radio. See Post Below to for link. You also need the .net framework installed on your computer. You can get that from Microsoft's site for free.

    3. You need a USB cable and a droid 3.

    Now the Fun Part

    1. Install the moto drivers and the .net framework. Install Radiocom. It will give you all sorts of errors, but it will install.

    2. Next, find it under your start menu. Right click on it, and select "trouble shoot compatibility" I just ran with the suggested settings. Basically what this does is run the application under XP compatibility mode. Now take a sip of beer, you are gonna get some error messages but don't tweak.

    a. You will still get the first screen that says do you want ot the following program from an unknown company to make changes on your computer - check yes.

    b. it will say motorola datacard drivers 1.5.9 : this installation is intended for 32-bit os versions only.please use the 64bit version on this machine. click okay.

    c. Installation incomplete: the installer was interrupted before motorola datacard drivers 1.5.9 could be instaled. You need to restart the installer to try again. hit close.

    d. Warning: Motorola Dataard Drier installlation package ersion mismatch. the version supplied with this tool does not match the installed version on the machine. WE cannot guiarantee proper radio enumeration unless you install the latest version. the installation package will start again the next tiem this tool is started. Click OK

    e. This version of RadioCOmm is more that 2 months old. This version may be out of date. Please visit the PDO compass webpage and download the latest version of RadioComm. - Click OK.

    Radiocom will start! Phew!

    you will have to select the chipset at start: I selected CDMA 1x (MSM 7500) w/ Android. I don't know if this is the best or most accurate one. I actually spent 45 minutes trying to search for exactly what our chipset base was... but I decided to be brave (or stupid) and went with this one and it worked. after it boots, Under settings in radiocom, USB, Select PST USB Driver.

    3. Now, Connect your droid 3 to your computer and put it in PC mode. If you installed the drivers correctly you should get this cool little screen showing your phone and telling you some info about it that pops up from motos software. in radiocom software in the upper right of the screen right under the RC logo, the lgiht should turn green to show the phone is connected. You can test by pushing the GET button under the SW version. It should return your Android software version. DON'T PUSH ANY OTHER BUTTONS. YOU COULD REALLY SCREW SOMETHING UP.

    Now a little background, Moto's software radio uses three different 128 char string identifiers for data requests. Thats how they can tell the difference between your phones web browser asking for data, and a laptop or Xoom connected to your phone asking for data. We are going to use Radiocom to make all three strings match the first string - so all data appears to be just for the phone. After doing so - your verizon installed hotspot app will work and the usb tethering option will too! ta da!

    3. now take a deep breath... use the arrows in the Radiocom program to find the tab marked P2K 1.

    Look at the image and in your Radiocom program in the bottom left there is a box called STELEM/ RDELEM. First Select Dec entries.

    Rdelem means read, and STELEM means write.

    now this is very very important. Do not screw this part up. make sure again you have selected Dec entries, because if you enter the numbers below in hex mode and then hit DEC they will change and you will be reading and writing the wrong values which is BAD.

    In Dec Mode

    For ElementID: enter 8040
    Record # 1
    offset 0
    length 128

    Now Hit RDELEM. the box in the top right should go green, a bunch of numbers should flash through but most importantly right next to where you entered the element ID and record number the box that says Data (hex only) will now have a 128 char string in there. Hilight the entire 128 byte string and copy it.

    4. You are now going to change the element ID to 8041 (record, offset, length stay the same) and hit RDELEM. If you compare these two numbers they are different, this is how moto knows you are tethering. You would have to paste both into a word file becuase they both end in a bunch of 00's so in the tiny data box they look the same, but trust me they are different. Select the data in the databox for 8041 and delete it. Paste the number from 8040. Now hit STELEM. Again you should see a bunch of numbers go through that box on the top right and it should be green.

    5. Now you are going to do the same things for element numbers 8042, and 8043. Remember each time to hit RDELEM first, paste the value from 8040, then hit STELEM.

    6. Now hit the restart button next the text box top center. You phone will restart. it will say something scary at first like SIm card not found. This is normal. Give it a Second and it will be right back to normal, you will have your 3G icon and be able to make calls, send texts etc.

    No Root Ruined, just open Verizon's Pre Installed Tethering App, It works OTB. Thanks Verizon for allowing me one more opportunity to learn "How it Works. and How to beat It."
  7. Primevci

    Primevci New Member

    Aug 5, 2012
    trudj thanks i was nervous doing it but it worked your awesome. I registerd jsut to tell you thank you.. im one of those grandfathered unlimited plan guys... This worked on my droid 2

Share This Page