1. Are you ready for the Galaxy S20? Here is everything we know so far!

[Verizon] Kernel help - I think I'm an idiot

Discussion in 'Android Devices' started by Liebensaft, Dec 30, 2011.

  1. Liebensaft

    Liebensaft Member
    Thread Starter

    My CDMA Nexus has been rooted for a few days now. I decided to start checking out the ROMs and kernels being made. Basically, I accidentally flashed a kernel meant for 4.0.3 over stock and rooted 4.0.2. Now, I can boot to recovery and the bootloader, but cannot reboot normally. I know I'm not totally screwed, but how am I supposed to get a new (stock 4.0.2 or otherwise) kernel on the phone for flashing? It's not being recognized by my laptop and I can't use dropbox for the file transfer if I can't boot it normally. Wish there was an SD card I could just pull and pop into the computer.

    Please help me figure this out so I feel less helpless. Thank you!

    edit: Did a factory wipe through recovery and it still doesn't boot. Is there an option besides un-rooting, etc? And if not, how do I even do that? Why would I not just make a backup before flashing....
     



    1. Download the Forums for Android™ app!


      Download

       
  2. scary alien

    scary alien not really so scary
    VIP Member

    Liebensaft,

    I'm thinking that you could flash the stock 4.0.2 boot.img file via fastboot (the boot.img file contains the kernel).

    I'll give you a quick outline and see if you need any gaps filled-in:

    - download the stock 4.0.2 image package (.tgz) file from Google

    - extract the contents to a working directory

    - extract the image-*.zip file to another working directory (that's where the stock boot.img file will be)

    - do a fastboot flash boot boot.img to overwrite the currently installed boot.img (which contains the kernel)

    Note: I've not yet flashed a new kernel on my GNex yet and one of the threads I've read indicates that doing a cache wipe is necessary. I don't know if that would be re-needed in this case after you flash the stock boot.img file.

    Make sense?

    Let me know.
     
    Liebensaft likes this.
  3. Yeahha

    Yeahha Usually off topic

    Try wiping cache and dalvik cache in recovery to see if that will allow you to boot normally.

    Other than that if you can push (via adb or fastboot) a kernel to it you should be able to flash it in recovery. Or push a rom and flash it.
     
    Liebensaft and scary alien like this.
  4. scary alien

    scary alien not really so scary
    VIP Member

    Yeahha,

    This issue seems familiar...I'm thinking you replied to something similar the other day/evening, right?
     
  5. Yeahha

    Yeahha Usually off topic

    Yes someone was asking about flashing a theme that failed. I had him make a backup before the flash. It is reasons like this that everyone should backup before any flash, you never know if something will screw up. I learned the hard way too, it is a PITA to learn this way but a good lesson to learn.
     
    Liebensaft likes this.
  6. Liebensaft

    Liebensaft Member
    Thread Starter

    Thank you both for your help. I'm connected to my laptop in fastboot mode on the phone. I'm using the terminal to navigate to the folder where the clean boot.img file (taken from the .tgz file from Google) is stored. When I try to use the command to flash it, I get

    "unknown partition 'boot.img'
    error: cannot determine image filename for 'boot.img'"

    I'm using OS X and the command "./fastboot flash boot.img" I'm not sure what I'm doing wrong. Basically, using a MacBook, what can I do while my phone is connected in fastboot mode to fix it? Wiping the cache, dalvik cache, and doing a factory reset in recovery all yielded no results. When I try to boot normally, I get the google logo and the unlocked symbol at the bottom and it never gets past that screen. This is a little frustrating.

    edit: after looking around a little bit more and trying to find ways to flash ROMs using fastboot mode, I'm convinced that I've managed to find my own corner of electronics hell. Firstly, using a Mac means that none of the instructions on the internet acknowledge your existence, and secondly, I don't know what is happening, but none of the commands I CAN find seem to be doing anything. They all give errors or just do nothing for me. Needless to say, my anxiety levels are rising dramatically. What would a Verizon rep even say if I brought the thing in like this? I'm at the end of my rope and I wanna snap the thing in half.
     
  7. scary alien

    scary alien not really so scary
    VIP Member

    Liebensaft,

    No worries...I think I know what is amiss, but first, have you tried doing the wipes that Yeahha suggested above?:

    "Try wiping cache and dalvik cache in recovery to see if that will allow you to boot normally."

    If you do still want to flash the boot.img file, I think the issue you're having is that you are missing the "boot" part of the command. You want to type this:

    ./fastboot flash boot boot.img

    (the boot part tells fastboot which partition you want to flash/overwrite).

    Let us know :).

    Cheers!
     
    Liebensaft likes this.
  8. Liebensaft

    Liebensaft Member
    Thread Starter

    It looks like all I was missing was the extra "boot" when typing in the command. All of the wipes in recovery didn't help me, but once I navigated to where the clean boot.img file was and added the extra word in the command, I was able to boot normally. Fresh, clean, missing apps and settings, but working again! Thanks again for your help.
     
    scary alien likes this.
  9. Steven58

    Moderator

    PS.. you're not an idiot. You are a highly valued member. Just pay the help you get here forward to someone else who may need it!
     

Galaxy Nexus Forum

The Galaxy Nexus release date was November 2011. Features and Specs include a 4.65" inch screen, 5MP camera, 1GB RAM, TI OMAP 4460 processor, and 1750mAh battery.

November 2011
Release Date
0
Reviews
Loading...

Share This Page

Loading...