1. Are you ready for the Galaxy S20? Here is everything we know so far!

[Verizon] [ROM] [JB 4.2] XenonHD Stable-11.1 (7/3/13)

Discussion in 'Android Devices' started by NSutherl, Jul 22, 2012.

  1. CopperWires

    CopperWires Android Enthusiast

    What is going on with this ROM? The latest one is so laggy. In some cases I'm counting seconds for things to show up or transition. I guess it could be some apps that I have installed but I have tried turning closing everything out and its still slow.

    I guess I'll move on to another ROM until the next update of XenonHD. Any suggestions on where to go from here? Sourcery maybe? I would like something similar.

    1. Download the Forums for Android™ app!


  2. p-bOt

    p-bOt Android Expert

    Codename android is where it's at if you are waiting on some good 4.2 roms
  3. viper689

    viper689 Android Expert

    4.2 RC1 is up on RootzWiki!
  4. p-bOt

    p-bOt Android Expert

    Just flashed... Its pretty nice I like it. Definitely better than the past few updates.
  5. NSutherl

    NSutherl Android Enthusiast
    Thread Starter

    OP updated for RC1 (11/25)
  6. NSutherl

    NSutherl Android Enthusiast
    Thread Starter

    OP updated for RC2.1 (11/30)
  7. NSutherl

    NSutherl Android Enthusiast
    Thread Starter

    I'm running RC2.1 now and it's great. This is the first 4.2 ROM I've used with more than just the most basic of mods. It's about as smooth and snappy as the stock 4.2 roms, and has a good number of the mods that were in 4.0 Xenon.
  8. in2uition

    in2uition Android Enthusiast

    Any links to the GApps? The one on RW is down.
  9. NSutherl

    NSutherl Android Enthusiast
    Thread Starter

    The link was down for me too. FWIW I'm using a common 11/22 4.2 gapps package with no issue.
  10. ymDroid

    ymDroid Well-Known Member

    Flashed RC2. Overall no problems except for the clock.

    When I try to add an alarm the click app crashes.

    Any ideas? I kind of need my alarm clock.


    EDIT: Fixed it. Titanium restored my old clock data. Wiped data and detached it from auto back up.
  11. ymDroid

    ymDroid Well-Known Member

    Great ROM very smoth. With Lean Kernel 4.2, the battery life is amazing.

    70% after 8 hours. After AOKP's battery life massacure, it's a relief to use Xenon again.

    The only glicth I see after two days is that the wifi toggle on notification menu doesnt show a picture. it still toggles wifi on and off, but the blue icon is not there.

  12. dockmaster

    dockmaster Well-Known Member

    I just flashed 4.2.1 and it works fine.
    I used this Gaaps, guess its the right one....works fine!!
    Index of ./roms/gapps-4.2/

    I had a hiccup with my first gaaps try (think I had a totally wrong one....my bad) and tried to restore from recovery my nandroid....it couldn't find file even though its there.....

    finally just went to the browser and typed in the addy for a gaaps and dwnloaded it and everything is peachy again....I guess at some point I should go back in and set permissions again?

    BTW...my wifi notification icon is working fine!!

    Guess lean kernel is next


  13. sourcery is laggy too. i've tried all 4.2 kernels.
  14. ckelly33

    ckelly33 Android Expert

    As is jelly belly from time to time.
  15. p-bOt

    p-bOt Android Expert

    This ROM has been rock solid and super buttery for me since its been updated to 4.2.1... I'm very pleased. And trust me I HATE LAG! battery life is pretty awesome too
  16. scoobntaz1996

    scoobntaz1996 Well-Known Member

    ok i got a quick and probably a silly question. i am new to the nexus but not new to rooting and flashing roms. i see everywhere that it says to put the rom and gapps on the sd card? but there is no sd card slot on the nexus. so i am assuming (i know dangerious lol) they go on the root of the phone memory. i am bootloader unlocked and rooted and have twrp installed for recovery. my question is when you go to wipe data to do a clean install it says it will wipe all internal memory. so if i do that the rom and gapps i just put on the phone will not be there. or am i missing something? thanks. if this is in the wrong post i'm sorry. i just put it here because this is the rom i want to run.
  17. there's a non removable sd card inside. factory wipe doesn't wipe the sd card. that's where the rom your going to flash is stored.
    NSutherl and scoobntaz1996 like this.
  18. scoobntaz1996

    scoobntaz1996 Well-Known Member

    ok a little lost again. when i connect my phone to my pc i get option to open the phone file. but i do net see anything on there as to where to put my rom files?
  19. CopperWires

    CopperWires Android Enthusiast

    I leave everything in \sdcard\Download.
  20. CopperWires

    CopperWires Android Enthusiast

    Which Gapps should I be using for the latest version?
  21. NSutherl

    NSutherl Android Enthusiast
    Thread Starter

    You can put your ROM files anywhere on the internal storage (sd card). When you go to flash the ROM in TWRP, you will browse for the location of the file, so as long as you remember where you put it, you can put it anywhere.
  22. NSutherl

    NSutherl Android Enthusiast
    Thread Starter

    The gapps link on the rootzwiki page seems to have been down for a while. I've been using 12/2 gapps from jakeday's JellyBelly page on rootz.
  23. scoobntaz1996

    scoobntaz1996 Well-Known Member

    i think that is where my problem is. i have no option to select sdcard. when i click on the drive it just gives me regular folders like ringtones, media, twrp and things like that. also i have put the rom on the interenal storage and when i selected wipe data in twrp it completly wiped everything on my phone and the files were gone. what i did do is wiped dalvik, dalvik cache, then wiped data. rebooted phone and put the files back on the phone and rebooted into recovery and installed the rom, gapps and everything seems to be working fine.

    here is a pic of the options i have when i open the drive for the phone on my pc. realize the files are there because of what i did before. if i run twrp and wipe data they are gone.
  24. NSutherl

    NSutherl Android Enthusiast
    Thread Starter

    I'm not quite sure I follow everything you're saying but here's some more info that might help clear some things up:

    The folders you see in the screen shot above are located on the sdcard on your phone. If you were to look for that folder on using a file explorer on your phone, the location of the Alarms folder would be


    As far the wipe data issue goes, if you are using TWRP, the process when clean wiping and flashing is this:

    from the main menu of TWRP, click "wipe"
    in the wipe menu select cache, dalvik cache, factory reset, and system.
    go back to the main menu, then click "install"
    in the install menu, browse for the ROM file, select it and install
    go back to the main menu, then click "install"
    in the install menu, browse for the gapps file, select it and install
    reboot system

    You can also add zips to the queue and flash multiple files in the same go.

    None of the wipes above clear data from you sdcard (internal storage). The factory reset erases all of the user data associated with the ROM.
    scoobntaz1996 likes this.

Galaxy Nexus Forum

The Galaxy Nexus release date was November 2011. Features and Specs include a 4.65" inch screen, 5MP camera, 1GB RAM, TI OMAP 4460 processor, and 1750mAh battery.

November 2011
Release Date

Share This Page