1. Check out our companion app, Forums for Android! Download from Google Play

[Verizon] [SOLVED][HELP] Galaxy Nexus Rooting: Issue with ADB/FASTBOOT [HELP][SOLVED]

Discussion in 'Android Devices' started by Edward Oak, Aug 15, 2012.

  1. Edward Oak

    Edward Oak Member
    Thread Starter
    6

    Aug 11, 2012
    9
    1
    6
    Hi,

    I'm a new User and I was following "Scary Alien" tutorial on rooting the GNex.
    So I followed the guide and my device was recognized by the command: fastboot devices

    So, I tried "adb push su.zip /sdcard/"
    and got the following error message: Error, device not found.

    So I contacted Scary Alien and we tried several things, including: "Unplugging-replugging;Re-install drivers;RestartBootloader;kill-server."

    Still without success.

    So after awhile I realized that when I plug my USB in fastboot mode, I get the error: Fastboot Command Read Error - 2147483647

    I searched a little bit on the internet and only got "re-install driver" tips.

    I re-installed the drivers over 5 times now. This is not working.

    Can someone please help me root my GNex?

    - Eddy
     

    Advertisement

  2. Edward Oak

    Edward Oak Member
    Thread Starter
    6

    Aug 11, 2012
    9
    1
    6
    I also applied "fastboot boot boot.img"

    So maybe the issue is relative to the image I'm currently on (speculations)
    I even tried a factory reset and it's still doing the same thing.

    I think I should apply the default GNEX 4.1 Default image.

    What do you guys think?
     
  3. Tim K

    Tim K Well-Known Member
    183

    Nov 2, 2009
    1,649
    471
    183
    Male
    Phila, PA
    are you sure your device is recognized? If you connect your phone to your PC can you "see it" as a drive? The Nexus is notorious for being a pain in the ass to get drivers working for it on a PC.
     
  4. Edward Oak

    Edward Oak Member
    Thread Starter
    6

    Aug 11, 2012
    9
    1
    6

    Yep, it's recognized by windows AND fastboot (cmd: fastboot devices)

    You specified "PC"

    Do you think I'd have a better chance on another OS (With or Without WINE)?
     
  5. Edward Oak

    Edward Oak Member
    Thread Starter
    6

    Aug 11, 2012
    9
    1
    6
    I think I might know what the error source was.

    My "Developper Options" were OFF even tho USB Debug was enabled (This probably happened during the boot.img application.)

    I'll try it again and upload results.
     
  6. Edward Oak

    Edward Oak Member
    Thread Starter
    6

    Aug 11, 2012
    9
    1
    6
    Issue still not resolved.
     
  7. ritchea

    ritchea Well-Known Member
    43

    Nov 2, 2010
    134
    34
    43
    south central Florida
    I would suggest USBDeview to make certain all the old devices are gone, but you said that your device does show up on fastboot devices command. I had some issues and this helped get rid of everything (even though I thought I had through right-click delete). Maybe the link will help others who don't get that far.
    Just read this "A tiny postscript to this article. I had some issues connecting my computer to fastboot(adb worked fine). When I would make the connection, I would get the error "Fastboot Command Read Error -2147483647" and in Windows Device Manager I would see the device as fastboot but with the error "Device cannot start". These were resolved by moving to a different USB port." at another site. It's worth a try.
     
    Edward Oak likes this.
  8. maxal

    maxal Member
    6

    Jun 19, 2011
    7
    1
    6
    Edward Oak likes this.
  9. Edward Oak

    Edward Oak Member
    Thread Starter
    6

    Aug 11, 2012
    9
    1
    6
    Thanks, I'll try Maxal's toolkit and try this right afterwards.
     
  10. Edward Oak

    Edward Oak Member
    Thread Starter
    6

    Aug 11, 2012
    9
    1
    6
    The issue seems relative to ADB. Could maybe re-installing the SDK Manager would help?
    PDANet had issues with installing drivers and Toolkit is having issues with checking adb.


    What do? Please, somebody help.
     
  11. VoidedSaint

    VoidedSaint Resident Ninja
    323

    Feb 10, 2010
    8,201
    2,090
    323
    Male
    Virginia
    Even though this thread is a few days old, since it has to deal with rooting, and by scary aliens technique, then it needed to be moved to the galaxy nexus all things root
     
    jmar likes this.
  12. jmar

    jmar Nexican
    523

    Sep 27, 2010
    4,851
    3,131
    523
    Male
    Sales
    San Jose, CA
    Link to the easiest way to do this in Windows: http://www.galaxynexusforum.com/for...wugs-galaxy-nexus-root-toolkit.html#post22678

    Or if you can get to a Linux based OS machine soon, I can walk you through it over gtalk.

    jmar

    Ninja'd on the WugFresh root toolkit.:D
     
  13. Edward Oak

    Edward Oak Member
    Thread Starter
    6

    Aug 11, 2012
    9
    1
    6

    Issue is now resolved.

    How did I fixed it:

    -Re-created Windows Profile.
    -Made sure no drivers relative to the GNex were installed.
    -Tried in another USB port.
    -Plugged in Debug mode.
    -Windows automatically downloaded the Driver "Galaxy Nexus" and failed downloading "Galaxy Nexus Interface"
    -Used the generic Drivers from on this forum to update the GNEX Interface driver

    Verified if ADB was working with cmd: adb push su.zip /sdcard/

    Worked (I was so happy to see "successful" instead of "error")

    I think the root source of the issue was either the USB port or some drivers errors.

    Last time I checked, the driver for "Debug" was labeled: " Samsung Mobile Phone Bootloader Interface".
    After I re-plugged it in another port to start a full driver install, it was labeled "Galaxy Nexus Interface".

    Anyways. Thanks for your help.

    Next time someone has a similar issue, simply tell him to "trial and error" with ports/computers/OS/Drivers.


    Thanks again.

    On that, I'm out... PEACE.

    - Eddy
     
    jmar likes this.
  14. Edward Oak

    Edward Oak Member
    Thread Starter
    6

    Aug 11, 2012
    9
    1
    6
    P.S.

    Mods, I'm unaware of how to close/lock a thread. Please close/lock the thread.
     
  15. jmar

    jmar Nexican
    523

    Sep 27, 2010
    4,851
    3,131
    523
    Male
    Sales
    San Jose, CA
    I think this thread is a good resource from which to learn. Maybe others will find it useful. How about keeping it open to help the community?

    jmar
     
Tags:

Share This Page

Loading...