1. Are you ready for the Galaxy S20? Here is everything we know so far!

[Verizon] Stuck in Recovery/Fast Boot

Discussion in 'Android Devices' started by StockAndroid, Jul 2, 2013.

  1. StockAndroid

    StockAndroid Lurker
    Thread Starter

    My Galaxy Nexus has been rooted for several months. I have been running AOKP JB-MR1 build 5 the entire time with no major issues. I originally rooted and rom'd using Wugs toolkit.


    Yesterday I noticed my phone was getting warm and when i took it out of my pocket the screen wouldn't come on. After a battery pull it booted into recovery and asked for a password, but I never encrypted the phone.

    This is where I'm still stuck. I can get into the bootloader or into recovery. I can cancel the password prompt in recovery and access the recovery options but it displays errors like "unable to mount '/cache' or "unable to mount internal storage".

    Factory reset and Wipe Internal Storage from within Team Win recovery both fail citing unable to mount errors. Wipe System completes "successfully" but still gives unable to mount errors.

    I used Wugs to boot temporarily to the stock recovery and tried a factory reset from there which said it completed but after a reboot the system loads back into Team Win recovery and still asks for a password.


    At this point I don't care about recovering the data. I just want to get the phone running again.

    Anyone have any ideas?
     



    1. Download the Forums for Android™ app!


      Download

       
  2. trophynuts

    trophynuts Extreme Android User

    yes. use ADB to unbrick it and restore it to stock.
     
    StockAndroid likes this.
  3. StockAndroid

    StockAndroid Lurker
    Thread Starter

    Thank you, I followed the instructions but the phone doesn't seem to be accepting the new data.

    For Example: "fastboot flash radio radio-toro-i515.fk02.img" returns the following lines in command prompt.

    sending 'radio' (10496 KB)...
    OKAY [ 0.970s]
    writing 'radio'...
    OKAY [ 1.289s]
    finished. total time: 2.259s

    After I reboot back into fastboot the baseband version hasn't updated and still reads I515.FG02.

    When I try to send the image-mysid-jdq39.zip file I get an error staying it failed the baseband version check, baseband is 'I515.FG02' update requires 'I515.FK02'.


    *Edit* After posing I hit start in fastboot, the google splash screen appeared then automatically went into fastboot giving the error FASTBOOT MODE - NO BOOT OR RECOVERY IMG

    the baseband version is listed as unknown now

    *Edit* Maybe I spoke too soon. After a few more reboots the Team Win recovery is back and in fastboot the baseband version is displayed again as I515.FG02.

    I'm at a loss and will just wait for more advice before trying anything else myself.
     
  4. iowabowtech

    iowabowtech root@android:/ #

    It may be worth trying a sequential update on your stock setup. It sounds like you were running 4.1.1 at the time of the troubles according to the baseband that seems to be the hangup. So perhaps try fastboot flashing stock 4.1.1 (JRO03O) and then if you get a booting phone, you can regroup from there. You can get the files here:

    https://developers.google.com/android/nexus/images

    I'd remove all the 4.2.2 files from your sdk's tools or platform-tools folder and replace them with the 4.1.1 files. Then CAREFULLY note and write down the file names for all the flashables as they will of course be different wording and you'll have to adjust your command set to those package names. Other than the file names, the general commands will remain the same as before. Personally, I don't use the reboot bootloader command between flashes but instead I just wait until each flash says its done before moving to the next. Up to you though, people have noted success both ways. Let us know if that works.
     
    StockAndroid likes this.
  5. StockAndroid

    StockAndroid Lurker
    Thread Starter

    I tried flashing with 4.1.1 and didn't get any errors, however the phone still doesn't boot. It sits at the Google splash screen considerably longer now, maybe 30 seconds, but then boots into custom recovery.

    The only suspicious thing I noticed during flashing is that when I flash the radio-cdma it takes about a third of a second to send but then takes 95 seconds to write. It does say it finished successfully.

    Anything else I can try?
     
  6. iowabowtech

    iowabowtech root@android:/ #

    That's pretty typical. That radio takes forever to write. Nothing wrong there.

    I'm sure there is, I'm just not coming up with it yet. I guess you could try to use your custom recovery you can't seem to overwrite to wipe system/data/cache/dalvik and try flashing a rom instead? If you don't already have a flashable rom on your internal storage, you could adb push one there.

    Or after the wipes (reformatting), try rebooting straight to the bootloader which is an option in TWRP and then re-run the 4.1.1 flash commands. I might try that first actually.
     
  7. jhawkkw

    jhawkkw Chinchillin'

    While in fastboot, did you perform any wipes? Since you claim to be unable to wipe cache or factory reset in recovery, where you able to do so while in fastboot?
     
    iowabowtech likes this.
  8. iowabowtech

    iowabowtech root@android:/ #

    Good point jhawk, I missed that in the OP. Might negate some of what I offered in my last post. Hmmm...gotta do some more head scratching here.
     
  9. jhawkkw

    jhawkkw Chinchillin'

    I was thinking wiping all the partitions except for the bootloader and radio partitions, that way you clear out everything that's not critical. Then flash the 4.2.2 bootloader, then 4.2.2 radios (LTE then CDMA), then try the update command to flash the system/boot/recovery partitions.
     
  10. iowabowtech

    iowabowtech root@android:/ #

    Are you suggesting he use fastboot erase and/or fastboot format commands in lieu of wiping in recovery? If so, which partitions specifically do you think he should focus on here?
     
  11. jhawkkw

    jhawkkw Chinchillin'

    I'm thinking, if it will allow him, to try and wipe out (fastboot erase) the stuff one would usually wipe while in recovery:

    cache, system, boot, and userdata (in order to wipe dalvik). Then maybe things will be set to flash a rom or factory image.
     
    StockAndroid and iowabowtech like this.
  12. iowabowtech

    iowabowtech root@android:/ #

    Definitely seems worth trying to me jhawk. I'd personally feel a little better starting out with fastboot format <partition> first and then if that doesn't do the trick, try erase, then format. May be overly consevative though idk.
     
    jhawkkw likes this.
  13. jhawkkw

    jhawkkw Chinchillin'

    May not be a bad idea. Hopefully mounting won't be an issue in the bootloader.
     
    iowabowtech likes this.
  14. StockAndroid

    StockAndroid Lurker
    Thread Starter

    When I type 'fastboot format cache' I get an error suggesting format isn't a valid command. Available commands are update, flashall, flash, erase, getvar, boot, flash:raw boot, devices, continue, reboot, reboot-bootloader and help. Am I missing something?
     
  15. jhawkkw

    jhawkkw Chinchillin'

    Try the erase command and see if that's successful.
     
  16. StockAndroid

    StockAndroid Lurker
    Thread Starter

    After erasing cache, system, boot, and userdata in fastboot I reflashed Google's factory image 4.1.1 (JRO03O). No errors reported and after an auto reboot the phone loaded into Team Win recovery and asked for a password. The details in recovery at that point read:

    Updating partition details...
    E:Unable to mount '/cache'
    E:Unable to mount '/cache'
    E:Unable to mount '/cache'
    E:Can't mount /cache/recovery/command
    E:Unable to mount '/cache'
    E:Can't mount /cache/recovery/log
    E:Can't open /cache/recovery/log
    E:Unable to mount '/cache'
    E:Can't mount /cache/recovery/last_log
    E:Can't open /cache/recovery/last_log
    E:Unable to mount '/cache'
    E:Can't mount /cache/recovery/last_install
    E:Can't open /cache/recovery/last_install
    E:Unable to mount '/cache'

    This is no change from any other time recovery loads, just trying to provide as much information as I can.

    If I cancel the password prompt the normal recovery menu is shown. From there I can select 'advanced' and then 'file manager'. It displays the root directory structure showing 28 directories such as 'boot' 'data' 'dev' 'sdcard' and so on. When I display the contents of each directory 'dev' 'etc' 'proc' 'res' 'sbin' 'sys' 'system' and 'tmp' are the only directories that show any files or subdirectories.
     

Galaxy Nexus Forum

The Galaxy Nexus release date was November 2011. Features and Specs include a 4.65" inch screen, 5MP camera, 1GB RAM, TI OMAP 4460 processor, and 1750mAh battery.

November 2011
Release Date
0
Reviews
Loading...

Share This Page

Loading...