1. Are you ready for the Galaxy S20? Here is everything we know so far!

Verizon Updating to 4.1.2 without OTA

Discussion in 'Android Devices' started by space_cat, Jan 31, 2014.

  1. space_cat

    space_cat Well-Known Member
    Thread Starter

    In another thread I described my issues with callers on the other end hearing reverb or echo, so I ended up FDRing the phone, which worked to fix the problem and led me down the road to the following ( I thought I might have to take the phone to the Verizon store to deal with the echo problem, so I wanted to look as unrooted as possible so they wouldn't hassle me):

    (skip ahead to 'Attempt at OTA' to get to the point of this long winded story):

    Before I FDRed, I did the following:
    I unfroze everything that had been frozen but not deleted (I used AppFreezer to freeze and unfreeze). I also made sure USB debugging was turned on and that ADB could see the device. After unfreezing apps, I used unlockrootpro to unroot, and I also used SuperSU to be sure I unrooted (SuperSU has an unroot function). I then checked with some root checkers to be sure I was unrooted. All of that because I'd read about people on the forum having problems with their rooted phones when attempting the OTA update. So I was as close to stock as I was going to get just prior to FDRing for whatever that was worth.

    When I was rooted, I had deleted a bunch of bloatware, frozen some stuff and done ithe ncoming call and foreign SIM card mods and some other minor rooty stuff. But I decided to do the OTA update anyway, with the knowledge that I had insurance if I really screwed things up.

    Attempt at OTA

    I'd had the Mobile Care apps frozen so the update had not pushed to me when it was first released.
    So once that was back on and I'd FDRed, I went to 'About Phone' in Settings then 'System updates' and checked for an update. I downloaded the 227MB file and tried to update. The phone rebooted and I got the robot with the blue wire ball in his guts. yay. At 38% I got the robot on his back with the red triangle in his guts. boo. I rebooted and it loaded the OS. I looked in the system update tab and it said the update had failed due to error 402. Whatever that is. So I tried all over again. Same thing.

    Researched on XDA.

    There is a Windows app called Verizon Software Upgrade and Repair Assistant. We all have this already. When you connect the phone via USB to laptop, the drivers load. One of the exe files there is called TL_Bootstrap.exe. If you run that it will install the Assistant. Once you run the assistant, you can do a repair of the phone (not sure exactly what it does to repair things) OR you can download the update and install from that interface. Not OTA. It took a long time to download to my laptop, and about 8 minutes to actually install it on the phone, but I'm running 4.1.2 now. I also have all the crappy bloatware that I'd deleted when I had root, back on my phone (like Zappos!?)

    So there is an alternative to the Over The Air update method, and a repair function with unknown capabilities which needs to be further explored.

    I am currently not rooted and will probably keep it that way for now.

    Once installed the assistant lives in your taskbar tray area or can be uninstalled via the uninstall list in control panel.
     


    rdwilson, Ragnian and meskalin like this.
  2. space_cat

    space_cat Well-Known Member
    Thread Starter

    Log file from Verizon Update Assistant
    ========================

    I attempted to isolate C811M040.mbn but was unable to find it on my drive after the update.

    From: C:\Program Files (x86)\EUT\C811\SUA
    ----------------------------------------------------
     

    Attached Files:

    aerry18 likes this.
  3. StJason

    StJason Newbie

    I don't have the Upgrade and Repair Assistant, and of course Verizon doesn't make it easy to find on their website. Anybody got a copy? I can't find it anywhere...
     
  4. rjglenn

    rjglenn Android Enthusiast

    Mine installed itself the first time I plugged the phone into my computer. It's on the phone.
     
  5. space_cat

    space_cat Well-Known Member
    Thread Starter

    The updater/repair tool is on the phone. Its called tl_bootstrap.exe. you have to run it to install. It will show up in windows when you first connect the phone via usb.

    I attached a zip file with tl_bootstrap.exe and the .ini file it needs to run.
    Unzip, run the file, it will install the updater/repair tool.
     

    Attached Files:

    netslider likes this.
  6. Ragnian

    Ragnian Newbie

    Please excuse the noob question, does this mean I can take my rooted and SIM fixed phone and migrate to stock 4.1.2? (this seems way to easy)

    Then I could in theory root that.
     
  7. space_cat

    space_cat Well-Known Member
    Thread Starter


    Not a noob question at all. There is almost no info on this site on what the upgrade/repair tool can do for us. A wider search also doesn't yield a whole lot of specifics. If you read my extremely wordy description above, it worked for me. I unrooted first, and had not done any major changes or software removal to the phone. I also had the SIM fix, and it didn't cause any problems.

    In your case, it is an unknown. It worked for me, but I was willing to take the chance and had insurance if things went bad. I'm particularly interested in what the repair function can do, but that means people testing it and possibly risking their phones. I've read on XDA about people unbricking their phones with the repair tool, but again, who knows how it will work with ours.

    Are you on Verizon and in the US? A user in another country, with another provider tried it and it didn't work for them. Not sure if the software checks your SIM or something to be sure you're using VZW. There's no harm in installing the tool, hooking up your phone. Just don't hit upgrade or repair if you're not sure.

    Be sure to back anything up that you don't want to lose, and you'll probably have to reinstall all your other apps, etc. I have not reattempted rooting my phone since I updated. The SIM fix can be installed without root.

    Here is a Verizon PDF showing the process for an Samsung S4, but it's the same for our phone.

    http://support.verizonwireless.com/support/pdf/system_update/galaxy-s4-instructions-sua.pdf
     
  8. Ragnian

    Ragnian Newbie

    Thanks!

    I am in the USA and a Verizon customer. I do travel a lot to Europe and I use a prepay SIM that I got when I lived there...keeps the costs WAY down compared to using Verizon.

    Anyway it sounds like my situation is similar to yours....so it "should" work.

    I am out traveling right now so it would not be a good time to brick my phone. But when I get home I might try it....

    Of course if I do I will write up what happened.
     
  9. Ragnian

    Ragnian Newbie

    Hopefully this information will help someone else...

    I had a M020 phone I had rooted and applied the SIMM fix described above to. When I tried to update to M070 from M020 over the air (OTA) I got the same exact results as space_cat.
    So I tried the repair tool as he described and kept getting an error S/W version can not be found(determined). In short it would not work. I was using a Windows 7 machine...on a whim I tried it on an XP box and it worked perfectly.

    I now have an M070 phone.

    For me at least it had to be done on a Windows 7 machine...
     
  10. bestaudioguy

    bestaudioguy Well-Known Member

    Mine refuses to take any update, OTA or using the USB and the PC. It starts the download but then fails to complete. I took it to verizon and they said the software was corrupt. I had the phone rooted, but when I was told to wipe the phone and let it reload, I started to use it un-rooted. Now it continues to try the OTA update and fails and when on the PC it also fails. Is there a way to force the download? I'm still on M050.
     
    rjglenn likes this.
  11. rjglenn

    rjglenn Android Enthusiast

    Reroot, install the recovery, install the update. You have apparently deleted a system app and are off the update path. BTW, there's nothing special about M070 so you may just want to reroot and freeze the updater.
     
    rdwilson likes this.
  12. sherwood420

    sherwood420 Lurker

    I'm hoping that this repair tool can help me..my commando won't stay operational unless on the charger. Off the charger it just turns off if I do anything and won't even get to the boot animation. If not I need to order another and not sure if I'll get a replacement since I was rooted.
     
  13. Wiebenor

    Wiebenor Lurker

    I have(or will have) one of these commandos when a friend is done replacing the factory second NAND that screwed up the phone during update...

    Anyway, I would like to know what if any dedicated or compatible mods to the stock ROM on the 4G are available, such as the power menu mod and sim fix...
    What does sim fix do BTW and what's it for...
     
    #13 Wiebenor, Jun 29, 2015
    Last edited: Jun 29, 2015
  14. Wiebenor

    Wiebenor Lurker

    Also could someone post or send me a list of what can get deleted or frozen from system...
    I need NFC, Direct Connect gZone apps and widgets, and all general/WiFi stuff saved

    My address is wiebenor@gmail.com
     

Casio G'Zone Commando 4G LTE Forum

The Casio G'Zone Commando 4G LTE release date was April 2011. Features and Specs include a 3.6" inch screen, 5MP camera, 512GB RAM, processor, and 1460mAh battery.

April 2011
Release Date
0
Reviews
Loading...

Share This Page

Loading...