1. Are you ready for the Galaxy S20? Here is everything we know so far!

[Verizon] upgrade to 4.0.4 seems to have killed root galaxy nexus

Discussion in 'Android Devices' started by m_lovelace, Jun 3, 2012.

  1. m_lovelace

    m_lovelace Lurker
    Thread Starter

    Hello

    My Galaxy Nexus got Verizons upgrade to 4.0.4

    After pulling the battery and rebooting everything looks OK except when I run something that wants SU access

    From Manager indicates that it was granted root but then fails running privileged commands.

    Any advice?

    Do I need to re-root? Re-unlock.....

    Any comments would be greatly appreciated.

    Thanks
     

    Advertisement

  2. Yes, superuser access is being denied, so return to factory 4.0.2 via here and install a custom rom as to not accept the OTA for 4.0.4. I have the same problem (kinda). I have a personal Nexus rooted way back and no OTA accepted and literally just got a business provided one with 4.0.4 accepted and SU is being denied. So just "dumb down" to 4.0.2 and have your way...
     
  3. mobrienjr

    mobrienjr Android Enthusiast

    all you should have to do is go into recovery, and flash su.zip again. It should work this time around.
     
  4. trophynuts

    trophynuts Extreme Android User

  5. motoko013

    motoko013 Lurker

    Ok, I will admit I really don't know anything about rooting or whatever, but somehow I managed to root my phone for the WiFi tethering app. I just got the notification to install the new system update for verizon. If I do it will I lose my Wifi app? Sorry for the noob question I tried reading about it "force downloads" and "ROMS" and "kernels" but I have no idea what those are.
     
  6. Idunno

    Idunno Android Enthusiast

    I can't say for sure that you'll keep root as i've heard some people don't have root access after the update. BUT... 4.0.4 is very easily rootable, so if you do lose root its no big deal to root it. With the proper set of drivers and the google nexus toolkit (whatever the latest version is) the GNex is very easily manipulated.
     
  7. markdmac

    markdmac Well-Known Member

    umataro42 likes this.
  8. dhworph

    dhworph Android Enthusiast

    Ya, I lost root. I would like to get it back manually though rather than use one of the easy tools.

    Can I just go back to fastboot mode and push su back into system or something?

    The real question is whether or not the phone is now locked? The 4.0.4 update doesn't re-lock the phone does it?
     
  9. dhworph

    dhworph Android Enthusiast

    Can anyone describe exactly what they did to re-root the phone after updating to the stock 4.0.4 (say from stock 4.0.2)?

    I figure push su.zip in recovery sounds about correct, but would like to here who has done it successfully...
     
  10. iowabowtech

    iowabowtech root@android:/ #

    Yeah just get su.zip on the sdcard and flash in cwm. Some people are trying to use the old, original su.zip that was posted all around the net when this phone came out and it doesn't seem to be working which has caused confusion and made people errantly think this method doesn't work anymore. So be sure to use the 4.0.4 comapatible su.zip found here:

    su.zip

    ^Originally posted by Adrynalyne @ xda.
     
    tjbugs1 and scary alien like this.
  11. Idunno

    Idunno Android Enthusiast

    I don't think the update locks the bootloader no, but I could be wrong. You can use ROM manager to boot into CWM and flash SU, if you look in the big sticky there is a link in there to an SU that is proven working on 4.0.4 as some other ones were reported to only work on 4.0.2.

    I'd just use the toolkit, its so easy.
     
  12. dhworph

    dhworph Android Enthusiast

    I just got root back by following these instructions:
    http://androidforums.com/verizon-ga...gs-root-samsung-galaxy-nexus.html#post3736596

    yes, the phone was still unlocked after the update to 4.0.4 from stock unlocked/rooted 4.0.2!

    easy peasy. Just have to use the old su.zip (the one that has su in xbin i think, the zip is like 679KB rather than 1,100KB). And flash clockwork recovery via fastboot b/c clockwork mod can't do it due to loss of root, i think. still had it sitting on my gnex sdcard.

    also my fastboot drivers wont stick on my windows xp system "winusbcoinstaller2.dll". I think you can get them from pdanet, but I just pulled it form an old win_usd_driver folder I had on my laptop harddrive. You can find them in various forum posts, maybe the one above...

    I haven't rebooted to make sure root stuck, but figure it should. however, i dont think the recovery will stick since I haven't fixed that issue.

    no warranties with the files attached to this post
     
  13. m_lovelace

    m_lovelace Lurker
    Thread Starter

    I see.that the phone is still.unlocked
    However,.CW gives an error running privaleged commands

    I just spent an hour trying.to get fastboot to work, to no avail
    When I get the phone into recovery,I can not get any menu or cause it to run. I have to pull the battery to get the phone back

    I'm a little lost.here

    Any.help would be great

    Thanks
    Mark
     
  14. bmikell2000

    bmikell2000 Lurker

    For some of you having issues you might need to track down the SAMSUNG 1.4.8 USB drivers instead of the 1.4.6 - they are hard to find, but fixes the ADB driver in non-bootloader mode. For bootloader, however, I found that Wugs included driver did the trick. Just load that up and push the 4.0.4 compatible su/superuser.apk duo. Took a minute to get mine right, but that did work.
     
  15. markdmac

    markdmac Well-Known Member

    Mark, try Wug's tool. I posted the link above. It was very simple and worked like a charm.
     
  16. m_lovelace

    m_lovelace Lurker
    Thread Starter

    Thanks guys

    Finally got all pieces in one place!


    Thanks for the great advice

    Used Wugs tool to get root back and to get CW loaded
    Loaded rooted 4.0.4 then loaded radios and extensions

    Thanks again
    Mark
     
  17. Bing

    Bing Well-Known Member

    I lost root when I got the OTA 4.0.4 upgrade as well. I see several solutions here and am tempted to try them, but I really do NOT want to have my data wiped (installed apps, settings, etc). Anyone able to direct me to which methods are safe from losing data?

    Thanks!
     
  18. tjbugs1

    tjbugs1 Well-Known Member


    I used Wugs tool with no data loss on mine, your GNex should be unlocked already you just need to reestablish root privileges. In the tool just use the "Root" button and tell it if you want CWM or not to flash CWM. Do not unplug the phone until it says it is completed.
     
  19. nbecker

    nbecker Newbie

    I don't have windows, so can't use wug. Anything to get root on 4.0.4 from linux? I know adb pretty well.
     
  20. Trent Reznor

    Trent Reznor Android Expert

    Download SU and CWM recovery. Put SU on SD card. ADB into bootloader, flash cwm, reboot into recovery, install su.zip, reboot.... profit;)
     
  21. nbecker

    nbecker Newbie

    I have not unlocked bootloader, only rooted, so I don't think I can install cwr without unlocking bootloader.

    Also looking for location of 'updated' su.zip, which I understand is needed for 4.0.4
     
  22. nbecker

    nbecker Newbie

    I followed these directions

    Download: Full Android 4.0.4 IMM76K Build for Galaxy Nexus, Flash Over Any ROM – Droid Life

    Installed update_imm76k.zip:

    fastboot oem unlock
    fastboot flash recovery ~/Downloads/recovery-clockwork-5.5.0.4-toro.img

    I had already used adb push to copy update_imm76k.zip to /sdcard/update.zip

    Use cmr select update from sdcard

    It's been updating now for 25 minutes. Shows android with spinning polygon. Not dead. I can use adb shell, top shows 13% cpu use by /sbin/recovery. I don't imagine it should take this long?

    OK, hit power button. Apparantly, it wasn't really doing any update. Used adb reboot. Eventually, rebooted BACK INTO 4.0.2.
     
  23. umataro42

    umataro42 Android Enthusiast

    Do you remember about how long it took before it said completed? I ran it, and pressed 1 (to indicate the ADB showed up), and after pressing enter, the cmd box went away and it didn't seem like anything was happening.
     
  24. umataro42

    umataro42 Android Enthusiast

    Nevermind my question, I ended up just downloading the su.zip file, copying it to my SD card and flashing it with Clockwork Recovery, and got root back this morning.
     
  25. markdmac

    markdmac Well-Known Member

    Wugz worked great for me with no loss of data.
     
Loading...
Similar Threads - Verizon upgrade seems
  1. Samsung
    Replies:
    2
    Views:
    484
  2. Rob
    Replies:
    11
    Views:
    217
  3. David W Merkel
    Replies:
    3
    Views:
    665
  4. Android News
    Replies:
    0
    Views:
    93
  5. Android News
    Replies:
    0
    Views:
    165
  6. Android News
    Replies:
    0
    Views:
    115
  7. Android News
    Replies:
    0
    Views:
    43
  8. corvairbob
    Replies:
    2
    Views:
    324
  9. dorlow
    Replies:
    4
    Views:
    113
  10. jmcook79
    Replies:
    0
    Views:
    743
Tags:

Share This Page

Loading...