1. Download our Official Android App: Forums for Android!

Root [Verizon] Very Precarious Set-Up

Discussion in 'Android Devices' started by Geist0504, Jan 5, 2014.

  1. Geist0504

    Geist0504 Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Jan 5, 2014

    Jan 5, 2014
    2
    0
    5
    Hi, so I got a replacement phone today and set about rooting it using this guide(can't post links, first result from xda googling root verizon galaxy s3 4.1.2) as I have the previous 4.

    Anyway I spent most of my day with a yellow triangle firmware upgrade error before tracing the issue to a corrupted varlec bootchain file. So after that was remedied I went to flash a recovery and selected TWRP. (Previously it seemed the stock recovery had been wiped from a failed CWM flash as nothing booted after a 10 minute period of waiting)

    I think I made an error in not booting regularly before testing the recovery because TWRP is asking for a password and after I cancel nothing mounts. People say this can be remedied by choosing format data but I can't find a clear answer on how that will affect the phone. I am most concerned because ODIN reported the TWRP flash as a fail, but it worked. I got the yellow triangle errors after this wipe, but a reflash of the VARLEc file made it work again. My previous stock ROM flash attempts (during the VARLEC issue phase) also reported fails at the boot.img stage.

    As you can see there is a lot going on and I can't quite track down a main issue, nothing has been this complicated before.

    My main concerns are:
    1. How can I fix the TWRP recovery or replace it with a working one? (I like CWM and only decided to stray after the failures during flashing)

    2. Can I somehow root with a faulty recovery? (I want to block the OTA update until I can at least buy a backup phone in case I mess this one up)

    3. Can anyone explain any of these issues? I have a 4.1.2 VRBLK version. I have a stock tar of this, but am nervous given the previous failures of ODIN. I already called in an insurance claim before I fixed it, so I might wait until receiving it wednesday to try anything incase I cause another snag.

    Thanks for any help, I know this was long, I hope any of you out there prove smarter than me.
     

    Advertisement

  2. Mikestony

    Mikestony ~30% Carbon Black ±
    Moderator
    Rank:
     #6
    Points:
    3,118
    Posts:
    28,986
    Joined:
    Sep 10, 2010

    Sep 10, 2010
    28,986
    22,788
    3,118
    Male
    Next to you
    Welcome Geist!

    I may not be able to quite explain what the issue is/was, but, was your device on 4.1.2 when you rooted or 4.3? (I assume 4.1.2 based on your search you indicated)

    The only thing I would personally try is to get back to stock and re-root using the Casual method.

    See section 5 in post 1 for unroot:
    [GUIDE][VZW Edition]How to root your Galaxy SIII & More!(ROMs/CWM/Stock) - xda-developers


    See this for the Casual Root Method:
    ★[8/27] [Casual] [Root, Unlock, Recovery] Vzw S3 Toolkit or 1-Click!![Up to MF1]★ - xda-developers

    Hope that helps a little bit:)
     
    breadnatty08 likes this.
  3. tensazan

    tensazan Android Enthusiast
    Rank:
    None
    Points:
    53
    Posts:
    379
    Joined:
    Apr 21, 2011

    Apr 21, 2011
    379
    82
    53
    Indiana
    Also, if you root and unlock your bootloader with casual, you may want to flash twrp or cwm using a different method, either through odin, or Rom Manager for cwm if you don't want to use Odin, as it seems twrp may have an out of date version of both, and from what I've read, it seems some people have issues after using goomanager to install a recovery
     
  4. Geist0504

    Geist0504 Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Jan 5, 2014

    Jan 5, 2014
    2
    0
    5
    Thanks a lot guys! I should have been clearer, it came as 4.1.2, I have been delaying the OTA update to make it 4.3. Also I am not actually rooted at this stage, I have an unlocked bootchain and a custom recovery(which doesn't work) but I stopped there.

    I think I will definitely attempt the ROM manager install for CWM instead. Can I just go right to this and install over TWRP or will I have to wipe with a stock ROM? My only hesitation is nervousness over the previous failures, don't want to brick the device. I have a superSU zip file to flash with a custom recovery for root, never had a problem with that before. Thanks again for all the help.
     
  5. tensazan

    tensazan Android Enthusiast
    Rank:
    None
    Points:
    53
    Posts:
    379
    Joined:
    Apr 21, 2011

    Apr 21, 2011
    379
    82
    53
    Indiana
    I'll try my best to answer your questions, though I just recently rooted my S3, and while I'm not new to the root game, I'm new to it for the S3. So here goes nothing.

    For your first concern, I believe you can reflash the stock recovery, then flash CWM, and that should hopefully take care of it; though I'm not sure if you need to flash the stock recovery...

    As for your second concern, assuming what I said above works, you should be able to root your phone. This tool (★[8/27] [Casual] [Root, Unlock, Recovery] Vzw S3 Toolkit or 1-Click!![Up to MF1]★ - xda-developers) is really easy to use when it comes to rooting and unlocking your bootloader (though you said your bootloader is unlocked). If you use this tool for anything, I would suggest you only use it for rooting your phone and unlocking the bootloader, and to stay away from flashing cwm or twrp with it, as it has out of date versions of both.

    Since you also said that you ordered one through insurance, if you end up keeping it, I highly suggest you give Casual a try, as it takes about a minute to root the phone, and about 15 seconds to unlock the bootloader... though when it comes to the bootloader, you may also need EZ Unlock (get V1.2) to make sure your bootloader is unlocked. When you open EZ Unlock, it may say that your bootloader state is unknown. You can go ahead and hit the "unlock" button, and it'll unlock it (if Casual actually didn't (I ran into this))

    Hopefully this helps, but I would highly suggest doing research of your own since I mainly did all my reading at night when I was fairly tired, so I may have misinterpreted something, or misread something.


    Also, make sure the phone from the insurance claim doesn't have 4.3
     

Share This Page

Loading...