Feb 6, 2012
I'm not sure where to start. I factory reset my phone a few days ago after a disaster copying media files from internal to external sd. The files were corrupted in the process somehow, they won't even show up on the card but still shows 6GB+ as being used up.

Anyways I went & reset it, like normally planned. Apps were reinstalling like normal. Ok. I go on the web browser to save a picture, but it won't save to the card. Went on Facebook, I can't save pics. Either images with other apps & can't save to internal. It's not just limited to pics, just saying.

I'm rooted with stock rom & have ran countless sd fix apps. That isn't the issue. Anyone have a clue what's going on here?

I can't even extract zipped files there
It's also saying it's read-only now. joy...

Edit: aaand problem solved. I downloaded an app called Folder Mount that fixed it. Said there was a error with my card. Anywho, I got the tip from Solution to S3 freezing and a read only inte… | Samsung Galaxy S III I9300, I9305 | XDA Forums
  • Like
Reactions: badbrainseddie