1. Download our Official Android App: Forums for Android!

Root [Virgin Mobile] Having troubles rooting...

Discussion in 'Android Devices' started by pistol_, Jul 24, 2013.

  1. pistol_

    pistol_ Lurker
    Thread Starter
    Rank:
    None
    Points:
    6
    Posts:
    6
    Joined:
    Jul 24, 2013

    Jul 24, 2013
    6
    2
    6
    Hi,

    I followed the guide to the simple root with twrp to the letter; seem to still be having the same problems.

    I load up into odin mode and everytime I start I get a "unsupported dev_type".
    I've reinstalled the Samsung drivers already.
    Made sure the phone was not connected before I loaded into Odin mode.

    Someone point out the obvious for me, please.

    Thanks, Justin
     

    Advertisement

  2. Madbat

    Madbat Android Expert
    Rank:
    None
    Points:
    343
    Posts:
    2,568
    Joined:
    Feb 9, 2012

    Feb 9, 2012
    2,568
    991
    343
    Male
    a/c and heating
    New Orleans
    Do you mean download mode? Power off your phone. Now with phone off hold volume down and power buttons together until you get confirmation. And before you start plug your phone to your computer to make sure your computer is recognising it. At what point are you getting this message?
     
  3. Madbat

    Madbat Android Expert
    Rank:
    None
    Points:
    343
    Posts:
    2,568
    Joined:
    Feb 9, 2012

    Feb 9, 2012
    2,568
    991
    343
    Male
    a/c and heating
    New Orleans
  4. pistol_

    pistol_ Lurker
    Thread Starter
    Rank:
    None
    Points:
    6
    Posts:
    6
    Joined:
    Jul 24, 2013

    Jul 24, 2013
    6
    2
    6
    why yes, I was in fact referring to "download mode" Which also says "odin mode" on my victory.

    Prior to starting up my phone in "download mode" I start odin,Uncheck the auto-restart option, Load the TWRP.tar file under the PDA file option in odin.

    After I press the volume up key to continue to install a custom O/S, I plug in my victory to the "usb" cable with the other end plugged into my personal computer(which runs windows 8).

    Once the device is recognized by Odin, I click start and receive a error on my victory in red type "unsupported dev_type",
    Odin states the following
    <ID:0/034> Added!!
    <ID:0/034> Odin v.3 engine (ID:34)..
    <ID:0/034> File analysis..
    <ID:0/034> SetupConnection..
    <ID:0/034> Initialzation..
    <ID:0/034> Get PIT for mapping..
    <ID:0/034> Firmware update start..
    <ID:0/034>
     
  5. JerryScript

    JerryScript Android Expert
    Rank:
    None
    Points:
    313
    Posts:
    2,212
    Joined:
    Mar 15, 2011

    Mar 15, 2011
    2,212
    2,065
    313
    Las Vegas
    Could be a bad TWRP.tar file. Are you sure it's the correct one for the Victory? If there was an md5 checksum posted with the link to the TWRP.tar download file, did it check out? Have you tried downloading it again and trying Odin with the fresh download?

    Here's the TWRP.2.4.3.0.tar I installed, and the md5 so you can check it after you download it.
    TWRP.2.4.3.0.tar
    md5 f2342fd4ed1ca20afd31e74e6446fe0a

    I'm thinking you may have a TWRP backup and not the actual recovery package, since most TWRP zips have the version number in the filename. The TWRP install package should be 7.65mb, and a backup size is over 600mb.
     
  6. pistol_

    pistol_ Lurker
    Thread Starter
    Rank:
    None
    Points:
    6
    Posts:
    6
    Joined:
    Jul 24, 2013

    Jul 24, 2013
    6
    2
    6
    The file was the same as I had previously tried, although I used the new file and came up with the same* end result.
    I'm going to break out my xp desktop and try this over.
    Thanks
     

Share This Page

Loading...