1. Download our Official Android App: Forums for Android!

Support Virgin Mobile (Mobile ID failed to download)

Discussion in 'Virgin Mobile' started by huntmarvin, Mar 18, 2016.

  1. huntmarvin

    huntmarvin Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Mar 17, 2016

    Mar 17, 2016
    2
    0
    5
    I have an HTC Desire 626S and recently had to do a factory reset due to a misbehaving application. The device is less than 1 month old and when I reset the phone a message came up in the status/notification bar that reads as follows: DOWNLOAD ERROR
    No action required. ID will automatically retry. An unexpected download error has occurred. (Code 30).

    It seems to retry when I restart my phone and then just randomly. It has also read as code 20 a couple times but mostly code 30. It's not just the mobile ID pack. The Essentials Pack isn't there either.

    I don't know what Virgin Mobile is up to but I have googled this and get no answers. Anyone else with the same issue? Anyone know of a fix for this?
    When I look under Apps, Mobile ID is there but I can't find it to put on my home screen so basically it's not completely downloaded maybe???

    Really seems shady because even before I reset the device to my recollection, it wasn't downloaded to begin with and obviously by the notifications I keep getting, it is using battery by trying to download.
    Thanks

     

    Advertisement

  2. mikeca

    mikeca Android Enthusiast
    Rank:
     #243
    Points:
    53
    Posts:
    350
    Joined:
    Jul 4, 2011

    Jul 4, 2011
    350
    34
    53
    my desire 601 did the same thing when it was new, really sucked. I can't remember how I got it fixed, I think the update to Kit Kat eventually did the trick, the other thing was it would definitely do it whenever I rebooted the phone.

    Hope that helps a bit.
     
  3. huntmarvin

    huntmarvin Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Mar 17, 2016

    Mar 17, 2016
    2
    0
    5
    I had a system update that was downloaded when I bought the phone. It updated to Android 5.1. I think Virgin Mobile has done something they don't and they aren't saying much. Usually when there is an issue with my device I can google it and find too many to count in the search results of folks with the same issue. This search yielded nearly nothing. There was one search result where someone said VM I.D. and essentials packages were removed from V.M. but if that were true, I wouldn't be getting error code 30 several times a day. Usually a representative will answer my question here in support and that isn't happening either. I am pretty smart with my electronic devices. I'm not an Android genius but far from Android Illiterate.
    VIRGIN MOBILE SUPPORT : AN ANSWER WOULD BE APPRECIATED.

    P.S. Another search had mentioned something about a launcher.

    Also there is an app called themes that was pre-loaded (bloatware but a really good app that uses very little memory)... Just wondering if the app could be interfering with mobile ID and essentials.
     
  4. Madbat

    Madbat Android Expert
    Rank:
    None
    Points:
    343
    Posts:
    2,570
    Joined:
    Feb 9, 2012

    Feb 9, 2012
    2,570
    990
    343
    Male
    a/c and heating
    New Orleans
    Just go into settings/apps and wipe data and cache for the mobile ID app. Do the same for download or download manager.
     
  5. Allen AKA DJLA

    Rank:
    None
    Points:
    25
    Posts:
    1
    Joined:
    Apr 6, 2016

    Apr 6, 2016
    1
    0
    25
    Male
    Demolition/concrete grinding and polishing
    Puyallup WA.
    I have an HTC Desire 626 as well I don't know if it is an "S" or not yet.. just recently got it.. What I just tried is force stop, clear data, and turned off notifications for that app.. we will see if it works.. hope that helps..♏
     
  6. MSPShadow

    MSPShadow Lurker
    Rank:
    None
    Points:
    15
    Posts:
    1
    Joined:
    Apr 7, 2016

    Apr 7, 2016
    1
    1
    15
    Male
    E-Learning Designer/Developer
    Minneapolis, MN
    I had the same problem. I contacted Virgin Mobile support and they kept telling me to remove/replace the battery, open the Mobile ID app and download the ID Packet; however, the battery on my Moto G 3rd Gen phone can't be removed and I had no Mobile ID icon on my phone. I did find the Mobile ID app in Settings/Apps/All. The support person told me to do what Allen recommended - force stop, clear data, and deselect Notifications - so far, it seems to work! Haven't received the error message since.

    I should note, however, the support person suggested that I do this ONLY if everything else on the phone, including access to Play Store, worked. She also forewarned me that I would not have access to the wall papers and ring-tones that come with the VM Essentials ID Packet. I'm fine with that. Otherwise, she told me that a factory reset and re-activation would be my only option.
     
    AnciusD likes this.

Share This Page

Loading...