1. Are you ready for the Galaxy S20? Here is everything we know so far!

[Virgin Mobile] No GPS after CM11 installed.

Discussion in 'Android Devices' started by Mumonk, Sep 22, 2014.

  1. Mumonk

    Mumonk Lurker
    Thread Starter

    Been having an issue after I flash CM11, i lose my GPS connection completely. Satellites won't connect at all. When I am running rooted stock rom, everything works fine. And when I flash CM11, the phone and data and wifi works fine, but no GPS at all.

    I have been looking all over google for days, all I can find are people talking about fixing the S3 GPS in general with the little screw tightening thing, which I have never had a problem with. Before root, and after root, when running stock rom, it connects in literally 2 seconds with perfect accuracy. Then nothing with CM11. If I restore back to 4.3 stock rom, the GPS works great again.

    It's Virgin Mobile Galaxy S3
    Model SPH-L710
    Running 4.3 Rooted Stock Rom Deodexed
    Kernal 3.0.31
    Using PhilZ Touch Recovery 6.48.4 (CWM 6.0.5.0)
    Trying to flash CM11 (d2lte)

    Thank you so much in advance for anyone who can point me in the right direction.
     



    1. Download the Forums for Android™ app!


      Download

       
  2. AMOCO

    AMOCO The Computer Guy
    VIP Member

    Clear Cache/Data in CWM/TWRP,And see if this fixes it.
     
  3. Mumonk

    Mumonk Lurker
    Thread Starter

    Sadly, did not work =(

    Also i dunno if it matters but I am on Baseband L710VPUBMK5. Forgot to put that above.
     
  4. Mumonk

    Mumonk Lurker
    Thread Starter

  5. Madbat

    Madbat Android Expert

    Are you flashing a nightly build? GPS may have a problem in it.
     
  6. Mumonk

    Mumonk Lurker
    Thread Starter

    I am using d2lte. From what I have read it is the one Virgin Mobile is supposed to use. And yes it is nightly.

    I would try another, just not sure which one. Sprint (d2spr)? Don't want to brick by using wrong one.

    On their Wiki it says that most US phones have been combined into the LTE build (d2lte).

    Would the stable Sprint Version work for Virgin?

    Again, i really do appreciate any and all help.
     
  7. Madbat

    Madbat Android Expert

    Your supposed to use d2lte, but nightly builds are sometimes unstable. I forget what they call stable builds now, I don't use cm. Definitely stick to d2lte, but maybe d2lte milestone or snapshot.
     
  8. alexizawesome

    alexizawesome Well-Known Member

    All Cyanogenmod builds are unified so definitely D2lte is the way to go. Only the old pre 11 are d2spr. The snapshots are the most stable. I just tested M10 and with Google Maps, it took a few seconds for it to lock to my location via 3g service. Tried 9/22 Nightly as well gps seems to working atleast for me. I did read a post on the S3 Att Xda thread about gps issues with nightlies dated 9/20. So, definitely try the M10 snapshot to see if it is not device specific.
     
    Mumonk and Madbat like this.
  9. Mumonk

    Mumonk Lurker
    Thread Starter

    YES!! It's working!

    I downloaded the CM11 M10 and it connected to the satellites instantly. Thank you so much!! I would totally hug you if you were here =P

    Thanks to everyone else as well for your input!
     
  10. mtuser

    mtuser Member

    I'm glad you posted about this, I use CM nightlies switching to the latest every few days.

    I noticed several weeks ago my gps wasn't working but like you attributed it to the loose screw issue - that I've actually had in the past.

    Finally got around to tightening them up and doh still no gps, even with latest nightly.

    LIikewse M10 works great, I wonder if they even know it's been broken as this has been going on I think since the end of last month.

    Haven't tried a nightly in the last week or so though.

    cheers
     
  11. LordDenton

    LordDenton Lurker

    No GPS on my S3 either with M11. I spent hours configuring the phone just the way I liked it and now I found out that GPS doesn't work. :p

    I hope there is some sort of fix where I don't have to start from scratch again.
     
  12. vsanch24

    vsanch24 Well-Known Member

    I went from M10 to M11 via the dirty flash method. My gps continued to work.
     
    Madbat likes this.
  13. mtuser

    mtuser Member

    interesting M11 GPS doesn't work for me nor a family members s3 dirty or clean install. Have to use M10.

    It's been broken for me since back in sept in nightlies, previously it worked.

    I should perhaps note it will lock when stationary and seems to work then, but it can't lock to save its life once you fire up google maps and move.

    I wonder if it's related to area somehow, since it seems to work for some but not others.
     

Samsung Galaxy S3 Forum

The Samsung Galaxy S3 release date was May 2012. Features and Specs include a 4.8" inch screen, 8MP camera, 1GB RAM, Exynos 4412 Quad processor, and 2100mAh battery.

May 2012
Release Date
0
Reviews
Loading...

Share This Page

Loading...