1. Are you ready for the Galaxy S20? Here is everything we know so far!

[Virgin Mobile] Root Explorer Not Working on 4.3 HELP!!!

Discussion in 'Android Devices' started by fcrjr, Dec 13, 2013.

  1. fcrjr

    fcrjr Member
    Thread Starter

    So here's my problem:
    Last night I decided to re-root and install 4.3. (I was previously running 4.3 unrooted with the Knox bootloader)

    Then I installed root explorer 3.0. When I tried to open it, it just closed. So then I tried installing a newer version (3.1.5). It actually opened, but when I go under the root tab nothing shows up.

    I'm currently using es file explorer but it would be great if I could get this figured out. I like root explorer much better.

    Thanks!!
     



    1. Download the Forums for Android™ app!


      Download

       
  2. struckn

    struckn Android Expert
    VIP Member

    Check your SELinux status just for grins. Is it on "Permissive" or "Enforcing"? Also, did you use the SuperSU v. 1.80 zip? It is designed to block Knox from denying apps that need root access.
     
  3. fcrjr

    fcrjr Member
    Thread Starter

    My SELinux status says "Permissive".
    Yes I did use SuperSU 1.80.
    I did everything exactly as its written on this thread.
    [ROM][MK5][STOCK][ODEXED/DEODEXED]- Virgin Mobile/Boost Mobile

    I do have root access. I know this because I downloaded Root Checker Basic and it said I have root access. Also, I can get to the root directory just fine on ES File Explorer. I just don't understand why root explorer wont work. I'm able to see the files on the internal storage and on my sd card, but nothing shows up under root.

    If I press Mount R/O or Mount R/W it asks me if I want to grant root access, but when I hit grant it just mounts it as R/O or R/W and nothing else happens.

    Also, I did install the Xposed framework, but I don't think that could have messed up root explorer because even before I installed Xposed root explorer wasn't working.

    Any help is appreciated!! Thanks
     

    Attached Files:

  4. struckn

    struckn Android Expert
    VIP Member

    Thanks for the detailed reply. First, Xposed does nothing besides provide a way to customize the framework in a harmless manner, so that is not the culprit for any root issues. I was just brainstorming with my other questions, especially with SELinux, since Enforcing mode has popped up and caused me issues a couple of times, but default for 4.3 is Permissive, so you would have had to intentionally change the status and I don't know why anyone would do that. Also, I have never used Root Explorer, strictly ES File Explorer for me, and you are experiencing what I have with ES. Only other thing I can think of is that Root Explorer hasn't been updated recently, so there may be compatibility issues related to Knox or just recent Android builds in general. Does Root Explorer do some things that ES can't, or is it just a personal preference, out of curiosity? I know I am really addicted to certain apps just from longtime use, even if other apps do the same things or may even be better!

    Edit: Never mind on the recent update question regarding Root Explorer, just looked it up on Play Store and they updated just three days ago to be compatible with KitKat. However, an update to work with KitKat doesn't necessarily mean Knox compatibility. The developer has an email link on the main app page for Play Store, maybe shoot them an email and see?
     
  5. fcrjr

    fcrjr Member
    Thread Starter

    Thanks for the response! Yeah, it is just personal preference. I've been using root explorer for quite a while and I guess I became really attached to it. But I've been using ES File Explorer for a day or two now and I'm starting to kind of get used to it now. I think I'll just stick with ES. Once again, thanks for the response.
     
    struckn likes this.

Samsung Galaxy S3 Forum

The Samsung Galaxy S3 release date was May 2012. Features and Specs include a 4.8" inch screen, 8MP camera, 1GB RAM, Exynos 4412 Quad processor, and 2100mAh battery.

May 2012
Release Date
0
Reviews
Loading...

Share This Page

Loading...