1. Are you ready for the Galaxy S20? Here is everything we know so far!

[Virgin Mobile/Sprint] Root and CWM - EASY how-to guide for noobs

Discussion in 'Android Devices' started by compjake, Dec 3, 2013.

  1. compjake

    compjake Lurker
    Thread Starter

    Disclaimer I will NOT be held responsible for anything unfortunate that happens to your phone if you decide to follow this guide and your phone turns into a nuclear reactor, fusion reactor, works perfectly or anything else!

    Take responsibility for your own actions!



    Now to the more important things.

    This guide assumes all apps, zips and backups will be located on your external_SD partition.
    If this is not the case, please pay VERY close attention to what your doing and where your doing it!

    First, download "LSVM720ZV5 Root and CWM.zip"
    MD5: 59D45715DBD8FACD7DBD5C05805B0D5F

    Step 1:
    Extract and install LG Drivers
    "LG_VZW_United_WHQL_v2.7.1.exe" Included in zip

    Step 2:
    Extract the folder "motochopper" to the root of C:

    [​IMG]

    Step 3:
    Turn on USB debugging in your android Developer options
    [​IMG]

    Step 4:
    Copy "lte2_l1m_recovery.apk" and "CWM Recovery.zip" from the zip to the root of your phones SD Card

    Step 5:
    Open "run.bat" found at C:\motochopper\run.bat

    [​IMG]


    Step 6:
    Assuming your phone was detected properly and the drivers installed correctly go ahead and press any key.
    After a minute or two you should have root!

    [​IMG]

    Press Enter and allow your phone to reboot. (Its now safe to remove the USB cable if needed)

    Congrats! You now have root!

    Lets move on to CWM shall we? :)

    Step 7:
    Use a file manager to locate "lte2_l1m_recovery.apk" on external_SD and open it.
    You may have to allow unknown sources.
    [​IMG]

    [​IMG]

    If all has gone well, you will open LTE2/I1m Recovery Touch and choose "Recovery Apply"

    Should be a success.
    [​IMG]

    If you're still with me and haven't gotten lost select Reboot.

    [​IMG]

    If you were successful please continue.

    Step 8:
    Select "Choose zip from external sdcard"

    [​IMG]

    Step 9:
    Select "CWM Recovery.zip" and choose Yes
    [​IMG]

    Now is time for one last reboot, once in Android power off the phone.
    Turn the phone back on while holding Vol - and Pwr\lock

    You SHOULD boot into CWM Recovery without the need for 2nd-init and with an UNLOCKED Boot loader!

    [​IMG]

    Now is the PERFECT time to create a nandroid backup, so please do so now!!

    [​IMG]


    Special thanks to:
    PlayfulGod, kenboyles72, CWM Team, and whoever created the LTE2 Recovery App.

    If I forgot to thank you in this post, please PM me and I will add you.
    If anyone wasn't given credit for their contributions; again, please PM me and I will give you the credit you deserve!
     



    1. Download the Forums for Android™ app!


      Download

       
  2. Deleted User

    Deleted User Guest

    Confirmed, it works perfectly! So now that the bootloader is unlocked, does this mean ROM development is around the corner?
     
  3. beazpickle

    beazpickle Newbie

    After following this guide I'm not getting any service. Just an X above the bars and tries to activate when I turn on my phone even though its activated.
     
  4. learning2

    learning2 Guest

    Thanks for all your work documenting this. I probably won't be able to try it until after the holidays, though.
     
  5. HaTrEd360

    HaTrEd360 Android Expert

    Bootloader is not unlocked just bypassed with Loki is all. Hence why we have recovery. So I don't think you'll be able to install kernels because of that. No boot.img's for us. :/
     
  6. Sinner67

    Sinner67 Well-Known Member

    I got this to work flawlessly, and took copmjake's advise and did a nandroid backup. Later, I used Titanium Backup to reboot the phone into recovery, and it did go into the CWM Recovery. I made no changes and told it to reboot and my phone reset to factory default. I shut down my phone and started it up recovery and restored my backup, and everything worked fine. Even shutting down the phone and booting into recovery with the keys, then telling recovery to restart the phone works fine. My advise would be to not reboot into recovery using an app.
     
  7. HaTrEd360

    HaTrEd360 Android Expert

    OP forgot to mention that the only way to avoid being factory reset is to use the hardware keys to enter recovery and not an app.
     
  8. beazpickle

    beazpickle Newbie

    My issue was the Meid was corrupted after clearing Dalvik. Pretty much unfixable, getting a new phone.
     
  9. Deleted User

    Deleted User Guest

    Wow. That has me scared. Did you try fixing it with the unbrick method?
     
  10. beazpickle

    beazpickle Newbie

    Yeah, it didn't work. Meid was still corrupted.
     
  11. HaTrEd360

    HaTrEd360 Android Expert

    The phone just needs to be reprogrammed is all, the meid should be on the battery, have Virgin Mobile reprogram it.
     
  12. HaTrEd360

    HaTrEd360 Android Expert

    Yeah just checked, your Meid should be right under the battery on the actual phone itself. Odds are is your meid is just zeroed out, I've seen it happen before. Reprogramming should fix it back up, since you have the original one under the battery. :)
     
  13. beazpickle

    beazpickle Newbie

    It's not zeroed out, it's completely different
     
  14. HaTrEd360

    HaTrEd360 Android Expert

    Doesn't titanium backup have a restore option for that? I forget

    Edit: Nvm that's Android Id. Hmmm
     
  15. HaTrEd360

    HaTrEd360 Android Expert

    I've got an idea! I just watched a YouTube video, and you can write a new meid to it using Cdma workshop. If you call Virgin mobile and complain enough you can get your MSL code to enter diagnostic mode to allow your phone to come up in Cdma workshop, then use it to write your old meid back then probably reactivate it. :)
     
  16. Wrath42

    Wrath42 Newbie

    Hey guys quick question, I rooted this phone in the process of trying to acquire the MLS anyways long story short Im returning this phone and getting the sprint version of it while best buy still has a deal on it.

    When I factory data reset the phone gives me [Secure Boot Error] at the top left and then the green android screen for a few seconds, then continues to factory data reset and seems clean from there, although another factory reset shows the same screens again.

    I have never unrooted a phone before this is not even my phone I am doing it for a friend that wanted to go pageplus but now has decided on ting because of the hassle with the MLS

    I am afraid best buy will attempt a data reset before accepting the phone for return and see this how can I get the phone back to complete factory stock?

    Thanks!
     
  17. Deleted User

    Deleted User Guest

    The unbrick method which is stickied at the top of this forum should bring your phone to a state very close to, if not, exactly like complete factory stock.
     
    Wrath42 likes this.
  18. Wrath42

    Wrath42 Newbie

    Ill give that a try then thanks for the quick response really wanna get this done and over with today I've spent the last 2 days glued to trying to flash the phone to another provider and I am so burnt out on this, cant wait to just return this thing get a sprint phone and go with Ting.
     
  19. Wrath42

    Wrath42 Newbie

    Another correction so after I disconnect and reconnect the USB cable in download mode the flashing starts after about 500 seconds I get
    :: Error ::
    F0000002

    Tried 3 times.

    4th time at 89% after the log says Rebooting and the phone boots up to the screen where it asks if you would like to activate talk back voice navigation for the visually impaired the communication port 41 that says LGE Android Platform USB Serial Port disappears I don't know if this has anything to do with the reason I am failing

    Can someone confirm for me they can see their phone in the device manager while the phone is on under the COM Ports listed as LGE Android Platform USB Serial Port

    5th time yup after Rebooting comes up in the log it disappears from the device manager.
     
  20. Deleted User

    Deleted User Guest

    Does your phone function normally after getting the error? I know that I got an error both times I have used this method but the phone still functioned perfectly. I believe that the creator of the thread for the unbrick method said that it gives every phone an error after about 80%. So you should be alright.
     
    beazpickle likes this.
  21. Wrath42

    Wrath42 Newbie

    Yeah it functions normally afterwards and your right he does quote " It does that on every phone " Uhg I'm sorry I should have read that better im just spread so thin right now and stressed out OKAY! thanks. I'm going to check if CWM boot messages still pop up after another factory reset then.
     
  22. beazpickle

    beazpickle Newbie

    Why does wiping the dalvik jack up the meid?
     
  23. jmpiv4

    jmpiv4 Well-Known Member

    Has anyone else confirmed this, or is this just an isolated indecent?
     
  24. beazpickle

    beazpickle Newbie

    Somebody else posted about "invalid Sim card" and it was the same cause
     
  25. redheadturkey

    redheadturkey Newbie

    Thanks for the heads up about the dalvik, I know now to wipe it when we do finally get custom roms.
     

LG Optimus F3 Forum

The LG Optimus F3 release date was June 2013. Features and Specs include a 4.0" inch screen, 5MP camera, 1GB RAM, Snapdragon 400 processor, and 2460mAh battery.

June 2013
Release Date
0
Reviews
Loading...

Share This Page

Loading...