1. Are you ready for the Galaxy S20? Here is everything we know so far!

[Virgin Mobile/Sprint] Rooting the F3 with Motochopper

Discussion in 'Android Devices' started by Deleted User, Jul 26, 2013.

  1. Deleted User

    Deleted User Guest
    Thread Starter

    delete
     


    #1 Deleted User, Jul 26, 2013
    Last edited by a moderator: Mar 18, 2018
  2. sinkist77

    sinkist77 Member

    I can officially confirm this. I just tried it and it successfully rooted my F3.
    Thank you for bringing this to the forums.
     

    Attached Files:

    shavatek and skarface1988 like this.
  3. skarface1988

    skarface1988 Well-Known Member

    Thanks! It work. I actually download mine for a s3. The first 3 try it didnt work. Fourth time it work!....thanks
     
  4. elgecko

    elgecko Android Enthusiast

    Just placed this phone on order.

    I see some are using Motochopper to root this phone.
    Does it place replace the stock recovery with CWM?

    I always like to root my phone to have total control over it, but want to make sure that CWM is also installed on it in case of any oops.
     
  5. skarface1988

    skarface1988 Well-Known Member

    There is no official custom recovery for this device yet. Ive seen other post if you go straight to recovery after rooting. It may get black screen. And can factory reset on its own. So dont attempt until we all see the official recovery..
     
    elgecko likes this.
  6. elgecko

    elgecko Android Enthusiast

    Has anyone rooted the phone before activation?
    Did it work?
    IIRC some phone would not activate after being rooted.
     
  7. elgecko

    elgecko Android Enthusiast

    My phone is here and I'm trying to root it so I can transfer all my data from TiB and I'm not getting access for some reason.

    I finally found on LG site drivers for Virgin Mobile. Installed them, even rebooted the computer.
    Have the phone set to USB debugging.
    Turned off firewalls and anti virus programs.
    This is what I get when trying to run motochopper.

    [​IMG]

    Any ideas what I'm doing wrong?
     
  8. skarface1988

    skarface1988 Well-Known Member

    Make sure you download the right driver model for you exact phone. And make sure your computer can detect/roconize your device. Amd than run motochop over n over til it works. It happen to me and i have to do it like 3 or 4 time..
     
  9. Mikestony

    Mikestony ~30% Carbon Black ±
    Moderator

    Just wondering if this indeed confirmed working etc.
    The reason I ask, is that in the root sticky, there is no link for a root guide. :)
    Let me know and I can add this thread to the sticky's guide :p
     
  10. sinkist77

    sinkist77 Member

    As far as I know, this method has been working. I myself rooted this way.
     
    Mikestony likes this.
  11. elgecko

    elgecko Android Enthusiast

    Had the wrong driver at first. Mine rooted on the first try. I rooted it after activating the phone. Yes it works.
     
    Mikestony likes this.
  12. Mikestony

    Mikestony ~30% Carbon Black ±
    Moderator

    Thanks guys! Added to the root sticky:)
    If you see anything else that can be added, let me know by p.m. or another guide (member in green) or mod. ;)
     
  13. Sharkhunter45

    Sharkhunter45 Well-Known Member

    I'm having some trouble rooting using this method. It keeps saying "adb is not recognized as an internal or external command, executable program," and something else i dont remember. Any ideas on how to make it work?
     
  14. Deleted User

    Deleted User Guest
    Thread Starter

    delete
     
    #14 Deleted User, Aug 14, 2013
    Last edited by a moderator: Mar 18, 2018
    j1232 likes this.
  15. swa goo

    swa goo Lurker

    What do i download to root optimus f3 with virgin mobile? Ive tried motochopper but it keeps saying that is doesnt find su. Please help asap!!!!!:thinking:
     
  16. Sharkhunter45

    Sharkhunter45 Well-Known Member

    Yeah, downloaded the drivers, downloaded two different motochoppers, and spammed the you-know-what out of the run.bat lol. It recognizes the device, adb just doesnt want to be recognized. Do i have to pull the motochopper folder out of the zip or no? Thanks for the help :)

    EDIT: It worked, i just had to pull the folder out of the zip lol
     
  17. Um yeah you definitely have to extract the files first. ;)
    Motochopper worked for me instantly on the first try.
     
  18. j1232

    j1232 Well-Known Member

  19. jamstewonline

    jamstewonline Well-Known Member

    Wow rooting this phone was easy. less then a minute. thanks
     
  20. aloerose

    aloerose Lurker

    Motochopper worked wonderfully. I just got the f3 today (virgin mobile), and started my customization process (beginning with rooting) right after activating.
     
  21. schpelTiger

    schpelTiger Newbie

    Just got this phone today (cracked my Optimus Elite's screen, oops), rooted successfully. Cannot wait until ROM development begins, if it does.
     
  22. Murf1

    Murf1 Android Enthusiast

    Installed LG drivers, ran motochopper, ran superuser, ran root checker - verified, ran update for superuser, ran root checker - verified. I'm Rooted!
     
  23. Murf1

    Murf1 Android Enthusiast

    Now that I have rooted and have Link2SD working can I turn off USB debugging?
     
  24. waterlubber

    waterlubber Lurker

    If you ran the run.bat file, you MUST unzip the files first...then it should work. Hope that helped.
     
  25. Scholzpdx

    Scholzpdx Lurker

    Root worked first try. My very first! Thanks!
     

LG Optimus F3 Forum

The LG Optimus F3 release date was June 2013. Features and Specs include a 4.0" inch screen, 5MP camera, 1GB RAM, Snapdragon 400 processor, and 2460mAh battery.

June 2013
Release Date
0
Reviews
Loading...

Share This Page

Loading...