1. Are you ready for the Galaxy S20? Here is everything we know so far!

VLC Stream & Convert

Discussion in 'Music & Media' started by sastek, Aug 1, 2010.

  1. sastek

    sastek Newbie
    Thread Starter

    Has anyone tried the app VLC Stream and Convert? VLC Stream & Convert v0.4.28 Application for Android | Multimedia

    It looks promising as a streaming option but I can't work out how to set it to actually stream videos to the phone. It's working as a remote (so VLC is working correctly) but there are no instruction available on how to configure streaming.

    1. Download the Forums for Android™ app!


  2. sastek

    sastek Newbie
    Thread Starter

    anyone tried it yet?, there has been an update, but I still can't make it work!
  3. DroidGnome

    DroidGnome Member

    I just tried it.. and it's working just fine for me.. however it only seems to work over WiFi (Though I've only tried from my own network, need to really try from a free hotspot somewhere)

    I've heard that Android 2.2 (or HTC's version anyway) seems to have broken RTSP protocols over 3G.. still researching myself.
  4. OmegaEpoch

    OmegaEpoch Lurker

    it works for me over wifi, haven't figured out how to (or if it's even possible to) stream over 3G
  5. sastek

    sastek Newbie
    Thread Starter

    Yeah, i've also got it working now with an mp4 file.

    I still haven't figured out how to convert and stream an avi file in real time, just need to figure out the correct transcoding settings.
  6. DroidGnome

    DroidGnome Member

    Ok did a bit more work on this and you CAN stream over 3G, but there's a small trick.

    You must have your WiFi antenna turned on.. Even if it's not connected.

    For some reason Android 2.2 seems to have changed the mechanism for RTSP (The protocol this uses along with other apps)... At least on the Evo 4G, you can no longer use that protocol over 3G. (My guess is to limit bandwidth by sprint perhaps?). However if you turn your WiFi antenna on, the phone will think you're on WiFi and will allow the correct stream to play, and the connection still comes in over your 3G (assuming you didn't find a wifi hotspot to connect to).

    As for AVI... Anything my VLC plays I can stream. AVI, DIVX, MKV, x264, etc... OverWifi it's almost flawless, though I cannot change any resolution settings and whatnot.

    I've no clue what the "Convert on PC" option is meant to do as there are no instructions for this app that I could find... perhaps that allows instant conversion? Not sure yet.
    Dvalin21 and ffigs like this.
  7. zahC

    zahC Lurker

    Evo 4G, using HTC's official Froyo 2.2.

    I can get everything to stream video over 4G (assuming wifi is on) but the audio sounds garbled. I've tried playing with the settings for the audio (increased bit rate, etc), but nothing.

    Any suggestions?
  8. drabidea

    drabidea Member

    Anyone know how to use this with crappy Vista? I can't set up VLC because I don't have administrative rights. I hate Vista
  9. DroidGnome

    DroidGnome Member

    Regarding the audio garbling.. is it every video or just certain ones? perhaps there's a problem with the video itself?

    I don't have any audio problems here, but then again I don't have 4G either, so can't properly duplicate your scenario.

    As for Vista and No Admin rights... umm the only thing I could suggest would be to find an Admin and have them install VLC. (That's kinda the purpose of not having admin rights... so you can't install stuff :) )
  10. gogol

    gogol Well-Known Member

    Mine also does not output audio (from a video) properly. There are some garbled (high pitch) background noise.

    HTC Desire (stock ROM, 2.2 official update, non-rooted), VLC 1.14, connected via wifi. Wifi speed is excellent.

    This happened to all videos.

    Although the video is smooth!

    Too bad, the audio is not.

    I have tried almost any settings (up/down bitrate, change resolution, etc.), no luck :(

    Clear data, reinstall ... also no luck.
  11. FuryriderX

    FuryriderX Lurker

    I'm getting the garbled audio too.

    Where is this 'force stereo' option?? I looked all over and cant find it. On the phone, or on the computer?
  12. SticklerX

    SticklerX Lurker

    I too am getting Garbled audio when streaming; regardless of file format or options on Android App.

    Tried playing with different MUX settings to no avail as well.

    Im running :
    HTC Evo 4G
    Connected to VLC via Wifi local network only
    Rom: Damage Control 3.5
    Netarchy Kernal

    If anyone finds a fix; please post it here.
  13. Ash88

    Ash88 Lurker

    I had the choppy audio, but decent video a couple of days ago...noticed the updated client and switched from 1.1.4 to 1.1.3 (also tried 1.1.2), but I cannot get any video/sound via RTSP...sound through http works.

    I followed all the steps (.hosts, firewall, etc) and rebooted both my phone and computer several times. It just says "buffering" and shows the time count up and the bar moves...no video.

    Galaxy S Vibrant

    Any ideas?

  14. zahC

    zahC Lurker

    I can get sound and Video, but the sound is garbled.

    If I stream a video file over http (audio only) then it sounds fine.

    I've tried playing with all the settings, but nothing seems to keep the video from sounding like it's under water.

    Oh. Evo 4G 2.2
  15. Aerimus

    Aerimus Well-Known Member

    Mine does the same thing on the Captivate. Can't seem to get past the buffering...
  16. Ash88

    Ash88 Lurker

    Recieved an answer on another thread - change the port under RTSP in the phone app to 5554 (somehow it changed to 554 on the last update). I made that change, reconnected, and it works perfectly now.

    Aerimus likes this.
  17. gogol

    gogol Well-Known Member

    Where is the developer? I thought this is the official forum.

    I hope he will address this garbled sound that many users has experienced.

    Still waiting this fix before purchasing the paid version (which is now I am worried to have good support).
  18. Brewmeister

    Brewmeister Newbie

    For those with the garbled audio, this seems to be a known issue with the app and VLC version 1.1.4. The app developer has posted info about it on the official app page.

    I just downgraded back to 1.1.3, and the issue went away, so that seems to be correct; or at least it was for me.
  19. gogol

    gogol Well-Known Member

    Confirmed, VLC 1.1.3 fixed the audio garbled.
  20. olandir

    olandir Newbie

    I've searched all over for 1.1.2 or 1.1.3 and can't find a way to download it. Where can I download an older version of VLC?

    Edit: Nevermind just found it
  21. painless

    painless Lurker

    I am having issues with video. I've checked and quadruple checked the directions when setting everything up.

    Rooted HTC EVO 4G with the stock rom.
    I have VLC 1.1.2
    I opened up all the required ports on my router
    I changed the RTSP port from 554 to 5554
    I changed all sound settings to mono

    The remote control of VLC works. If I stream through http, I can play mp3s and audio from video files with no problem. It only messes up when I try to stream video to phone through rtsp.

    I've tried both on wi-fi and 3g but I always get the same thing. On wi-fi after I hit play, the screen will expand a bit as if it knows how to size the video. The timer bar starts to count up but there's no picture or sound. If I try to go to menu -> stop and close, I get an error that says, "ERROR: -38 / 0". That status message will stay on the screen even after closing VLCSC. I have to FC to get the status msg to go away.

    On 3g it's the same except the screen never expands like it does when I'm on wifi, and also I do not get the ERROR -38 / 0 message when hitting menu -> stop and exit. The time will keep counting up and every few seconds it'll say "Buffering ..."

    Ugh I've been trying to get this thing to work for the past 2 hours and I'm going crazy. Anybody encounter this before? I tried restarting my comp, reinstalling vlc/vlcsc atleast twice each. I opened all the ports on TCP first. When that didn't work I added UDP rules too.

    Somebody please help!! I'm dying to get this app to work. Will gladly upgrade to the paid license 10 times over if I can get it working on my phone.
  22. max-greece

    max-greece Newbie

    As ever my problem is different from everyone else. I am running VLC 1.1.0.
    The audio is working perfectly over both http connection and rtsp. The remote control function also works perfectly.
    What I cannot get is any video on my phone. I have tried every variation and permutation of MP4 / H 263 / H 264 etc etc and yet - nada.
    For reference my computer is running XP (Service pack 3) and my phone is the LG Optimus running Android 1.6.
    If this problem can be solved then this program gets my Android App of the year award.
  23. max-greece

    max-greece Newbie

    OK - that's funny - someone else with the exact same problem as me posting one minute earlier. Hi Painless - join the club.
  24. painless

    painless Lurker

    Damn. I saw a reply to my post and I thought somebody had come up with a solution already. Didn't expect to read somebody with the exact same problem posting a minute later hahah
  25. max-greece

    max-greece Newbie

    Actually we have slight differences looking at it. When I play video I do get the sound - just no picture and no resizing or anything to tell me to expect a picture.

    Gotta be something simple and dumb that I am missing......

Share This Page