1. Download our Official Android App: Forums for Android!

Support Voice recognition on SMS only working on WIFI

Discussion in 'Android Devices' started by Niniani, Sep 20, 2012.

  1. Niniani

    Niniani Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Sep 20, 2012

    Sep 20, 2012
    1
    0
    5
    Hello All

    I have finally given up iPhone for an Android phone - Galaxy S3 and am loving it so far but there is one issue that drives me mad.

    On my iPhone I used to always dictate txt messages (sms) to it and it was pretty good.. The Galaxy has a little mic icon on the keyboard and I can speak to it then and it is very good better than the iPhone recognition actually.

    But it only works on WIFI ! as soon as I turn the wifi off in my phone it just says CXonnection Error and thats it. Im not talking about the S Voice here only the speech - to - text recognition but the interface looks very similar so it probably is using the same API. This is useless to me, I usually want to dictate when I'm in a shop and need to do it quickly or when I drive (and no I don't want to use SVoice )

    Can someone confirm if it's only meant to work on WIFI and are you having the same problem? Maybe it's just my phone ? Maybe someone knows the solution ? I'm on T-Mobile UK.

    Regards

    Nini
     

    Advertisement

  2. djmisterb

    djmisterb Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Nov 7, 2012

    Nov 7, 2012
    1
    0
    5
    Me too - exactly the same problem - did you resolve it? can anyone help us?
     
  3. aldo82

    aldo82 Well-Known Member
    Rank:
    None
    Points:
    38
    Posts:
    111
    Joined:
    Jul 27, 2012

    Jul 27, 2012
    111
    12
    38
    i don't know the answer, sounds like a bug to me. It should work via 3G also. Perhaps not if you have a really poor data connection but if you've tried with a good 3G signal then not sure.

    Are you one Jelly Bean? If you are then you can download an offline language pack in the settings of google now. If you get this then will it allow you to dictate? As far as I know this should work even in airplane mode. Not the full soultion to your problem but could help till you get it fixed
     
  4. Heisenberg123

    Heisenberg123 Android Enthusiast
    Rank:
    None
    Points:
    78
    Posts:
    703
    Joined:
    Sep 25, 2012

    Sep 25, 2012
    703
    74
    78
    Hamilton, ON
    do you have a data signal when you turn wifi off?
     
  5. StixHo

    StixHo Lurker
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Dec 11, 2012

    Dec 11, 2012
    2
    0
    5
    Male
    USA
    I'm having the same problem here on AT&T as well. Works fine while using WiFi but once I switch back to 4G/LTE it doesn't work, just shows connection problem/error. Been searching the web for hours, still can't iron out a way to correct the problem. The strangest part is that everything else works while using the 4G/LTE data, Google search voice, S voice, all apps, etc... Just not the dang sms!!!
     
  6. StixHo

    StixHo Lurker
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Dec 11, 2012

    Dec 11, 2012
    2
    0
    5
    Male
    USA
    Okay... I figured out what was wrong with my text to talk, I'm not sure if what I did will help you or anyone else who reads this but I'll share it anyways.

    Considering that I despise all things background data I stopped the background data for my msg app and the Google/Samsung engines that's used for voice recognition on SMS to only use background data when connected to WiFi.

    All I did to correct this problem was to go to Settings--->Data Usage--->select apps. After that I just made sure all apps allowed background data on both WiFi and data.

    Hopefully this will help....

    Cheers
     

Share This Page

Loading...