Voicemail Notification & Alert Won't Leave


Hello All!

I have a ZTE Maven 1 with Android 5.1 (the newest the phone can use with this carrier). It is on AT&T Go Phone network. (Pay & Go is great for one who makes about 2 calls a month.)

For the last many days, the Voicemail icon is always in the upper bar of the screen and the Notifications screen shows "you have voicemail". Additionally, the voicemail audible alert comes on when the phone is turned on or turned off. I have no voicemail messages.

Here Are The Steps That I've Tried To Get Rid of The Notifications:
1) Reboot several times

2) Checked voicemail by calling from the phone, hoping to be able to delete a message. Nothing to delete.

3) Checked voicemail by calling from a different phone, hoping to be able to delete a message. Nothing to delete.

4) At Settings - Device - Apps - All: Cleared the following-
a) Phone with a Blue Icon: Cleared Cache (Data won't clear)
b) Phone with a Blue Icon (It appears twice on the list): Cleared Data & Cache
c) Phone/Messaging Storage: Cleared Cache (Clear Data is greyed out.)
I did not clear the App cache for the icon Phone with a green robot icon. I don't know what it is and backed
off from messing with it. In that one, Data = 0.00B Cache = 32.00 KB (I tend to stay away from messing with any green robot app icon items, or any that say Qualcom.)

Next, I called AT&T to ask if it was a problem from them. They said no & quickly changed the subject to signing up for a contract. (Surprise! Who'd a thunk they'd do that?)

The Real Crummy Part:
When a new (real) voicemail arrives, there is no new notification sound or notification banner.

Can you think of anything that I have missed in this futile attempt to stop the voicemail notifications & alerts?

Thanks Very Much for helping. It's appreciated.

Please Enjoy This Day!


Android Expert
Also, clear the cache in the Voice Mail app.

If that fails, then clear the data.
That will reset the app.

Your voicemails are not stored onthe device, so you wont lose any that you may have saved.


Thread starter
Hello DannyDet & Puppykickr. Thank You both for taking time to reply.
I goofed, DannyDet, and forgot to mention that swipe right doesn't work.

I searched the Apps list in Settings - Apps - All and don't see one for Voicemail, Puppykickr.
Items A & C on the list in my first post won't allow Data to be cleared, but the Item B allows it & I cleared the Cache.

With all the checking & cache clearing that failed to solve the problem, do you think perhaps AT&T is sending a Voicemail alert by mistake? (They said no, but were more focused on trying to sell me a contract than solving the problem.)

Thanks Again!


Thread starter
Solved - Was a case of M. A S. (Mysterious Android Stuff)
I go the alert to leave by deleting messages in what AT&T calls "The Archive".

When I listen to a message & wish to save it, I can press key pad 4 and the message is saved for a certain number of days. This can be done on the phone or via a different phone. It used to be OK to do this and no alerts of voicemail would arrive. I always have one or more in the "archive".

When the permanent alert problem drove me a little too crazy, I called voicemail and deleted the archived messages. Now the non-removable voicemail alert is gone.

I restarted the phone, left it a message & acknowledged the alert when it arrived on the phone. The alert was gone, as it should be.

Next, I called voicemail, listened to my message and then saved it in the archive. Later, I restarted my phone and the voicemail alert showed up. I could not get it to leave. I called voicemail and all that was there was the archived message.

So, this leads me to believe that it's a new AT&T thing, or a phone glitch, that causes a permanent notification if one has a message in the archive.
The odd part is one can swipe away a new voicemail message without listening to it ONLY if it is a new message.

Crazy, Crazy M . A. S.

Thanks again DannyDet and Puppykickr for helping. I really appreciate the time you took!
Enjoy This Day,