1. Are you ready for the Galaxy S20? Here is everything we know so far!

W7 64-bit (Ultimate) won't install drivers on Galaxy S3

Discussion in 'Android Devices' started by redbourn, Jan 11, 2013.

  1. redbourn

    redbourn Member
    Thread Starter

    I have a GT 19300 v4.1.2 and all was well until a week or so ago.

    W7 64-bit

    Now when I connect the phone to my PC (W7) the system sees it and tries to install drivers but then gives a message saying the it failed to install them.

    Device manager now shows my phone as an unknown device and it didn't before.

    I don't think this is a cable or a Kies problem, because I've installed and uninstalled Kies and tried a new cable.

    I haven't done a reset because many other people tried it and all it did was waste their time :-(

    I have the Samsung GS3 Int ToolKit and it installed the latest drivers today and they didn't help.


    Today I disconnected the internet and plugged the phone into a different USB socket before booting the PC

    The message I got this time was,

    Samsung_Android X Device unplugged

    Unidentified Device X No driver found

    The above makes no sense to me but if it does to you then please let me know.

    Later Today

    I got a message on my cellphone "the software does not exist on your computer to allow it to connect with your phone. You need .. XP with Windows media player ... etc." I don't remember the exact words but I'm using W7 64-bit.

    Then when I 'unplugged' my phone W7 said drivers are being installed and then said "not successfully installed".

    But the auto-play box opened for a few seconds and although it didn't show files on my PC it did recognize the phone as a Samsung android and even the model I think.

    I'm relatively computer literate but very weak on androids.

    Any help would be much appreciated!


  2. Mikestony

    Mikestony ~30% Carbon Black ±

    Your mention of Windows Media Player makes me think vaguely of someone else having an issue such as yours and I think they had to update Windows Media Player to get it to work...not sure, but worth a shot:)
  3. redbourn

    redbourn Member
    Thread Starter

    Thanks for the reply.

    I'm running the latest version.

    It would seem like Windows and Samsung haven't got their act together on the latest Galaxy update.
  4. slurp812

    slurp812 Newbie

    Maybe its something with ultimate? I have win7 home premium 64 bit, and it works fine. In fact yesterday there was a windows update install for Samsung electronics that failed. Maybe the update is broken? I am looking into why mine wont install. OK, I plugged in the phone and manually checked for updates, and this time is was successful. Maybe you could try to run updates with the GS3 attached and unlocked, and see if windows updates installed the latest software?
  5. redbourn

    redbourn Member
    Thread Starter

    Thanks for the reply.

    I just checked Windows update and there' nothing available.

    My problem started after the last Samsung update and it would seem that MS hasn't caught up with it yet.

    There's a lot of stuff about this on different forms. Different Windows systems and MAC too!

    Once I get this sorted out I'm going to turn off automatic updates on my phone and only update when people stop complaining or seem happy.
  6. oNOVAo

    oNOVAo Newbie

    I have 7 and 64 bit and have only had one problem and that was updating my phone with kies i had to disable my anti virus protection and it worked fine and once updated just turned it back on.
  7. redbourn

    redbourn Member
    Thread Starter

    I uninstalled Kies a couple of days ago because it can supposedly cause conflicts.

    Turned off my anti-virus but drivers didn't install.

    Just read on another forum that Samsung know about the problem and don't yet have an answer; but the post was dated last July.


    DSTURBED Lurker

    I have the exact same problem running W7 U....Waiting for an update
  9. redbourn

    redbourn Member
    Thread Starter

    Not sure it's only W7 I've seen all kinds of systems listed including mac.

    I think it was nuts for me to chase around for three days, buying a cable, buying a blue tooth adapter and reading hundreds of posts.

    I can actually do anything that I want do via Airdroid because it uses wi-fi.

    Looking at dates it would appear that installing the latest firmware caused the problem 4.1.2 in mid December.

    It was interesting today when I booted up my pc with the phone plugged in. It saw the phone and model number and asked (the auto-play screen) how I wanted to open the phone in future. And then the phone disappeared :-(
  10. redbourn

    redbourn Member
    Thread Starter

    Twice in the last half hour the auto-play suddenly appeared and I was able to see the content of the phone; for a minute or two.

    I turned off the pc, rebooted started the phone and plugged it into a difference usb slot.

    On boot up the system tried five times to try and install the drivers instead of just once.

    It didn't succeed and I have no idea what changed today.


Samsung Galaxy S3 Forum

The Samsung Galaxy S3 release date was May 2012. Features and Specs include a 4.8" inch screen, 8MP camera, 1GB RAM, Exynos 4412 Quad processor, and 2100mAh battery.

May 2012
Release Date

Share This Page