1. Download our Official Android App: Forums for Android!

Apps WARNING: Application does not specify an API level requirement!

Discussion in 'Android Development' started by StevenHu, Mar 2, 2011.

  1. StevenHu

    StevenHu Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    91
    Joined:
    Feb 8, 2011

    Feb 8, 2011
    91
    0
    15
    Male
    Webmaster
    Orange County
    I get this message in the console when testing on an Android device: "WARNING: Application does not specify an API level requirement!"

    I checked my AVD manager in Eclipse and the API level is there. But how do I specify it in the application?

    Thanks!
     

    Advertisement

  2. cr5315

    cr5315 Android Enthusiast
    Rank:
    None
    Points:
    68
    Posts:
    434
    Joined:
    Jul 23, 2010

    Jul 23, 2010
    434
    158
    68
    Narnia
    In your AndroidManifest, go to the </application> tag and right under that put
    <uses-sdk android:minSdkVersion="3" />

    The 3 is the API level for Android 1.5
    If you want other levels, use:
    1.5 - 3
    1.6 - 4
    2.1 - 7
    2.2 - 8
    2.3.1 - 9
    2.3.3 - 10
     

Share This Page

Loading...