1. Check out our companion app, Forums for Android! Download from Google Play

Support Weird?... ( battery question )

Discussion in 'Android Devices' started by Clittzen, Jul 21, 2010.

  1. Clittzen

    Clittzen Well-Known Member
    Thread Starter
    63

    May 22, 2010
    357
    42
    63
    Student.
    New River, AZ.
    So, I was at work yesterday. Up at 330 AM, at work at 4. Phone was on entire time. At about noon the battery was at about 50%. I was very excited about this. I put my phone down for 20 minutes, came back and it was down to 5%? Drained the entire battery yesterday and let it charge overnight. Haven't seen any problems. Didn't have anything like this before the update. Has anyone else seen something like this?

    I did a reboot and took battery out as well to see if it was a false read, but nothing...
     

    Advertisement

  2. Helicrewchief

    Helicrewchief Well-Known Member
    43

    Jun 30, 2010
    191
    31
    43
    Blackhawk Crewchief
    North Carolina
    Its been like this for me since launch. For me its fine until I hit 30% usually around 10 hours of moderate use and within 30 minutes my phone is dead. I'm a firm believer in letting the battery "condition" but after a week it seems like we should really start seeing some improvements on the battery.

    Looks like I will need to invest in a larger battery. :(
     
  3. Clittzen

    Clittzen Well-Known Member
    Thread Starter
    63

    May 22, 2010
    357
    42
    63
    Student.
    New River, AZ.
    Hmm, it never did it for me before though and I use my phone to the end of its existance for that day lol. I am thinking it has something to do with the update. I am going to test it today and see if the same thing happens. I hope not though.
     

Share This Page

Loading...