1. Download our Official Android App: Forums for Android!

Support weird problems? anyone else having these?

Discussion in 'Android Devices' started by andid, Jun 14, 2012.

  1. andid

    andid Newbie
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    25
    Joined:
    Apr 10, 2012

    Apr 10, 2012
    25
    0
    15
    So my son and i both got the elite and are having weird but different problems,when he makes a call the screen stays black so he cant hang up and has to remove the battery to hang up, my phone answers itself when i get a call, ill be sitting on the couch and my phone on the end table and i will hear someone screaming hello! it didnt ring, just answers incoming calls by itself...this happens a lot, any one else have this issue? or maybe know why this is happening?
     

    Advertisement

  2. ktb83

    ktb83 Android Enthusiast
    Rank:
    None
    Points:
    93
    Posts:
    653
    Joined:
    Jun 10, 2012

    Jun 10, 2012
    653
    212
    93
    Well, for your son's issue...

    There is a sensor located just to the left of the Virgin mobile logo on the front of the phone. If the phone still has the screen protector which came with it, you'll see a cutout for it there. Try wiping/cleaning off that part of the phone. The screen should come back on then after taking the phone away from your ear. You might want to try cleaning it really well and installing a good screen protector which will cover that area to prevent smudges, etc.

    I hope this suggestion helps.

    I'm not sure what could be causing the issue with your phone.
     
    andid likes this.
  3. andid

    andid Newbie
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    25
    Joined:
    Apr 10, 2012

    Apr 10, 2012
    25
    0
    15
    thank you very much, i will pass this on to him
     
  4. kwknott

    kwknott Android Expert
    Rank:
    None
    Points:
    253
    Posts:
    1,520
    Joined:
    Mar 19, 2012

    Mar 19, 2012
    1,520
    729
    253
    Your phone sounds like there may be a hardware or software issue. I'd try a factory reset and if that didn't help I would look at returning it for exchange if you recently got in store or call VM for a warranty replacement
     
    andid likes this.

Share This Page

Loading...