1. Are you ready for the Galaxy S20? Here is everything we know so far!

What to do if 2.0.1 update fails to install

Discussion in 'Android Devices' started by twjonesjr, Dec 11, 2009.

  1. twjonesjr

    twjonesjr Newbie
    Thread Starter

    Ok so the update notification came in and I went under settings to manually check for system updates and proceed with the install. All seemed to be going normally but then the update failed. I know this because I saw this screen: http://support.vzw.com/images/droid_upgrade9.jpg.

    I followed the instructions per Mandatory System Update: DROID by Motorola on removing battery and restarting. However when I go to settings to check for new system updates it says that "I'm up to date". Firmware is still 2.0


    1. Download the Forums for Android™ app!


  2. jestexman

    jestexman Android Enthusiast

  3. blakejohann

    blakejohann Lurker

    If instead of taking the battery out you hold down volume up and press the camera button at the ! screen- it will take you to a ui that tells you an update error and gives you the option to reboot. The error i got: assert failed: appy_patch_check("MTD:boot:2512896:86ce122fdfab1ca 7aea268575ec692699c8556ab:2502656:e79414a1774b152c 9c3eca09f1be0c6b1b24e889") is the same error I got when I tryed to manually apply the patch two days ago.

    You could try to manually apply yourself- there are instructions here: AllDroid.org - View topic - 2.0.1 Update.zip but I don't know how to get the phone to attempt to auto update again- maybe just wait?
  4. twjonesjr

    twjonesjr Newbie
    Thread Starter

    I can't try that though because after the screen with the exclamation mark came up, I pressed the power button instead of taking the battery out (I had not read the verizon instructions on the site I linked above). So my phone continues to operate like normal but the firmware version is still 2.0 and every time i go to check for system updates, it says i'm currently up to date.

    Will this update just get pushed out again eventually since apparently there's no way to force this download other than to do it manually (which I don't really trust myself to do)
  5. fortworthbret

    fortworthbret Member

  6. jestexman

    jestexman Android Enthusiast

    My OTA failed and the Manual update also failed. I am on the phone with VZW right now. Stay tuned.
  7. twjonesjr

    twjonesjr Newbie
    Thread Starter

    hahaha thanks for rubbing it in man but that picture is pretty comical.

    Thanks for the update jestexman. I also tried calling last night but they said to call from a different number than the phone affected and i have no other line so that ended that quickly. Keep me posted!
  8. jestexman

    jestexman Android Enthusiast

    they are telling me to pull my battery but i cant get the dam body glove case off. Have you already tried that? I told them i have done that and nothing happened.
  9. twjonesjr

    twjonesjr Newbie
    Thread Starter

    I did. I took the battery out after powering off and then putting it back in and powering on and checking for an update and nothing happened. Also tried taking battery out while phone was still on and doing the same above and nothing
  10. jestexman

    jestexman Android Enthusiast

    Ok so she put me on hold and came back and said the person she talked to said oh tell him his phone got the update.

    I said oh so i got the update!! Wow and i was worried i did not!! I then went on to tell them that i did not get the update or i would not be on the phone with them.

    Long story short they are sending me a new phone.
  11. twjonesjr

    twjonesjr Newbie
    Thread Starter

    wait so why are they having to send you a brand new phone? i have seen others say where worst case, you could take it to the store and they could install the update from there.
  12. jestexman

    jestexman Android Enthusiast

    i told them about some of the other problems i was havening.High pich ringing while on a call maps crashing and now it wont update.

    Oh and i tried to go to the store the other day they said they cant do it
  13. twjonesjr

    twjonesjr Newbie
    Thread Starter

    interesting. i'll have to call later and see what they tell me but my phone has been fine except for the lack of an update.
  14. flatfoot

    flatfoot Lurker

    I also had the upgrade failed and called verizon. they had me remove the battery a couple of times. when that didn't work, they said i needed a new phone. the new phone will not come with and updated OS so i'll need to retry it with the new phone.
  15. Trebacz

    Trebacz Lurker

    I talked to the a Verzion rep after my failure -and waiting about 8 hours for it to resend my update. I found my answer here:

    AllDroid.org - View topic - 2.0.1 Update.zip

    Applied my update and all seems to be working great -I'm now running 2.0.1
  16. twjonesjr

    twjonesjr Newbie
    Thread Starter

    well i ended up having to get a new phone from Verizon. I called customer support and they were unable to help me get the update installed as it failed again. so they directed me to the store where i had to get a brand new phone and by the time i got in my car and was going to drive away the notification for the update appeared. i installed it and all has been well since.

    Hopefully Google and/or Verizon will figure out a better solution to this problem than just giving out brand new phones just because some won't update
  17. inahaz

    inahaz Lurker

    My update did not work either. The night prior my battery was very low so I turned off the phone. Friday morning after turning it on, I received the upgrade message about 5 minutes later. (Battery still low.) I delayed the install. It popped up 5 minutes later. I proceded to install.

    The force close message then came up. I closed it but nothing else happened. Did a few battery pulls and power cycles. It hasn't been sent again. (Manual update screen says I'm up to date, but still showing the 2.0 version and old unlock screen.)

    I'll wait a few more days, then call the number. I haven't had any problems with my phone, so I'm not in a hurry.

    I'm probably a bit anal, but I'd rather get the update directly from verizon than manually from the 3rd party site. (version control, trust, etc.)

    My wife has the same phone. It worked flawlessly on hers. She claims it's faster, but I don't see much of a difference. I'm going to do some side by side tests.
  18. Campah

    Campah Member

    My update didn't work either, and neither did manually updating. Several calls to Verizon ended up getting to Motorola support, and they sent be back to Best Buy to replace the phone (which was a fun 3 hour session pleading my case...)

    I have yet to see a fix for the assert failed: appy_patch_check("MTD:boot: error. Everyone seems to have had to replace their phone. Where it fails at checking the current system, I'm pretty sure that the base OS already installed on these phones has some sort of problem and fails whatever check the update does. Even a restore of the phone wasn't fixing my problem.

    The update thread is so buried now, and I'm too lazy to find it, but you can read my struggle there.
  19. inahaz

    inahaz Lurker

    My issue seems a bit different than yours. I didn't get the assert failed message you've listed above. My install didn't even start. I'm just going to wait around and maybe the customer service folks will learn a bit more on how to fix it rather than replace it. I don't really want to go through the hassle of installing everything on a new device, etc. Plus, 2.0 works fine for me. Maybe I'll just wait until the next OTA update.
  20. Eueyj

    Eueyj Lurker

    I had this on my phone however after rename my corpcal.bak back to the original corpcal.apk my phone then upgraded fine and is now happily running 2.0.1.

    Have you rooted your phone and renamed anything or deleted anything?
  21. exposed29

    exposed29 Lurker

    My phone too failed the OTA update. The manual update wouldn't work either... I had the exact problem as Campah. Finally called support today and after nearly two hours on the phone they resorted to sending me a replacement. Reseting the phone to the factory settings would cause the update to download but I always got the triangle with exclamation mark. Nobody I spoke to on the support line ever heard of the problem that just a few of us are having.

    Anyway, my Droid worked great otherwise... hopefully the replacement does too.

Motorola Droid Forum

The Motorola Droid release date was November 2009. Features and Specs include a 3.7" inch screen, 5MP camera, 256GB RAM, processor, and 1400mAh battery.

November 2009
Release Date

Share This Page