1. Are you ready for the Galaxy S20? Here is everything we know so far!

When rooting... and getting to the end commands what should the prompt be?

Discussion in 'Android Devices' started by Not techie, May 28, 2010.

  1. Not techie

    Not techie Newbie
    Thread Starter

    I am following the steps of this walkthrough . I have now completed parts two and 3 however...

    during step 3 it asks to enter these in a command prompt.

    adb shell mount -o rw,remount /dev/block/mtdblock3 /system
    adb push recovery.img /sdcard
    adb push flash_image /system/bin
    adb shell chmod 755 /system/bin/flash_image
    adb shell flash_image recovery /sdcard/recovery.img

    After entering these I get a message saying

    "flash_image": not found

    at the end of step 3 is that what is supposed to happen? from this I gather that the partition has not been created...

    Is it safe to go on to step 4?

    1. Download the Forums for Android™ app!


  2. hallstevenson

    hallstevenson Android Expert

    When you did first two "push" commands, did it give you info on how much and how fast the file(s) were pushed (copied) ?

    Start over, there's no harm in doing so. Things must be typed EXACTLY right.
  3. erisuser1

    erisuser1 Android Expert

    Hi Not techie,

    Simple answer - No. Fix the problem at the current step and then move on.

    It looks like you are making progress - that's good.

    The error message that you are getting indicates that the "flash_image" file that you unpacked from the "recovery.zip" archive is not in the same folder (directory) that is the "current directory" where you are running the commands.

    Check to see if it is there using either Windows Explorer, or by just typing the command "dir" in your command window (without the quotes).

    I'm assuming you got your device driver(s) installed - if so, when you type the command

    adb devices

    you should see your phone Device ID show up "HTA...." (letters and digits).

  4. Not techie

    Not techie Newbie
    Thread Starter

    so I am essentially searching for a file in a location where the file is not at.. got it.

    I will check to see where the darn thing is!

    thanks for the awesome help!
  5. theboo7

    theboo7 Well-Known Member

    or just redownload and extract it
  6. erisuser1

    erisuser1 Android Expert

    The place it is supposed to be is in the folder indicated by the "prompt" in your command window - probably your tools folder.

    You didn't mention a problem with the 2nd line of those instructions, which is essentially the same type of command ( push a file from your PC to the SD card on the phone), so you must have unpacked the "recovery.zip" file into that folder ... otherwise, you would have also seen a message such as

    "recovery.img" not found.

    You must be getting part of it right ... ;)

  7. Not techie

    Not techie Newbie
    Thread Starter

    the flash image is a 10kb file, but the updated file is 3834 kb. they are both in the tools folder of the android sdk folder.

    I have typed it several times paying close attention to the spelling.

    but still get the same message.

    Am I suposed to be typing a space between the word, and the first forward slash?
  8. Not techie

    Not techie Newbie
    Thread Starter

    yes I did not get it right the first time, but I checked and had made a spelling mistake. after I got it right there was a lot of script in the command window.

    At this time I have removed both the Flash_image file, and the recovery file. then unzipped them and put them back in the folder.

    but nothing has changed...

    thanks for continued encouragement!

    I am stuck now.
  9. erisuser1

    erisuser1 Android Expert

    I am having a hard time imagining what you are trying to say.

    The best way for you to ask this type of question is to cut and paste the exact text that is on your screen, and paste it (Ctrl-V) in your post between the "tags"

    [ CODE ]
    [ /CODE ]

    When you use those (tags) above, don't leave any spaces after the left bracket `[' or before the right bracket `]'. I typed them this way so you can see what I mean.

    Here is an article that shows you how to do the cut-n-paste from the Windows command window.

  10. erisuser1

    erisuser1 Android Expert

    Also, note that the 3rd command that you refer to

    Code (Text):
    2. adb push flash_image /system/bin
    is simply copying the file "flash_image" to the top-level folder of the SD card.

    If you know how to do that by "Mounting" the SD card to your PC, just do that instead. If you don't, then don't get distracted with that method.

    BTW, You never answered the question:

    When you use the command "adb devices", do you get some output which indicates that your phone is connected?

  11. Not techie

    Not techie Newbie
    Thread Starter

    ok.. let me see if I understood this.

    these are steps 3-5 since step 2 seems to be working

    Code (Text):
    2. C:\ANDROI~1\ANDROI~1\TOOLS>adb shell chmod 755/system/bin/flash_image
    3. Usage: chmod <MODE> <FILE>
    5. C:\ANDROI~1\ANDROI~1\TOOLS>adb shell flash_image recovery/sdcard/recovery.img
    6. flash_image: not found
    8. C:\ANDROI~1\ANDROI~1\TOOLS>adb shell flash_image recovery/sdcard/recovery.img
    9. flash_image: not found
  12. Not techie

    Not techie Newbie
    Thread Starter

    Just the flash image or the recovery as well?

    I can do that no problem. I can just copy the flash_image to the "removable disk" which is the sd card mounted on the phone.
  13. erisuser1

    erisuser1 Android Expert

    copy them both. But hang on, I see several problems with your prior post - give me a chance to write something here.
  14. erisuser1

    erisuser1 Android Expert


    Each of those commands resulted in an error.
    should be

    Code (Text):
    2. adb shell chmod 755 /system/bin/flash_image
    3. adb shell flash_image recovery /sdcard/recovery.img
    yes, you need a space after the 755 and after the word recovery.

    Note that in the same way that you cut and pasted text into this post, you could have cut-and-pasted text from the walkthrough into your command window - that would have saved you some spelling errors

  15. erisuser1

    erisuser1 Android Expert

    As a previous poster commented, it will do you no harm to re-run all the commands in sequence. That way we're sure that you haven't made any prior mistakes.

    What I want you to do is the following:

    One at a time, copy each line of the below commands (highlight in your browser using a with left click and drag, then Ctrl-C), and then paste them (Ctrl-V) onto the command line and hit the Enter key

    Code (Text):
    2. adb shell mount -o rw,remount /dev/block/mtdblock3 /system
    4. adb push recovery.img /sdcard
    6. adb push flash_image /system/bin
    8. adb shell chmod 755 /system/bin/flash_image
    10. adb shell flash_image recovery /sdcard/recovery.img
    Then, copy and paste that whole block of text back to a post here.

  16. Not techie

    Not techie Newbie
    Thread Starter

    so now when I do that after copying the second line, it says that the recovery.image is a read only...

    Any ideas? why would it say that? isnt this supposed to be a no hassle file?

    unfortunately I have to give this project another break as I am due at work in 9 hrs. but would gladly pick this up on sunday night.

    your support has been inspiring enough to get back to this as soon as I can for every free minute I can... you could say I am slightly hooked! This stuff is very interesting I just wish I didn't encounter a problem at every turn. but who knows maybe I can walk someone else through this soon!
  17. erisuser1

    erisuser1 Android Expert

    My first suspicion is that you left the SD card "mounted" to the PC when you went to copy the files over manually, and the phone does not have it mounted any longer. (The phone and the computer can not share the card at the same time, only one of them have control of it). The place where it would normally be "mounted" on the phone is a directory "/sdcard", which is in the root file system on the phone - a read only file system.

    You need to unmount the SD card from the PC (First using the "Safely Remove Hardware" control on the PC, and then using the SD card menu on the phone) before those instructions will work - reverse the steps you took to get the phone sharing it's SD card to the PC.

    No worries - actually, I think you are literally inches away from getting it done. You clearly solved the problems with the device driver install.

    I will repeat my earlier comments though: in your posts, you need to put up a verbatim transcript of what you are typing, and exactly what responses the computer is giving you... anything else requires both of us to guess at what each other is saying, and that's a recipe for profound mis-understanding. Use the cut-n-paste trick with the [ CODE ] [ /CODE ] encapsulation.

    I can add one more tidbit that you will find useful: I think that every one of those commands, if it is successful, will be absolutely "silent". That is typical of Unix command-line utilities. So, you can use that as a gauge of whether or not you are seeing further failures.

    The key line is this one:

    Code (Text):
    2. adb shell flash_image recovery /sdcard/recovery.img
    If that works, the very next thing you should try is to power down the phone, and power it back up by holding down the Volume-Up and End/Power buttons simultaneously (keep holding them down until the screen lights up with the "three skating droids").

    Hopefully you will see this after about 12 seconds:

    (image courtesy of jxnrxy)

    If you see that, you are on the home stretch - you just need to download a ROM .zip file to the root of your SD card and install it (using menu item #4).


    PS, for completeness, I should point out that, over in that other post, I mentioned that Ivanmj's zip file "recovery.zip" file contains an older version of Amon_RA's recovery.img file. You really ought to be using the newer version. I couldn't tell from your more recent posts whether or not you had downloaded that newer file, and that was the "recovery.img" file you were talking about. See that other post for details - I put links in it for everything.
  18. hallstevenson

    hallstevenson Android Expert

    Or he typed the "mount" command line incorrectly.
  19. Not techie

    Not techie Newbie
    Thread Starter

    Just wanted to say thanks for all of your help guys. I did find out what the problem was and as erisuser1 pointed out it was the adb.

    Once it worked it was flawless thanks so much for your help and valuable info!


HTC Droid Eris Forum

The HTC Droid Eris release date was November 2009. Features and Specs include a 3.2" inch screen, 5MP camera, 288GB RAM, MSM7600 processor, and 1300mAh battery.

November 2009
Release Date

Share This Page