1. Are you ready for the Galaxy S20? Here is everything we know so far!

Where do the app file is downloaded to?

Discussion in 'Android Devices' started by emaeo, Jun 28, 2013.

  1. emaeo

    emaeo Lurker
    Thread Starter

    Hello guys

    Android version: 2.2
    No task killer app is used
    Phone not rooted

    Issue:

    I had a 35 Mb free space internal memory, i tried to install an app (44 MB) from the market, but i have forced apps to be installed on the sd card without rooting (using some thread in this forum). Any way, while downloading the app, Google play shows that the zipped apk file was around 11 MB only, so it was successfully downloaded. But while installing, it showed an (Insufficient storage available) error and the installation was terminated.
    The problem is that the free internal storage was reduced to 16 MB even the app was not installed. I tried to do the same process again, and now the internal memory is reduced to 11 MB

    Where can I find the downloaded apk file, and can I delete it?

    Please note that i tried clearing the cache using many apps (App 2 SD, Elixir, & History eraser). Also i tried rebooting the phone.

    Fast response is highly appreciated

    Thanks in advance
     



    1. Download the Forums for Android™ app!


      Download

       
  2. emaeo

    emaeo Lurker
    Thread Starter

    Come on guys, does any one at least know where I should start searching?
     
  3. A new update has been released into germany that allows u to move apps from phone memory to sdcard , just wait until the update comes to ur country and update it
     
  4. emaeo

    emaeo Lurker
    Thread Starter

    Thanks for the reply, but as I mentioned I have forced apps to be installed to the sd card (using some post in this forum). But I guess the apk zipped file is first downloaded to the phone memory before being installed to the sd card. So I am seeking of a way to delete that apk zipped file ( which failed to be installed, as I mentioned in the main post)
    Hope i made my self clear
     
  5. Hadron

    Hadron Smoke me a kipper...
    VIP Member

    @Android Player: That's for the S4, not the HTC Desire. Or were you posting from Tapatalk? That sometimes posts in a completely different thread from the one you were looking at ;)

    @emaeo: If it's in internal memory rather than the cache partition then it's probably in the /data area, which on an unrooted phone you have no direct access to. The thing is, if you force install to sd that only moves the apk (apk plus lib when running 2.3). Other app components remain in internal storage, and that's why you've hit low memory.

    It might not be the apk either - could be another app components (e.g. the .dex file - dalvik cache element, which will always be in /data), or some data file that the app downloaded. I'd look in /data/app or /data/data, but as I say, without root you can't do that.

    The trouble is, if it is somewhere you can't see, and the app isn't installed (so can't be uninstalled), there might not be a fix other than a factory reset, which has the drawback of erasing everything.
     
    emaeo likes this.
  6. emaeo

    emaeo Lurker
    Thread Starter

    Thanks for the help :)
    The sentence which helped, is when you said:
    "The trouble is, if it is somewhere you can't see, and the app isn't installed (so can't be uninstalled),..."
    So I uninstalled some apps to free some actual space for the 44 mb to be installed. And then I uninstalled the app after correctly installing it. And then re-installed the app. And by comparing the free space before and after the re-installation, I got 5 more mb. So I guess its solved now.

    Thanks again :)
     
    Hadron likes this.
  7. Hadron

    Hadron Smoke me a kipper...
    VIP Member

    Ah, good thinking! :D
     

HTC Desire Forum

Features and specs are not yet known.

unknown
Release Date
0
Reviews
Loading...
Similar Threads - Where app file
  1. AuroraR
    Replies:
    1
    Views:
    295
  2. dontpanicbobby
    Replies:
    5
    Views:
    469
  3. user_2014
    Replies:
    0
    Views:
    343
  4. Katies1290
    Replies:
    5
    Views:
    1,042
  5. Julie3322
    Replies:
    1
    Views:
    361
  6. connor99z
    Replies:
    5
    Views:
    926
  7. Shorefisher
    Replies:
    1
    Views:
    1,376
  8. Biffos
    Replies:
    8
    Views:
    2,530
  9. Ghulam Mujtaba Jatoi
    Replies:
    0
    Views:
    5,324
  10. Elton Brown
    Replies:
    3
    Views:
    3,332

Share This Page

Loading...