Whoa, Swype?!


Android Enthusiast
So i've been using swype all day....LOVE it. outta nowhere it says my "trial has experied, you must upgrade swype"


I thought this was a free program! anywho, i like it enough i may buy it. but, uh, how?!?! i see nowhere to upgrade! any thoughts?


Android Enthusiast
Try another link to download, there were a few versions floating around, one of which was a beta trial I believe.


Android Enthusiast
Thread starter
Yeah, I did the beta trial one i think....because every link i found said "sorry swype is incompatible with this screen resolution"

none worked on my eris except one, which was in a comments section of the link posted in the Apps for the Eris sticky thread.

got a link?


Android Enthusiast
I would just try re-downloading the first link he has on his original post and see if that works. If not, try the 2nd? I'm not too sure of the differences other than the theme... I'm pretty sure they can stand alone.

Sorry if I'm confusing you, I've been up for about 24 hours now. I'm coming off of night shift into my weekend :D
I know this was a while ago but I had the same this pop up on my Incredible this morning. After some investigating on the Swype Beta forum, I found the advice to uninstall the keyboard through Settings - Applications - Swype and then reinstall through the Swype Installer available on the Swpe Beta Website. Apparently the beta versions are only good for 100 days at a time, so I'll have to remember this for next time.

Like I said, I know this is an old post and I'm sure that you aren't having an issue anymore, but since this post popped up on Google, I thought I would post and help someone else. =)
I just got this message as well saying that I need to upgrade Swype. In the settings it doesn't allow me to delete the program. Is there another way to delete it before I reinstall it from the website you mentioned above?


Android Enthusiast
glad i'm not the only one. haven't tried to do anything yet. was going to try uninstalling reinstalling, but i'll have to do that later today.


Well-Known Member
I still have Swype but now the actual "swype" feature where you trace the word you want to input doesn't work. I can still tap out the letters tho, and send as well. What gives???

UPDATE: Just saw the "trial period has ended, please upgrade" pop up on my phone. Will try the new download and report back.

UPDATE: Did the old "uninstall - reboot - download the new installer - install" routine and back in business. Crisis averted!



Android Enthusiast
you've got several options,

1. join the beta and get whatever is there each time.
2. google any of the following and look for what you want(HVGA is the screen type that the eris uses, NOT WVGA etc):


and of course there are even lower versions that still work good, many of them should work, as stated above, you remove, reboot reinstall and trial is back in play.

all swype versions are "trial" for the most part unless they've been hacked well.

good luck.