1. Download our Official Android App: Forums for Android!

Root Why can't I downgrade from Gingerbread??????

Discussion in 'Android Devices' started by aswethinkweiz, Jul 12, 2011.

  1. aswethinkweiz

    aswethinkweiz Newbie
    Thread Starter
    Rank:
    None
    Points:
    18
    Posts:
    17
    Joined:
    Jun 14, 2011

    Jun 14, 2011
    17
    13
    18
    Male
    nerd
    Auckland, NZ
    Hi all,

    So I've been trying to root my gingerbread upgraded DHD but with no luck. Looking for a litte insight as to how I've went wrong.

    1. Tried following the below link
    [GUIDE] Telus Desire HD - Rooting and Flashing - xda-developers

    Prob here from what I read was that these instructions were for if you had froyo still installed so when i put in the last line, the cmd gives the error message:

    adb push psneuter /data/local/tmp
    adb push misc_version /data/local/tmp
    adb shell chmod 777 /data/local/tmp/psneuter
    adb shell chmod 777 /data/local/tmp/misc_version
    adb shell /data/local/tmp/psneuter

    Failed to set prot mask (innappropriate ioctl for device)

    So I found out that I need to use gingerbreak but have had no luck with that either. I downloaded the DOWNGRADE file needed and pointed the CMD to it but am still getting nothing. See below

    Microsoft Windows XP [Version 5.1.2600]
    (C) Copyright 1985-2001 Microsoft Corp.
    C:\Documents and Settings\**********>cd c:/desktop/Downgrade
    C:\Documents and Settings\**********\Desktop\Downgrade>adb push misc_version
    /data/local/tmp
    15 KB/s (0 bytes in 15837.001s)
    C:\Documents and Settings\**********\Desktop\Downgrade>adb push GingerBreak /
    data/local/tmp
    1051 KB/s (0 bytes in 16830.000s)
    C:\Documents and Settings\**********\Desktop\Downgrade>adb shell chmod 777 /d
    ata/local/tmp/misc_version
    C:\Documents and Settings\**********\Desktop\Downgrade>adb shell chmod 777 /d
    ata/local/tmp/GingerBreak
    C:\Documents and Settings\**********\Desktop\Downgrade>adb shell
    $ ./data/local/tmp/GingerBreak
    ./data/local/tmp/GingerBreak
    [**] Gingerbreak/Honeybomb -- android 2.[2,3], 3.0 softbreak
    [**] (C) 2010-2011 The Android Exploid Crew. All rights reserved.
    [**] Kudos to jenzi, the #brownpants-party, the Open Source folks,
    [**] Zynamics for ARM skills and Onkel Budi
    [**] donate to 7-4-3-C@web.de if you like
    [**] Exploit may take a while!
    [+] Plain Gingerbread mode!
    [+] Found PT_DYNAMIC of size 232 (29 entries)
    [+] Found GOT: 0x00014360
    [+] Using device /devices/platform/goldfish_mmc.0
    [*] vold: 0000 GOT start: 0x00014360 GOT end: 0x000143a0

    Basically I'm truly stuck with where to go from here. I have tried 10+ times or more to run the gingerbreak from the downgrade v2 but get no further then the above. Do note that I have waited quite some time with each running say 20-30 mins and got nothing ut the last line of listed from the command prompt

    Even tried the below for kicks:

    1. Did factory reset on the DHD....tried again and no luck
    2. Recreated gold card a few times and still no go

    Could someone out there shine a little light on how I may get past this and downgrade so that I can root. I read somewhere that the only way to use gingerbreak is with S-OFF and not S-ON.

    Please help!!
     

    Advertisement

Share This Page

Loading...