1. Download our Official Android App: Forums for Android!

Why can't I see my SD card files from my PC?

Discussion in 'Android Lounge' started by relztrah, Apr 9, 2018.

  1. relztrah

    relztrah Member
    Thread Starter
    Rank:
     #507
    Points:
    36
    Posts:
    51
    Joined:
    Jun 21, 2013

    Jun 21, 2013
    51
    9
    36
    Male
    With my old Moto E2 I simply connected the phone to my Windows 10 PC and I could see the internal storage and the SD card. With this Moto E4 running Android 7.1 I can see the phone from my PC, but it shows that this folder is empty. I've looked through all the settings on my phone and don't see anything that would prevent or allow me to see files when connected to the PC. There are several YouTube videos addressing this issue but none of them has a solution that works.
    [​IMG]
     

    Attached Files:


    Advertisement

  2. El Presidente

    El Presidente Beware The Milky Pirate!
    Moderator
    Rank:
     #5
    Points:
    3,118
    Posts:
    31,920
    Joined:
    Jan 3, 2011

    Jan 3, 2011
    31,920
    23,665
    3,118
    Scotland
    Have you set your SD Card as Adopted Storage?

    Also make sure your device is unlocked and you've ok'd any prompts that appear on your screen when you connect the phone to the PC.
     
    Bg260 likes this.
  3. lunatic59

    lunatic59 Moderati ergo sum
    Moderator
    Rank:
     #3
    Points:
    4,238
    Posts:
    35,683
    Joined:
    Jun 12, 2010

    Jun 12, 2010
    35,683
    32,371
    4,238
    Male
    IT
    Pennsylvania
    With Android 6, the default setting for USB connections is "charge only" mode. Windows 10 will detect the device but not allow access to files. On your phone when plugged in you should see the USB icon in the notification bar. Open notifications and tap on that and you should see USB options. Choose file transfer or MTP mode and your files should then be accessible.
     
    Bg260 and El Presidente like this.
  4. relztrah

    relztrah Member
    Thread Starter
    Rank:
     #507
    Points:
    36
    Posts:
    51
    Joined:
    Jun 21, 2013

    Jun 21, 2013
    51
    9
    36
    Male
    I knew I could find an answer here. Thanks a million. Yes, there's a setting on the phone that allows transfer of files that wasn't on my E2.

    usb connection.jpg

    Thanks again.
     
    Stuntman, El Presidente and lunatic59 like this.
  5. lunatic59

    lunatic59 Moderati ergo sum
    Moderator
    Rank:
     #3
    Points:
    4,238
    Posts:
    35,683
    Joined:
    Jun 12, 2010

    Jun 12, 2010
    35,683
    32,371
    4,238
    Male
    IT
    Pennsylvania
    Be advised that this is not a 'sticky' setting in many phones and you may have to set it each time you plug in USB.
     
    El Presidente and LV426 like this.
  6. relztrah

    relztrah Member
    Thread Starter
    Rank:
     #507
    Points:
    36
    Posts:
    51
    Joined:
    Jun 21, 2013

    Jun 21, 2013
    51
    9
    36
    Male
    And in fact I did have to enter it again. But at least it works for which I'm grateful.
     

Share This Page

Loading...