1. Check out our app, Forums for Android! Download and leave feedback here!

Root Why do all Froyo roms sound terrible over bluetooth?

Discussion in 'Android Devices' started by althornin, Jul 14, 2010.

  1. althornin

    althornin Active Member
    Thread Starter
    15

    Apr 29, 2010
    25
    0
    15
    I use Slacker and Pandora every day in my car on the ride to and from work, via bluetooth.
    Every Froyo rom I've tried (CM 6 alpha, the straight FRF57, FRF84, etc) sounds terrible.

    Its like the highs and lows are WAY overboosted and distorted.

    Because this has been common to every rom I've tried to date, and it is always fixed by reverting to my rooted 2.1, I usually do that.
    But I'm tired of missing out on flash and chrome-to-phone. Is there a sound fix?
     

    Advertisement

  2. althornin

    althornin Active Member
    Thread Starter
    15

    Apr 29, 2010
    25
    0
    15
    So is it just me, or do other people experience this also?
     
  3. gnath9

    gnath9 Well-Known Member
    63

    Jun 18, 2010
    418
    43
    63
    I have not tried yet but, I do own the Moto S9HD's so I just might have to charge them up tonight :)
     
  4. stad

    stad Member
    15

    Jul 8, 2010
    13
    0
    15
    Financial Analyst
    San Jose, CA
    I had that problem too.. It seems to have gone away though. Have you wiped when you installed the new ROM?
     
  5. s4eric

    s4eric Member
    15

    Apr 6, 2010
    11
    0
    15
    Wisconsin
  6. joshjunior

    joshjunior Member
    15

    Apr 28, 2010
    12
    0
    15
    i'm runnin bb.4 i dont bluetooth to my stereo but bluetooth phone calls sound just the same as before root. pandora straight from my phone sounds the same as well
     
  7. randallman

    randallman Active Member
    16

    Jul 13, 2010
    33
    1
    16
    Issue 9308 - android - eaac+ and aac+ decoding sound quality problems (Android 2.2) - Project Hosting on Google Code

    This appears to be related to extended AAC decoding. The bug reporter clearly has a grasp on the details that I do not have, but the bottom line is that the streams from pandora et al. arent being decoded well... We're lucky it works at all I suppose :)
     
    WarMace likes this.
  8. althornin

    althornin Active Member
    Thread Starter
    15

    Apr 29, 2010
    25
    0
    15
    Yeah, I wipe properly (both with ROMS and in real life, lol).

    Thanks for the good info guys, I hadn't managed to find any threads about it, and I was wondering if it was just me.

    I saw one post in a thread on Chevy's SS 4.4 that said audio in pandora was fixed. He is using FRF91, I wonder if that fixes it?
    I may just have to give it a shot...

    But according to the official bug report, its still broken in FRF91
     

Share This Page

Loading...