1. Check out our companion app, Forums for Android! Download from Google Play

Support Why does the screen brightness go dim when I browse the Internet?

Discussion in 'Android Devices' started by torontokid, Jul 4, 2012.

  1. torontokid

    torontokid Member
    Thread Starter
    16

    Jul 4, 2012
    21
    3
    16
    My S3 is set to full brightness mode, and the desktop screens and apps project nice and brightly. However, when I go to any website, the screen autmoatically goes pretty dim, and I can't find a setting to change this? I'd like the brightness to remain as vivid as it is when I'm on the home screen. What gives?
     

    Advertisement

  2. colnago

    colnago Well-Known Member
    243

    Nov 17, 2009
    3,091
    218
    243
    If the S3 is like the Note in this regard, the browser's brightness setting is managed independently from the general screen brightness. Try pressing the menu key with the browser open, to access the browser's brightness setting:


    [​IMG]
     
  3. NightxFall

    NightxFall Well-Known Member
    53

    Mar 31, 2012
    301
    67
    53
    I noticed this when I tried out the phone as well. Its damn annoying
     
  4. Geordie Ahmed

    Geordie Ahmed Well-Known Member
    16

    Jun 9, 2010
    86
    7
    16
    The brightness on the browser has its own control

    Next time you open the browser, hit the menu button and then scroll down until you see the option for brightness and colors, then change it to what suits you

    [​IMG]
     
    ricketstown likes this.
  5. torontokid

    torontokid Member
    Thread Starter
    16

    Jul 4, 2012
    21
    3
    16
    Thanks that was very helpful, but this has now created a new problem. Everytime I close the browser and re-open it, it automatically goes to level 3 power-saving - which keeps the brightness dim (albeit brighter than before). Any idea how to keep it set to default or Level 1?

    [​IMG]

    [​IMG]
     
  6. torontokid

    torontokid Member
    Thread Starter
    16

    Jul 4, 2012
    21
    3
    16
    Ahh, I figured it out. If you have Power Saving enabled in your home settings, it will override the browser brightness to level 3. So if you disable power saving, the browser will retain the power level you set it too.
     
    Bexy and fahady2f like this.
  7. SCobert

    SCobert New Member
    5

    Aug 12, 2012
    1
    0
    5
    Thank you for the advice. This totally improved my screen view.
     
  8. RoarOfZonda

    RoarOfZonda Well-Known Member
    16

    Jul 25, 2012
    53
    3
    16
    Get Dolphin Browser IMO. It's muchh better
     
  9. Ron H

    Ron H Well-Known Member
    38

    Nov 26, 2010
    233
    21
    38
    How do you set the brightness setting (as described above) in Dolphin Browser?
     
  10. Sandroidfan

    Sandroidfan Well-Known Member
    163

    Jul 11, 2011
    2,150
    483
    163
    Male
    Engineer
    Central TX
    Dolphin and other non-stock browsers don't have its own brightness setting. It will just use the brightness from the display setting in basic settings.
     
    Ron H likes this.
  11. Sandroidfan

    Sandroidfan Well-Known Member
    163

    Jul 11, 2011
    2,150
    483
    163
    Male
    Engineer
    Central TX
    You can probably uncheck brightness, color options in power save mode and still use the stock browser with its internal brightness setting, power save on.
     
  12. ceva321

    ceva321 Well-Known Member
    113

    thanks i was having the same issue it was driving me crazy !!! LOL
     
  13. Nicole_Le

    Nicole_Le New Member
    5

    Oct 20, 2012
    1
    0
    5
    Hello, I did the same step that you guide; however, i don't know somehow my internet browser doesn't have the brightness adjustment on the menu. Can you know me how to get that back?
    Thanks a lot
     
  14. rborelli

    rborelli Well-Known Member
    58

    Mar 22, 2011
    108
    11
    58
    MA
    Mine does not either.

    Bob
     
  15. racer88

    racer88 Well-Known Member
    36

    Oct 5, 2012
    55
    4
    36
    Milky Way Galaxy
    That's what I thought, until I realized that the menu extends down beyond the bottom of the screen. Just scroll down the menu, and you'll find the brightness setting. :)
     
    pseudandry likes this.
  16. johnnylighton

    johnnylighton Well-Known Member
    38

    Sep 22, 2012
    112
    12
    38
    So Cal
    Thanks for the suggestion, but we've tried that. It's just not there anymore.
     
  17. icenet

    icenet Member
    26

    Jul 11, 2012
    5
    1
    26
    Transportation
    Ontario Canada
    Had the same problem it was the browser. No matter the adjustments made to the brightnes control the home screen stayed bright and as soon as I went on the web it would dim.
    I went to setup, applications, running, find internet icon, clear cache and data. Note: you will lose your bookmarks so write them down or back-up.
    This worked for me.

    The second option is, download chrome browser for android from play store. This works as well.
     
    johnnylighton likes this.
  18. johnnylighton

    johnnylighton Well-Known Member
    38

    Sep 22, 2012
    112
    12
    38
    So Cal
    Solved - Thanks icenet! I had tried this before and it didn't work, but it worked for you so I tried it again. Maybe the first time I had just cleared the cache and not the data. :)
     
  19. dllorenzo313

    dllorenzo313 Member
    5

    Nov 17, 2010
    7
    0
    5
    Female
    Detroit, MI USA
    I have scrolled to the bottom of my internet menu and there is no brighteness/ colours (or the like) option. Nothing is in settings. I cleared the cache and data and still nothing.

    Are you all in the US or Europe? Also are you running ICS or JB? I am in the US w AT&T and have ICS (rumor is JB this week).

    Thanks.
     
  20. dwaded

    dwaded Member
    16

    Feb 3, 2011
    13
    2
    16
    Im on AT&T and I couldn't find the setting in the internet menu either.

    I did however find it in phone's main Settings: Power Saving: Background color.
    Uncheck it and it won't dim the internet browser (to save power).
     
  21. johnnylighton

    johnnylighton Well-Known Member
    38

    Sep 22, 2012
    112
    12
    38
    So Cal
    My dim browser finally reset the SECOND time I cleared the cache and the data in the app settings (Settings - Application Manager - All - Internet).
     
  22. ceva321

    ceva321 Well-Known Member
    113

    I downloaded it and I love it!!! thanks :)
     
  23. jmoesta

    jmoesta New Member
    5

    Nov 15, 2012
    1
    0
    5
    I have a GS3 through C-Spire and the 'brightness and coloring' option does not exsist in the menu. I vaguely remember when I first got the phone I came across a way to dim or not dim the browser screen but for the life of me I can not find that option again. The dimming is really annoying. Any guidance would be welcome.
     
  24. fahady2f

    fahady2f New Member
    5

    Dec 5, 2011
    1
    0
    5
    Chicago
    Man..... this really helps. I was having the same problem that brightness on my Galaxy Note 2 was going dim even with full brightness selected in options. You were right Power Saving was accidently got on. Once thats off its fine now. THANK YOU.
     
  25. Lyn16Lyn

    Lyn16Lyn New Member
    5

    Dec 14, 2012
    3
    0
    5
    To stop the screen from going dim when browsing the internet on the Samsung Galaxy Note 2, simply go to Settings ^ Power Saving Mode, then deselect Background Color only. You do not need to turn off Power Saving Mode completely as some have suggested--though it does take care of the problem.
     

Share This Page

Loading...