1. Download our Official Android App: Forums for Android!

Support Why will my Samsung Galaxy S2 not connect to home wifi??

Discussion in 'Android Devices' started by roisinbg, Jul 5, 2011.

  1. babsy01

    babsy01 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    4
    Joined:
    Jul 20, 2011

    Jul 20, 2011
    4
    0
    5

    my phone worked perfectly through my DLINK wifi with ap's, until the moment my phone number carried over to vodafone au??? now its not working tried static ip adress ect. exactly the same as in vid. Had my phone unlocked from vodafone didn't help??????
     

    Advertisement

  2. icedtea

    icedtea Android Enthusiast
    Rank:
    None
    Points:
    38
    Posts:
    304
    Joined:
    Jul 20, 2011

    Jul 20, 2011
    304
    11
    38
    Male
    using win7. configured internet sharing (got no router or usb adapter) my other laptop sees the hotstpot (laptop where the internet is) but SGS2 cannot find it :(

    used WPA security as well. . .
     
  3. babsy01

    babsy01 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    4
    Joined:
    Jul 20, 2011

    Jul 20, 2011
    4
    0
    5
    there is clearly a fault with the phone, i have never had so much trouble with anything. i brought a printer and it just worked!!! as with my TV,BLU-RAY,LAPTOP,PC,iPHONE,NOKIA,Wii,PS3!!! Static wont work either??? tryed putting in ip same as another device and it said not connected, put back on proper settings connected! but wont work!!!! WHOULD MAKE FORE A GREAT SKIPPING STONE IN MY LOCAL LAKE!!!!! Have latest softwere/firmware. Poor effort samsung :-(
     
  4. babsy01

    babsy01 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    4
    Joined:
    Jul 20, 2011

    Jul 20, 2011
    4
    0
    5
    rang samsung and i did a factory data reset, working for now! i was informed of softwere issues and hand set needs to be sent to be repaired if reset didn't work.
     
  5. icedtea

    icedtea Android Enthusiast
    Rank:
    None
    Points:
    38
    Posts:
    304
    Joined:
    Jul 20, 2011

    Jul 20, 2011
    304
    11
    38
    Male
    my S2's wifi has connected to my officemate's phone. . .i think the problem is the sharing from my laptop. . :)

    first time wifi user here (using S2) sorry for that ;)
     
  6. Junk10

    Junk10 Lurker
    Rank:
    None
    Points:
    6
    Posts:
    8
    Joined:
    Jul 6, 2011

    Jul 6, 2011
    8
    1
    6
    Australia
    Hi Everyone
    I received a new handset on Thursday and had a similar problems with limited or no wifi connection.
    I updated the firmware, which did help a lot.
    I also downloaded various wifi apps that identified the signals and a wifi fixer that locked the signal, band 11 that helped a lot.
    I purchased the best Netgear N300 Duel Band Modem Router and the phone is flying all the wifi apps have been removed and I can use it half way down the street.
    Unfortunately all my neighbors now live in my wifi shadow.
    The SGS2 has a very poor wifi reception compared to all my other devices and if it was not for the overall appeal of the device I would of returned it rather than accommodating it with expensive new wifi upgrades.
    I thank the eclipse_mint team at eBay for their time, patience and effort.
    Samsung please note the GS2 has very poor wifi reception
     
  7. icedtea

    icedtea Android Enthusiast
    Rank:
    None
    Points:
    38
    Posts:
    304
    Joined:
    Jul 20, 2011

    Jul 20, 2011
    304
    11
    38
    Male
    hey guys, any recommended wifi status widget? :)
     
  8. sloanetce

    sloanetce Lurker
    Rank:
    None
    Points:
    5
    Posts:
    3
    Joined:
    Jul 25, 2011

    Jul 25, 2011
    3
    0
    5
    There is the same problem with SG the old model. I have just bought one with Froyo 2.2 and I can not connect to WiFi. I used Factory data reset and the phone worked for 2 days. But it does not work anymore. I thing Samsung has a problem wityh Wifi not only a model like SG2.
     
  9. spurl

    spurl Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Aug 6, 2011

    Aug 6, 2011
    1
    0
    5
    I too had problems connecting to wi-fi on a sky router. It would just not accept my password even though it was correct. I eventually got it to work by entering the password using capital letters instead of lowercase. It could be something as easy as this instead of getting all technical about it.
     
  10. Demonsfc

    Demonsfc Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Sep 5, 2011

    Sep 5, 2011
    1
    0
    5
    Thanks for the tip to use dd-wrt firmware. Could not do a thing previously. Could connect to my WLAN but no WAN on my WRT54GL router. After changing the router's firmware from stock, my GS2 connected the first time and I have no problems since. Cheers :-D
     
  11. martytarty

    martytarty Well-Known Member
    Rank:
    None
    Points:
    16
    Posts:
    88
    Joined:
    Jan 19, 2011

    Jan 19, 2011
    88
    8
    16
    Just incase anyone has more issues with wifi not connecting try going to router settings and simply change
    the channel, pick a channel between 1 and 11 (assuming your router has these settings) then all should work again
     
  12. Slug

    Slug Check six!
    VIP Member
    Rank:
    None
    Points:
    2,043
    Posts:
    20,541
    Joined:
    Aug 1, 2009

    Aug 1, 2009
    20,541
    16,964
    2,043
    Male
    Mobile phone retail
    Inverness, UK
    If you're in the UK/Europe then your router should have 13 to pick from.
     
  13. MrBumtrinket

    MrBumtrinket Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Sep 27, 2011

    Sep 27, 2011
    1
    0
    5
    Hi! I am not really good with technology and gadgets. Hence, I couldn't follow your suggestion. Is there a way you could help me out with your suggestion? I tried finding how one does the AES encryption thing on the internet but couldn't find it. Would be great if you could help me out.
     
  14. Slug

    Slug Check six!
    VIP Member
    Rank:
    None
    Points:
    2,043
    Posts:
    20,541
    Joined:
    Aug 1, 2009

    Aug 1, 2009
    20,541
    16,964
    2,043
    Male
    Mobile phone retail
    Inverness, UK
    It's a setting in the wireless config for your router.
     
  15. Cheese55

    Cheese55 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Sep 30, 2011

    Sep 30, 2011
    1
    0
    5
    bij mij was het opgelost toen ik met hoofdletters WPA2 key invoerde.
    hoop dat je hier iest aan hebt. greets.
     
  16. Phenomenons

    Phenomenons Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Oct 7, 2011

    Oct 7, 2011
    1
    0
    5
    Folks,

    I have somehow a same problem. My GS2 can connect to my home router but I can connect to internet VERY DIFFICULTLY. it means it get the error of " can not communicate with server" and may be within 10 trialas i can connect to a website 1 time if i am luck. this is while my signal is full. i've try it in out side with other wifi's and it is ok. also i try a galaxy s at home where it was connevting to any website wery quickly while mine was turning around to find the error. I'm confused what is the source of this pain!

    Any idea?
    Cheers
     
  17. devenster

    devenster Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Oct 19, 2011

    Oct 19, 2011
    1
    0
    5
    Hi
    I am using a wifi without any encryption.But I am not able to connect to the wifi..it says connecting...obtaining ip address... remembered..disabled,Any ideas?
     
  18. icedtea

    icedtea Android Enthusiast
    Rank:
    None
    Points:
    38
    Posts:
    304
    Joined:
    Jul 20, 2011

    Jul 20, 2011
    304
    11
    38
    Male
    i think S2 have issues regarding adhoc connections. .. :( same setup with mine. .with OR without password encryption
     
  19. Galaxygall1991

    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Nov 2, 2011

    Nov 2, 2011
    2
    0
    5
    Hi there,

    I was just using my Samsung Galaxy S with Wifi, when out of the blue it stiopped working and shut down on me (The Wifi)

    I checked my router which was fine, then tried turning my wi-fi on my phone back on, after 5 seconds a message on my phone came up sayin

    'Unable to scan devices'

    I tried connecting my phone to the router with the WPS button Connection, but due to the wifi automatically turning it self off, this didnt work.

    I have turned my phone off for up to 20 mins and still nothing.

    I dont understand why this is happening, and due to work life i need the internet on my phone for e-mails to come through.

    My wifi has never done this before and now wont even turn on for a long enough time to scan properly, even though i stand the phone right next to and away from the router.

    Please Please can some one help me!!
     
  20. angielicious

    angielicious Lurker
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Nov 3, 2011

    Nov 3, 2011
    2
    0
    5
    HI. My encryption is already under AES. I wanted to try changing it to change it back but it does have a drop down arrow like others so there's not way I can change the encryption? What should the authentification be?

    I restored my phone to factory default as I just got it yesterday and it connects fine to public wifi and the shop's private wifi. I have no idea why it's only MY HOME wifi that the phone can't even detect. Please help. this is driving me nuts.
     
  21. angielicious

    angielicious Lurker
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Nov 3, 2011

    Nov 3, 2011
    2
    0
    5
    HI. I finally got connected and all I did was change my SSID =.= Less technical than going through my whole router setup. Hope my connection stays and hope you guys with problems can finally resolve this. I had this problem for less than 24 hours and I couldn't sleep nor eat.
     
  22. wiztrail

    wiztrail Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Nov 3, 2011

    Nov 3, 2011
    1
    0
    5
    As slug suggested (#5), switching encryption protocol from WEP to WPA2 sorted it out.
    Probably the SG2 does not cover properly the more basic security options... (all other phones and computers were using the previous encryption easily and flawlessly. so it points back to samsung. pity but solvable.
     
  23. Slug

    Slug Check six!
    VIP Member
    Rank:
    None
    Points:
    2,043
    Posts:
    20,541
    Joined:
    Aug 1, 2009

    Aug 1, 2009
    20,541
    16,964
    2,043
    Male
    Mobile phone retail
    Inverness, UK
    WEP is no longer considered secure, so moving to an authentication protocol that offers more secure encryption is actually a good thing. :)
     
  24. tscho

    tscho Lurker
    Rank:
    None
    Points:
    5
    Posts:
    3
    Joined:
    Nov 4, 2011

    Nov 4, 2011
    3
    0
    5
    I am having same issue - can connect at friends' houses etc but not at home. I used to be able to connect fine then one day it just stopped.

    I have tried changing the SSID as previously suggested, I've changed the router's security to WPA instead of WEP, any other ideas?

    Its a netgear router.

    Thanks


    UPDATE: Just checked router config and it has recognised my phone's mac address is connected, but still can't obtain IP address...
     
  25. Slug

    Slug Check six!
    VIP Member
    Rank:
    None
    Points:
    2,043
    Posts:
    20,541
    Joined:
    Aug 1, 2009

    Aug 1, 2009
    20,541
    16,964
    2,043
    Male
    Mobile phone retail
    Inverness, UK
    Check that the router is acting as a DHCP server to the network, that its MAC address has been added to the access control list (if using MAC filtering) and that wireless encryption is set to AES.

    If all that checks out and the problem persists, try restarting the router to reset its routing table and force it to issue new IP leases to connected devices.
     

Share This Page

Loading...