1. Check out our companion app, Forums for Android! Download from Google Play

why won't DDMS launch for me ?

Discussion in 'Android Apps & Games' started by gwcaton, Jun 19, 2010.

  1. gwcaton

    gwcaton Well-Known Member
    Thread Starter

    Apr 25, 2010
    I have searched and searched for help and am not finding anything. Well i take that back I have found countless guides on how to do it. tried many of them, didn't work, deleted everything, tried another , didn't work so now I am asking for help. LOL

    I am trying to do screen captures using the SDK and eclipse and whatever else the guides say to download.

    Whenever i double click the ddms file a command box flashes up on the screen for a split second and thats it . Can't go any further if the commab box won't stay up. I think a windows window is supposed to pop up after that so I can choose my phone.

    I am using Vista ( 64 bit I believe ) on a TouchSmart pc. My phone is a Mytouch 3g

    any help appreciated.


  2. kevin@teslacoilsw

    kevin@teslacoilsw Well-Known Member

    Jun 13, 2010
    WidgetLocker developer
    If you are already running eclipes, then DDMS can't talk to the device because eclipse already is. You can try quitting eclipse and then opening ddms, or you can use DDMS embedded in eclipse. To do that in eclipse go to Windows > Show View > Other > Android > Devices then you should get a new tab down with Problems and Console named "Devices". Click on it and then click on the screen shot icon on the right.
    gwcaton likes this.
  3. gwcaton

    gwcaton Well-Known Member
    Thread Starter

    Apr 25, 2010

    Thank You ! I knew it had to be something "easy" LOL I laugh because nothing is "easy" for me when it comes to this type of thing the first time. But I'm getting there with the help of people like you.

    I'm off to play and maybe post some screen shots .

    Thanks !
  4. RocknSteve

    RocknSteve Well-Known Member

    Jan 8, 2010
    I was having the exact same problem. However, doing it through Eclipse as opposed to the Command Prompt did work.

    When trying to do it via the Command Prompt, it'd popup for a split second (like you said) and disappear. I was able to take a screenshot of my screen for the split second the prompt window was open and this is what it read:

    (The ">>>" are just to indent the lines. They weren't actually there.)

    29:57 E/ddms: shutting down due to uncaught exception
    29:57 E/ddms: java.lang.Error: Cannot load javax.swing.plaf.nimbus.NimbusLookAndFeel

    >>>at javax.swing.UIManager.initializeDefaultLAF<Unkown Source>
    >>>at [other such lines starting with "javax.swingUIManager"]
    >>>at [lines starting with "org.jfree.chart"]
    >>>at [lines starting with "com.android.ddmulib"]
    >>>at [lines starting with "com.android.ddms"]

    Not sure if that's enough information but any insight would be appreciated!

Share This Page