1. Are you ready for the Galaxy S20? Here is everything we know so far!

WI-FI connection problems using a Linksys Range Expander

Discussion in 'Android Devices' started by the.rebel.agent, Dec 25, 2009.

  1. the.rebel.agent

    Thread Starter

    Hello guys, this is my first post. I am from Argentina and I recently bought a Motorola Milstone locally. The phone seems to have a problem to get a valid wi-fi connection when I use a Wireless-G Range Expander WRE54G ver. 3. Anybody having the same problem? There is no problem for the phone connecting it directly to the access point. I am using DHCP by the way and no security encryption, only MAC address filter.

    1. Download the Forums for Android™ app!


  2. amacuk

    amacuk Lurker

    Hi Mr Rebel,

    I have exactly the same situation, Milestone and Linksys WRE54G. My Milestone would connect (associate) with the Linksys but could not obtain an IP address or get out to the internet. To be honest it was a new extender and even my laptop had trouble doing it too - I am therefore not sure it is related to the Milestone.

    The linksys forums are full of people who have had trouble with this extender. I have resolved to send it back to Amazon today as I totally frustrated with configuring it properly but suffering loads of issues. Seems we're not alone looking at the forums though.

    Good luck.
  3. the.rebel.agent

    Thread Starter

    Actually, I have my laptop and Wii connected to the Range Expander, even a print server from Linksys. Only device not working is the Milstone.:mad:
  4. the.rebel.agent

    Thread Starter

    I tested another Milstone phone and did not work. So, basically it a phone/os/hardware bug?
  5. ade

    ade Lurker

    Wifi is not working particularly well for me. It's working now, but there's a delay from requesting a webpage until it starts loading...

    It was not working at all before, i had to change a setting, that turned off wifi when the display is sleeping (I set it to "never"). Now it's better.

    using a brand new d-link dir 855 that works perfectly otherwise.
  6. the.rebel.agent

    Thread Starter

    Tried G and mixed and nothing. Tested another access point and did work. It seems that won
  7. NicodeVries

    NicodeVries Lurker

    I am having similar problems with a G1 and a Ruckus MM2211 repeater. It seems Android has problems with repeaters. Perhaps repeaters are configured for the way Windows usually connects to Wifi routers.

    When I look with WifiScanner (WiFi Scanner v1.6 Application for Android | Tools) I noticed that both the router and the repeater are shown seperately with the same name but with a different MAC address. Perhaps this somehow confuses Android.

    I found a workaround which works. When I configure the Ruckus to create a separate network instead of repeating the existing one I can connect to it with the G1. Not really a solution I like but at least it allows me to extend the range.

    Anyone else found a better solution yet?
  8. NicodeVries

    NicodeVries Lurker

    I tried chatting with Ruckus:

    Code (Text):
    1. You are now chatting with 'David' David: Hi and welcome to Ruckus Wireless.  Did you have a question?
    2.  Nico de Vries: Hello David.
    3.  Nico de Vries: I just got a MM2211, however it does not seem to work with Android phones. Is this perhaps a known problem?
    4.  Nico de Vries: It works fine with laptops etc.
    5.  David: we haven't heard this before...
    6.  David: it's strictly a wi-fi device
    7.  Nico de Vries: Somehow the phone does connect to the router but not to the repeater. I noticed other people having similar problems: http://androidforums.com/motorola-milestone/30488-wi-fi-connection-problems-using-linksys-range-expander.html
    8.  David: i'll look into it and ask our developers
    9.  Nico de Vries: Thank you.
    10.  Chat session has been terminated by the site operator.
  9. the.rebel.agent

    Thread Starter

    That could explain the problem. Let
  10. the.rebel.agent

    Thread Starter

    Did try a lot of stuff and nothing. Hope Google fix this bug for the next update. :(
  11. the.rebel.agent

    Thread Starter

    BUMP. any news on this?
  12. valleysboy

    valleysboy Lurker

    I have a fairly old Sitecom wireless extender (WL-130), and my Milestone connects to it (and the internet) with no problems. It would seem this isn't a generic Android/Extender issue.

    Hope that helps....
  13. lilleyen

    lilleyen Newbie

    I'm using a D-Link extreme N router with a Hawking N extender.
    They show up as two different networks for some reason.

    I can connect to either one with my Milestone, no problem.
    It tends to default to the one with the stronger signal, which is usually the Hawking one, unless there are other issues at the time.
  14. mixpix

    mixpix Well-Known Member

    I'm using a Linksys WAP54G Access Point/Extender with no issues.

    Does it work if you turn off MAC filtering?
    Do you have speed boost options on the extender or main router? Might want to turn them off and test it.
  15. lilleyen

    lilleyen Newbie

    Sort of a side issue, but it might have a bearing on your problem.

    I recently hooked up WD TV Live unit to my TV with a hard drive etc.
    It's supposed to enable WIFIinternet to the TV with a USB WIFI dongle insertedinto the WD unit.

    When it didn't work (not recognized), with my D-Link Extreme N setup, I contacted the manufacturer.
    They replied that they didn't yet have a firmware update ready for my WD unit that included drivers for this router and USB dongle.

    Could this be related to your problem, maybe your router or range extender is just not on their list yet?

    Or maybe it is the MAC filtering, as suggested by mixfix.
    I had to go into my router setup and add my Milestones MAC address to the list before it would connect.
  16. devtig

    devtig Lurker

    Same problem with my Motorola Milestone. I have no problem connecting with my Motorola Milestone to my Linksys router WRT54GL (with WPA encryption) when my Linksys expander WRE54G is turned off or when the Expander's signal is weaker the my router's signal.

    But, the moment I turn on my Expander AND the wireless signal from it is stronger than the wireless signal of my Router AND I start my wireless connection on my Motorola MileStone, then I cannot connect to the internet with it. With Wifi Analyzer (Version 31) I see my SSID 2 times. When I am closer to my Expander, PhoneInfo (version 5) reports: no internet connection and no internet IP, but it has gotten an network ip from dhcp. Can't browse the internet.

    Now, I just walked to my Router. I resetted wireless on my Motorola and now I am connected to the internet, because when I now check with PhoneInfo, I get an internet IP and i can browse the internet.

    Now, I walked back to my Expander with my Wifi Analyzer on. I see the signal strengths swap. Now my Expander signal is stronger again, but my internet connection keeps working, because my Motorola stays connected to the Router who's signal is still strong enough. PhoneInfo still reports an internet IP and i can browse the internet.

    Now, still sitting close to my Expander, I resetted the Wireless connection on my Motorola. Obtaining IP address... Connected! And, as expected, PhoneInfo reports No Internet IP and I can't browse the internet.

    My laptops work perfectly with my expander.

    I hope the dev's read this. It's very reproducable.
  17. Hey there,

    I have the same problem. I'm using a Motorola Milestone with Android 2.1
    and a Linksys Wireless G Range Expander WRE54G.

    There were no problems connecting to the router. Connecting to Expander only worked after switching phone and expander off a couple of times. The connection was established, but still browsing the internet is impossible.

    Tried to set the WLAN to manual IP, gateway, subnet mask, DNS etc... the result, the phone connects immediately with the expander, but still no internet. Also tried a couple of different DNS Servers, which I don't think makes any difference ...

    Hope somebody has an answer for us "Expander" users :(
  18. devtig

    devtig Lurker

    Sounds very similar.

    Can anybody report having successfully connected with the internet using a Motorla Milestone through a WRE54G?
  19. Smithers

    Smithers Newbie

    Jep, me. Had a similar problem with LANCOM and Linksys routers, my phone would connect to a network but not transmit data. Here goes the solution that may be helpful for you too:

    A Milestone will connect & work if you manually define the IP data, i.e. specify an IP address, Gateway (which is the router that normally assigns the DHCP) and DNS server (use google and for instance). Then it'll work. My phone received the credentials via DHCP which worked but wouldn't transmit any data for some reason. Manually defining those values helped. If it does not connect radiowise (i.e. no logical error but physical) try deactivating any standby or low power settings. This used to cause problems with NOKIA phones in the past.

    PS: There is an app called wifi static that is able to set predefined sets of IP/Gateway/DNS data for specific WiFi networks automatically, perfect.


    My website: Handyortung kostenlos - My phone: Milestone - My OS: Android 2.1
  20. MadEyeBall

    MadEyeBall Lurker

    Hey Guys,

    This is my first post here, and I'm glad i found this place!

    I've had a bit of trouble with my milestone when tying to conect with my D-link DI-524 router trough a DWL-G700AP set to repeater mode....

    From what i could find, what was happening is that with the DHCP server off on the repeater (but on on the router) the phone wasn't being able to get an IP address, but if you first connect to the router to get the IP and then connect to the repeater it will work, as long as the lease on this particular IP address does not expire (you can see it on the router's Dynamic DHCP Clients List linked to the phone MAC address)

    I'm not particularly savvy on networking, so if anyone can see if what i'm saying dosn't make sense or if i'm making any wrong assumptions here, please correct me where i'm wrong..

    thanks guys,
  21. astrolabe__67

    astrolabe__67 Lurker

    Same problem, WRE54G v Android 2.1, but different phone (Vodafone 845 - a.k.a. Huawei 8120, Huawei Joy)

    I also can connect to Router, but can't connect to Linksys Range Extender that runs off it (Laptop no problem),

    Message: Obtaining IP address from Linksys... then: Unsuccessful

    Does anyone know a resolution to this?

Motorola Milestone Forum

Features and specs are not yet known.

Release Date

Share This Page