1. Check out our companion app, Forums for Android! Download from Google Play

Support Wi-Fi just won't connect

Discussion in 'Android Devices' started by sillas999, Jun 14, 2011.

  1. sillas999

    sillas999 New Member
    Thread Starter

    Jun 14, 2011
    I'm not posting this on the specific device category because I think this issue belongs to the Android system itself and has nothing to do with my tablet.

    Hey guys, I have a Coby Kyros Tablet 7015A w/ Eclair Android 2.1, it's rooted, and has a bunch of apps installed. It seems to work perfectly, but my problem is actually with one particular wi-fi network. Not my home wi-fi, this one works flawlessly, but the problem is in my university's wi-fi, which kind of is the main reason why I bought the device: to use it in class.

    Here's the deal: The university's wi-fi is an OPEN network, which you can connect normally, but it has a login system which comes up once you try to open up any website on your browser. Well, the system worked pretty well until now, I can connect with my notebook and even with my java-based-system Samsung smartphone (S5620). The login page comes up like I was on a pc and I can connect.

    Obviously, the internet just doesn't work if you are not logged in. You can connect, but won't access anything.

    HOWEVER, sorry to take so long to get to the point, my Kyros won't connect to that network. I use wi-fi buddy app to manage my networks and when I press the "connect" button it tries to connect, but after a few seconds, the button just appears "pressable" again, like if I had done nothing. I can't even get to the browser because it says I'm just not connected. I already tried to connect through the settings too and the result is the same.

    I suspect this is a general Android issue with that kind of network, so I decided to ask you guys if you can help me. Any suggestions?

    Thanks a lot!


  2. sitlet


    Apr 11, 2010
    It's not an Android general issue, I connect to these networks all the time. It sounds like a problem with your knock-off tablet, or maybe because you are rooted.
  3. nickdalzell

    nickdalzell Well-Known Member

    Jun 17, 2011
    Owensboro, KY
    i hear of this happening on Droid phones, Samsung Fascinates and other Android devices, including the Archos and Nook. i don't know what it is. i cannot blame Android or the device but it seems common. my iPhone never has issues but my Kyros is a pain to get (and stay) online.

    EDIT: I have no problem at all with auto connecting and maintaining a connection via my wireless at home which uses a B/G router, but anything with an N seems to be rather selective on the Android. many would only connect after a few reboots only to boot you off after a few minutes. not sure what kinda wifi chip is in the tablet or if it supports N. i thought routers are supposed to offer B/G also if N is not there but it seems the N routers love N and nothing else.

Share This Page