1. Check out our companion app, Forums for Android! Download from Google Play

Wi-Fi not showing on handset

Discussion in 'Android Devices' started by Zorro, Dec 25, 2009.

  1. Zorro

    Zorro Member
    Thread Starter
    15

    Dec 25, 2009
    16
    0
    15
    West Midlands, UK
    Just got a new HTC Hero and on my wi-fi screen is showing a number of networks local to me that i could connect to, but not my home w-fi arrggghh!

    My wireless router is a Belkin N1 Vision that connects via my Virgin media ADSL cable provider.

    Thanks in advance for your help :)
     

    Advertisement

  2. michael_84

    michael_84 Well-Known Member
    16

    Oct 27, 2009
    62
    3
    16
    IT Techy
    Manchester, UK
    Is your WiFi box transmitting the SSID or is it hidden? If it is hidden then you will enter the network manually.

    Oh and another thought.. the N1 makes me think it's runs N standard WiFi... is it using N standard exclusively? I think the Hero only supports B/G so you would have to enable G standard on your Belkin box.
     
  3. Zorro

    Zorro Member
    Thread Starter
    15

    Dec 25, 2009
    16
    0
    15
    West Midlands, UK
    No its not hidden as it appears for my laptops and iPhone.

    Yes it is N series....will have to work out how to enable G series as you suggest.

    I would of thought that latest Hero would support latest wi-fi series?

    Thanks for prompt reply and Happy Christmas.
     
  4. CitizenErazed

    CitizenErazed Well-Known Member
    15

    Sep 24, 2009
    66
    0
    15
    London, UK
    N standard requires quite power-hungry chips, is my understanding. Very few mobile phones support it. Infact I can't actually think of any that do.
     
  5. michael_84

    michael_84 Well-Known Member
    16

    Oct 27, 2009
    62
    3
    16
    IT Techy
    Manchester, UK
    Nexus One is the only one I know that supports it... well that's according to Wikipedia...

    Just checked.. the iPhone only supports G standard so I can only think about changing channel, not tried channel 12-13 (europe only) on the Hero, it might not allow you to connect to them even if you have a UK phone.
     
  6. Zorro

    Zorro Member
    Thread Starter
    15

    Dec 25, 2009
    16
    0
    15
    West Midlands, UK
    ok, after finally finishing the turkey, here is my router wireless info


    Wireless Channel > 6
    Extension Channel > 2
    SSID > Belkin_N1_C3970E
    Wireless Mode > 11b + g + n
    Broadcast SSID > on
    Protected Mode > off
    Bandwidth > 20MHz + 40MHz auto


    so what do i change?

    btw, i'm based in UK and Hero is purchased on UK mobile network if that further info helps?

    thanks for support so far.
     
  7. michael_84

    michael_84 Well-Known Member
    16

    Oct 27, 2009
    62
    3
    16
    IT Techy
    Manchester, UK
    Maybe have a try switching to Channel1, your SSID doesn't contain any non-standard characters by any chance?
     
  8. Zorro

    Zorro Member
    Thread Starter
    15

    Dec 25, 2009
    16
    0
    15
    West Midlands, UK
    no idea what you mean by non-standard characters?

    is that SSID that says Belkin_N1_C3970E?

    which channel to change, Wireless channel to 1 or Extension channel?
     
  9. michael_84

    michael_84 Well-Known Member
    16

    Oct 27, 2009
    62
    3
    16
    IT Techy
    Manchester, UK
    Wonder if the length of the SSID is an issue... I would try changing the Wireless Channel first as this won't stop any existing devices from working.
     
  10. Zorro

    Zorro Member
    Thread Starter
    15

    Dec 25, 2009
    16
    0
    15
    West Midlands, UK
    sadly changing the wireless channel to 1 didn't work :(

    it auto changed the extension channel to 5
     
  11. michael_84

    michael_84 Well-Known Member
    16

    Oct 27, 2009
    62
    3
    16
    IT Techy
    Manchester, UK
    The only thing left for me to suggest is to try changing the SSID to something shorter.. (may I suggest fred?), this will stop other devices working for now.. but you can see if that fixes it, if not then just revert back to the default name again (Belkin something or other)
     
  12. Zorro

    Zorro Member
    Thread Starter
    15

    Dec 25, 2009
    16
    0
    15
    West Midlands, UK
    tried that and it didn't work :(

    i found an option on security setting for belkin called "guest", so i swithched that to on and as if by magic the router appeared on Hero options on wi-fi

    so i now have wi-fi connection at home! :D

    thanks for everyones comments and help, much appreciated and hope you all have a prosperous 2010!
     
  13. GlennT

    GlennT Member
    16

    Nov 19, 2009
    17
    1
    16
    retired
    south central MS
    I have a Belkin N wireless router and had the same problems.
    Do you have the option of changing "Wireless Mode > 11b + g + n"?
    I changed mine to "G" only and everything works fine. I did have to disable
    mobile network initially but after the phone connected and remembered the wifi network I enabled the mobile network again and all is OK.
    Hope this helps.
     
  14. Zorro

    Zorro Member
    Thread Starter
    15

    Dec 25, 2009
    16
    0
    15
    West Midlands, UK
    thanks for your help GlennT.

    my router wouldn't let me change to G only wireless, but i tried a "guest" option on router and allowed to me login via that connection.

    i have no idea why this works, but it works! :)
     
Tags:

Share This Page

Loading...