1. Check out our app, Forums for Android! Download and leave feedback here!

Wi-Fi problems

Discussion in 'Android Devices' started by marshall518, Feb 18, 2010.

  1. marshall518

    marshall518 Well-Known Member
    Thread Starter
    36

    Feb 10, 2010
    100
    5
    36
    So Cal USA!
    On my Hero I have Wi-Fi on and added to connections for automatic connect (home and work). Every time I go to those location the Wi-Fi doesn
     

    Advertisement

  2. marshall518

    marshall518 Well-Known Member
    Thread Starter
    36

    Feb 10, 2010
    100
    5
    36
    So Cal USA!
    Still having the Wi-Fi problems. Now it seems like my 3G is running slow, what should I do?

    Please help!
     
  3. Kelmar

    Kelmar Done by choice
    823

    Nov 28, 2009
    11,820
    4,751
    823
    Update your PRL. Power cycle your phone and see if the problem continues.
     
  4. Droidone

    Droidone Well-Known Member
    93

    Dec 12, 2009
    595
    118
    93
    I don't have the same wifi problem and I usually use my neighbors connection because he never set up a password. I notice that the wifi on the hero is not as fast as it should be. Even when I use my wifi connection from my computer. I wish there was a way to unthrottle to get full potential out of the connection. I hope 2.1 fixes it.
     
  5. marshall518

    marshall518 Well-Known Member
    Thread Starter
    36

    Feb 10, 2010
    100
    5
    36
    So Cal USA!
    I did what you recommended, but now when I try connecting to a web page it says
     
  6. Kelmar

    Kelmar Done by choice
    823

    Nov 28, 2009
    11,820
    4,751
    823
    At the top of your screen does it have a 1x or EV logo with bars on it or is that not showing up at all? WiFi logo or not.
     
  7. marshall518

    marshall518 Well-Known Member
    Thread Starter
    36

    Feb 10, 2010
    100
    5
    36
    So Cal USA!
    The connection error stopped. I
     
  8. Kelmar

    Kelmar Done by choice
    823

    Nov 28, 2009
    11,820
    4,751
    823
    Yes, you can do a factory reset without having to contact Sprint. I do not know if we get charged extra for data roaming check with sprint and let us know.

    Glad it's working now! :D
     
    marshall518 likes this.
  9. pwabbit

    pwabbit Well-Known Member
    78

    Oct 19, 2009
    502
    60
    78
    I have never been charged for data roaming. Only problem: Roaming is at it very slow 1X connection speeds.
     
  10. marshall518

    marshall518 Well-Known Member
    Thread Starter
    36

    Feb 10, 2010
    100
    5
    36
    So Cal USA!
    I checked and they said no roaming data charges! Roaming phone calls deduct from your 450 landline minutes! I still don
     
  11. Kelmar

    Kelmar Done by choice
    823

    Nov 28, 2009
    11,820
    4,751
    823
    You have it set to remember the network in your settings?

    Go Menu > Settings > Wireless Controls > Wifi Settings... click on the network you use all the time and see if it tells you to remember it or forget it. Try forgetting it then remembering it and see if that fixes it.

    3G connection may just be something to do with where you live and how busy the local tower(s) are..., but I couldn't tell you for sure.
     
  12. marshall518

    marshall518 Well-Known Member
    Thread Starter
    36

    Feb 10, 2010
    100
    5
    36
    So Cal USA!
    Both connections are remembered. Does the phone have a much weaker Wi-Fi card (or whatever) then a laptop? My phone is connected to the same Wi-Fi as my laptop then it just drops off and continues to scan for a Wi-Fi and never reconnects. What the heck? I
     
  13. Kelmar

    Kelmar Done by choice
    823

    Nov 28, 2009
    11,820
    4,751
    823
    Sounds like you've got a bad phone to me.
     
  14. marshall518

    marshall518 Well-Known Member
    Thread Starter
    36

    Feb 10, 2010
    100
    5
    36
    So Cal USA!
    Me to!

     
  15. Kelmar

    Kelmar Done by choice
    823

    Nov 28, 2009
    11,820
    4,751
    823
    Sprint should replace it... just take it to them and explain the problems.
     
  16. sprucebeach

    sprucebeach Well-Known Member
    16

    Nov 12, 2009
    73
    1
    16
    I'm having a different wi-fi problem. My laptop can find my wireless router even though I don't broadcast the SSID. (I turned broadcast on, connected, then turned it off.) I think it used to be that my Hero could too (after it had connected once) but now it can't connect unless I'm broadcasting the SSID. It remembers the password OK - it just isn't aware of the router unless I'm broadcasting the SSID. Is there a setting I'm missing?
     
  17. Kelmar

    Kelmar Done by choice
    823

    Nov 28, 2009
    11,820
    4,751
    823
    Try removing SSID and just filtering buy MAC address.
     
  18. sprucebeach

    sprucebeach Well-Known Member
    16

    Nov 12, 2009
    73
    1
    16
    Thanks. I'm doing that already. But I also want it to behave like my laptop and find the router even when I'm not broadcasting the SSID.
     
  19. marshall518

    marshall518 Well-Known Member
    Thread Starter
    36

    Feb 10, 2010
    100
    5
    36
    So Cal USA!
    Sprint replaced my phone no questions asked. I
     
  20. Kelmar

    Kelmar Done by choice
    823

    Nov 28, 2009
    11,820
    4,751
    823
    Just reconfirming you have the network set to remember, correct?

    Is your network hidden or anything? Try "wefi" from the market, it was something I had to use on all my old s60's to get them to auto connect (never used on android though so I'm not too familiar with how it'll work on the Hero).
     
  21. marshall518

    marshall518 Well-Known Member
    Thread Starter
    36

    Feb 10, 2010
    100
    5
    36
    So Cal USA!
    Yeah it
     
  22. Kelmar

    Kelmar Done by choice
    823

    Nov 28, 2009
    11,820
    4,751
    823
    When you toggle it with the widget does it connect automatically?
     
  23. marshall518

    marshall518 Well-Known Member
    Thread Starter
    36

    Feb 10, 2010
    100
    5
    36
    So Cal USA!
    Yeah, but is seems like it connects then drops off. I
     
  24. Kelmar

    Kelmar Done by choice
    823

    Nov 28, 2009
    11,820
    4,751
    823
    I've never left my WiFi on to see if it'll reconnect so I can't help there. I can confirm that WiFi on the Hero is slower than in my laptop though.
     
Tags:

Share This Page

Loading...