1. Download our Official Android App: Forums for Android!

Support Wi fi won't turn off on xperia x10

Discussion in 'Android Devices' started by Matt43, May 29, 2011.

  1. Matt43

    Matt43 Member
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    47
    Joined:
    Jun 24, 2010

    Jun 24, 2010
    47
    0
    15
    My Xperia X10 has been suffering from poor battery life for a while, and I've got an inkling of what the problem may be. Every few minutes I get a circular "refresh" type symbol at the top right of the screen, which I am led to believe is the wi-fi searching for a network. I never use wi fi on this phone but am struggling to disable it. I go to "Settings" and "Wi-fi settings" and turn it off, then within the hour it turns itself back on.

    Is there a way of turning the damn feature off and making it stay that way until I decide otherwise ???? Thanks
     

    Advertisement

  2. Bullitt_McQueen

    Bullitt_McQueen Well-Known Member
    Rank:
    None
    Points:
    38
    Posts:
    158
    Joined:
    May 5, 2010

    May 5, 2010
    158
    12
    38
    That icon is the sync icon. It means one or all of the accounts you have set up are syncing.

    Go into Settings > Accounts & Sync and have a look at the options you have checked. I have Background Data and Auto Sync checked relating to my Googlemail account at the bottom.

    What have you got?
     
    Matt43 likes this.
  3. alan_s

    alan_s Newbie
    Rank:
    None
    Points:
    36
    Posts:
    23
    Joined:
    May 25, 2011

    May 25, 2011
    23
    2
    36
    Bristol, UK
    As Bullitt say, this is the google mail and calendar synch icon. I suspect one of your downloaded apps is turning the wifi on, as with my X10 when I turn it off it does stay off! Finding out which one may be tricky, but you can start from market place, go into "my apps" and see if there are any network-based ones that may be doing this, eg a diagnostic utility.

    Alan
     
    Matt43 likes this.
  4. Matt43

    Matt43 Member
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    47
    Joined:
    Jun 24, 2010

    Jun 24, 2010
    47
    0
    15
    On the "Accounts & Sync" page, Background data and Auto sync are unchecked. I have three accounts, all of which say "Sync is OFF". I have checked "My Apps" from the marketplace, I have loads downloaded but cannot see an easy way to tell which one(s) might be overruling the wi-fi setting.
     
  5. alan_s

    alan_s Newbie
    Rank:
    None
    Points:
    36
    Posts:
    23
    Joined:
    May 25, 2011

    May 25, 2011
    23
    2
    36
    Bristol, UK
    Even stranger! So something is turning on sync as well as wifi!
     
  6. Bullitt_McQueen

    Bullitt_McQueen Well-Known Member
    Rank:
    None
    Points:
    38
    Posts:
    158
    Joined:
    May 5, 2010

    May 5, 2010
    158
    12
    38
    I guess the next thing to do is to check what services are running on your handset.

    Go to Settings > Applications > Running Services and list what's running. Use the grey bar as the heading and then list all the services. I'm no expert but someone might be able to see what the issue is.
     
    beau420 likes this.
  7. beau420

    beau420 Android Expert
    Rank:
    None
    Points:
    143
    Posts:
    1,104
    Joined:
    Nov 10, 2010

    Nov 10, 2010
    1,104
    173
    143
    Computer Guy
    Ottawa
    Good suggestion.

    If he still thinks it might be the WiFi...add a Power Control Widget where you can turn WiFi, Data, GPS, Screen Brightness on or off.

    Like Bullitt said...check running services....or download an app like Task Manager that will do the same thing, but I find it a little easier to look at.
     
    Matt43 likes this.

Share This Page

Loading...